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Technotes Index by Topic 

1. Most important Frequently Asked Questions  

#12637: Hottest Fontographer frequently asked questions  
Hottest Fontographer frequently asked questions Issue 1 "I upgraded from the Fontographer 4.1 
Macintosh floppy disk version (serial number is of the 111xxxx variety) to Fontographer 4.1.4 Macintosh 
on CD and I was not given a new serial 

#14314: Common questions about Fontographer  
Common questions about Fontographer   What are the main features and functions of Fontographer? 
What is the learning curve on Fontographer? What font formats can Fontographer create? Can 
Fontographer convert fonts from PostScript to 

#03702: Commonly asked questions  
Commonly asked questions How long has Fontographer been on the market? Since its introduction in 
1986, Fontographer has remained the industry-standard for font-creation software. What type of fonts 
does Fontographer generate? Fontographer 

#12207: Quick Tips for Fontographer  
Quick Tips for Fontographer Here are some fast and friendly tips for Fontographer users, courtesy of 
Macromedia Technical Support. 1 To change layers, click on the NAME of the layer (Outline, Template, 
Guides, Hints) in the Layers Palette 

#15928: Fontographer and OS X issues  
Fontographer and OS X issues This TechNote addresses several issues regarding Fontographer and 
Macintosh OS X, including: Running Fontographer in Classic mode on Macintosh OS X Installing a non-
FPU version of Fontographer on an OS X 

#03733: Fontographer 4.1 Windows issues  
Fontographer 4.1 Windows issues Top Issues The splash screen or toolbox icons do not display properly 
Can't perform a Save As on an old Fontographer database Windows 95 fonts won't open correctly with 
Windows 95 encoding Difficulties with 

#03707: Fontographer and RAM Optimization  
Fontographer and RAM Optimization Macintosh Fontographer uses a lot of RAM. When a font is opened, 
it is retained completely in RAM. A font database can easily exceed 500K. Solutions If you want to work 
on four fonts at once with several 

2. Installation, Latest Versions, Serial Numbers  

#12094: Fontographer 4.1.5 Release Notes  
Fontographer 4.1.5 Release Notes October 1, 1996 Welcome to Macromedia Fontographer 4.1.5 for 
Windows(TM)! If you run into a question and don't see the answer here, or in your documentation, then 
please examine the "4.1 TechNotes" 

#12069: Fontographer 4.1 release notes  
Fontographer 4.1 release notes February 25, 1996 Welcome to Macromedia Fontographer 4.1 for 
Windows(TM)! If you run into a question and don't see the answer here, or in your documentation, then 
please examine the "4.1 TechNotes" frequently 
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#12067: Fontographer 4 Release Notes  
Fontographer 4 Release Notes June 24, 1993 Welcome to Fontographer 4! Since we went to press with 
the User's Guide, we have come up with a few special notes we'd like you to be aware of. It is very 
helpful for you to read this document 

#03720: Where to find Fontographer Updaters  
Where to find Fontographer Updaters Issue Where can I find the latest update to my version of 
Fontographer? Solution Go to the Fontographer downloads page to download updaters. Here's the list: 
Macintosh Fontographer 4.1to4.1.3 Power 

#12597: Latest Versions of Fontographer  
Latest Versions of Fontographer PC Fontographer Windows Fontographer 3.5.2 Updater (Updates from 
3.5.0 and 3.5.1 available online) Windows Fontographer 3.5.2 Upgrade to 4.1.5 - $99 Windows 
Fontographer 4.1 Updater to 4.1.5 - Free upon 

#12564: Fontographer Mac/Win Serial Number Issues  
Fontographer Mac/Win Serial Number Issues PC Fontographer Windows Fontographer 3.5.2 Updater 
(Updates from 3.5.0 and 3.5.1 available online) Windows Fontographer 3.5.2 Upgrade to 4.1.5 - $99 
Windows Fontographer 4.1 Updater to 4.1.5 - Free 

#15290: Finding serial numbers  
Finding serial numbers How do I find my serial number? If the serial number for your product is missing, 
try the following: Look at the software packaging. If you purchased a boxed copy of software the 
number is located on your registration 

#15266: Installation on multiple machines  
Installation on multiple machines Can I install my software on more than one computer? Single user 
licenses vary slightly by product, so it is best to check the End User License Agreement for confirmation 
of installation information. The 

#16717: Purchase and Download FAQ  
Purchase and Download FAQ Pre-Purchase Frequently Asked Questions What is purchase and download? 
Can I order the software CD and manual to be sent to me in addition to downloading the product? How 
does purchase and download work? How long 

#15318: Missing serial number  
Missing serial number What do I do if the trial is requesting a serial number? Authorware 7, 
Fontographer, Director MX If your trial download was successful, but it is prompting you to enter a serial 
number, please uninstall the trial and 

#15282: Serial number not accepted  
Serial number not accepted My serial number won't work during installation or during product 
registration Most Macromedia serial numbers are 21 digits, beginning with three letters and followed by 
a series of numbers separated by dashes. 

#12336: Where to find Fontographer Updaters  
Where to find Fontographer Updaters Where can I find the latest update to my version of Fontographer? 
Go to the Fontographer Downloads area. Here's the list: Macintosh Fontographer 4.1 to 4.1.3 Power 
Macintosh updater Updates Fontographer 

3. Common Error Messages and Problems  
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#12339: Windows error messages in Fontographer 4.1  
Windows error messages in Fontographer 4.1 Error message "fontog.exe caused error in FONTG410.DLL" 
The error alert box may appear with the following error message: "This application has performed an 
illegal operation and will be shut down". 

#15709: Windows 30202 Error in Fontographer  
Windows 30202 Error in Fontographer Fontographer crashes with a -30202 error in Windows NT or 
Windows 2000 There have been a few reports of this error which we have not been able to reproduce. 
The only evidence that has surfaced is that the 

#12296: Macintosh Fontographer cannot open Windows font  
Macintosh Fontographer cannot open Windows font When attempting to open a Windows font file (PFB 
or TTF) located on a disk, an error message appears indicating "End of File -39." Either of the following 
reasons may cause this error message 

#03703: Out of Memory Errors in Fontographer for Windows  
Out of Memory Errors in Fontographer for Windows Issue: 1) Import a .bmp into Fontographer's Edit 
window to Autotrace and get an Out of Memory error. 2) Attempt to Autotrace the back ground image 
and get an Out of Memory error. Reason: The 

#03705: Error= -11501, Could not open file- unknown format  
Error= -11501, Could not open file- unknown format Issue: When trying to open a file in Fontographer 
4.x for the Mac, you get the error, "Could not open the file because it is in an unknown format error = -
11501" Reason: Trying to open the 

#13719: Missing FPU error message  
Missing FPU error message Issue "Missing FPU" message is displayed when installing Fontographer 4.0.x 
to a Power PC. Reason This msg is caused by installing the FPU version of Fontographer on a Power PC . 
The Power PC has an FPU which is 

#12314: Fontographer 4.1 errors and extension conflicts  
Fontographer 4.1 errors and extension conflicts I'm getting an error: when autotracing, installing 
Fontographer or while editing a font. Open Transport conflicts may be displayed as: Illegal User, Type 1, 
Type 11, or other system errors. 

#03500: General Macintosh troubleshooting  
General Macintosh troubleshooting Introduction This TechNote suggests some general troubleshooting 
techniques for problems or unexpected behaviors with Macromedia applications running on Apple 
Macintosh OS X. It is broken up into three main 

4. Font Formats, Generating Fonts  

#12918: Font format tutorial  
Font format tutorial Font files come in a variety of formats; distinguishing among them (and how they 
appear on different platforms) can be a daunting task. Use the chart below to quickly determine the 
meaning, extensions and icons 

#12326: Saving a database versus generating a font  
Saving a database versus generating a font "File>Save" or "Save As," is used for saving a Fontographer 
DATABASE. The name which is chosen (Example: mydatabase.fog) is ONLY the name of a DATABASE. 
FONTS are named under Element>Font 
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#12565: The easy way to generate a font with Macintosh Fontographer  
The easy way to generate a font with Macintosh Fontographer Here are some quick steps for generating 
fonts: 1 When the font is ready to generate, go to Element > Font Info menu. 2 Be sure to give the font 
a unique name under the Family Name 

#14298: The easy way to generate a font with Fontographer for Windows  
The easy way to generate a font with Fontographer for Windows Here are some quick steps for 
generating fonts: 1 When the font is ready to generate, go to Element > Font Info > General menu. 2 Be 
sure to give the font a unique name under the 

#13450: Quick-Start Mac to PC Font Conversion  
Quick-Start Mac to PC Font Conversion What is the fastest way to convert a Mac font into a PC font using 
Fontographer for Mac? There are several factors which impact a successful font conversion. Here are 
some quick steps for the most 

#13449: Quick-Start PC to Mac Font Conversion  
Quick-Start PC to Mac Font Conversion What is the fastest way to convert a PC font into a Mac font? 
There are several factors which impact a successful font conversion. Here are some quick steps for the 
most popular conversions : PC Fonts 

#12322: How do I convert Mac fonts to run on my PC?  
How do I convert Mac fonts to run on my PC? How can Macintosh fonts be converted to Windows 
format? How can Macintosh fonts be opened in Windows Fontographer? Macintosh fonts (and files) 
have resource forks which are used by Macintosh HFS 

5. Drawing Glyphs, Importing Illustrations  

#12635: Using Illustrator to copy/paste into Fontographer  
Using Illustrator to copy/paste into Fontographer Issue Illustrator 7 for Macintosh will not copy/paste 
paths into Fontographer. Macromedia is aware of this issue. You can confirm that there is a clipboard 
problem by placing something on 

#13846: Using FreeHand 8 with Fontographer 4.1  
Using FreeHand 8 with Fontographer 4.1 How is FreeHand typically used with Fontographer ? Some 
designers are more comfortable with the editing tools in FreeHand. Thus, they often prepare artwork or 
character shapes in FreeHand to be brought 

#13916: Unable to Copy/Paste from FreeHand to Fontographer  
Unable to Copy/Paste from FreeHand to Fontographer Issue Can't see pasted image when using 
clipboard from FreeHand to Fontographer. Reason The native format for the Macintosh clipboard is 
PICT. The problem occurs when the FreeHand Export 

#03721: Problems Importing EPS files into Fontographer  
Problems Importing EPS files into Fontographer Issue Problems importing an EPS. Reason Illustrator1.1 
EPS format is the typical EPS format which Fontographer understands. Error -11200 on the Macintosh 
means that the EPS being imported has 

#03711: Scanning and autotracing in Fontographer  
Scanning and autotracing in Fontographer --> Many font developers use scanners to create bitmap 
images of their lettering and artwork. Fontographer can use these scanned images as a basis for creating 
outlines for characters in a font. 
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#12768: Tips on Autotracing in Fontographer  
Tips on Autotracing in Fontographer Issue: I want to take my handwriting and make it into a font. I see 
that Fontographer can autotrace background images, but the process can be confusing. Please explain. 
How To Do This: 1. Scanning Your 

#08166: Bringing images into Fontographer  
Bringing images into Fontographer Issue 1 Fontographer won't import EPS Reason Some EPS files (such 
as PhotoShop EPS files) contain bitmap images within an EPS wrapper. Fontographer can only import an 
EPS file which has path information. 

#12311: Creating Handwriting Fonts in Fontographer for Windows  
Creating Handwriting Fonts in Fontographer for Windows This tutorial is designed to illustrate the easiest 
method of creating a handwriting font. Handwriting samples should be fairly large, 3 inches is ideal. If 
the sample handwriting is 

#03701: Creating a complex logo font  
Creating a complex logo font A logo imported into Fontographer and generated as a font will not display 
or print properly. At some point sizes the logo appears fine but at others the logo is replaced by a 
vertical bar or an empty box. This 

#03708: Steps to help blending fonts  
Steps to help blending fonts Blending Plain and Bold faces to create a medium face. In order to blend a 
font, the two source characters being used must have the same number of paths or Fontographer won't 
blend them. 1 Turn on the radio 

6. Font Families, Font Names  

#03719: Cross-platform font issues in Fontographer  
Cross-platform font issues in Fontographer Here are some things to keep in mind when preparing a 
cross-platform project: Macintoshes and Windows machines have different character sets ASCII is a 7 bit 
code which both platforms base their 

#13365: Creating portable fonts  
Creating portable fonts What is a Portable Font? Traditionally, Microsoft Windows wasn't designed to 
recognize all Macintosh keystrokes (for example, the Apple key) and the Apple OS wasn't designed to 
accommodate Windows users. A portable 

#12319: Creating PC font Families  
Creating PC font Families Windows font families can become problematic when certain family members 
don't show up in the font menu. This problem may occur whether the fonts are created on Macintosh or 
Windows. Be advised that Windows only 

#03712: Large font families in Windows  
Large font families in Windows ATM for Windows only allows four fonts in a font family. The styles it 
allows are Roman, Bold, Italic, and Bold Italic. (The Roman style may be called Normal, or Plain, or 
Book, etc.) Therefore, when you need 

#03723: Troubleshooting font names  
Troubleshooting font names PC Troubleshooting Fontographer's Type 1 PC font naming rules correspond 
closely to Adobe's file naming scheme. A legal family name is required in order for ATM to see the font 
correctly. 1 The operating system 
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#03724: Creating a Bold or Oblique font  
Creating a Bold or Oblique font Instructions for creating bold styled fonts. Here are some tips on creating 
a bold font which is technically and artistically uniform when compared to the Plain version of the same 
font. Before taking these 

#08165: Bold Italic style problems  
Bold Italic style problems Manually entering Bold Italic style parameters Sometimes the font information 
which is needed in order to update a font's attributes is not being written correctly by Fontographer. The 
proper parameters need to be 

7. Metrics and Kerning  

#03715: Importing font metrics into Fontographer 4.1  
Importing font metrics into Fontographer 4.1 Font loses leading, spacing or kerning. When Fontographer 
opens a font file, it reads all the pertinent information in that file. It does not search for related files. 
When opening a TrueType 

#12652: Controlling Custom Leading of Macintosh Fonts  
Controlling Custom Leading of Macintosh Fonts Issue "How can I control the leading of my Mac Truetype 
font?" Solution Leading is set via Element>Font Info and by changing the Ascent. The "Leading" field 
itself is a placeholder for 

#12323: Increase ascent without scaling characters  
Increase ascent without scaling characters Issue In Fontographer 4.x, increasing the ascent will also scale 
the font so that the intended result of gaining more white space between lines does not occur. Solution 
In order to gain the extra 

#12651: PC Truetype Leading Issues  
PC Truetype Leading Issues Issue Characters have too much or too little white space between sentences. 
Reason This may happen because the distance from the cap height to the ascender is either too close or 
too far. The Windows operating 

8. Encoding  

#15464: What is Unicode and how does it work?  
What is Unicode and how does it work? What is Unicode? The Unicode Standard, developed by the 
Unicode Consortium, is a universal character encoding standard used for representation of text for 
computer processing. The current version (3.1) 

#12953: Quick-Start Unicode Font Tutorial  
Quick-Start Unicode Font Tutorial Issue I want to create a new international TrueType font by adding 
some characters which are not in an existing font. Solution There are a couple ways to look at this: 1. 
Hopefully, this is a working 

#12333: Setting Truetype parameters for Unicode Fonts  
Setting Truetype parameters for Unicode Fonts Issue How can I input the proper parameters into the 
TrueType table fields in Fontographer? Solution The data in these fields is obtained from the TrueType 
Specification (TTF Spec). There are 

#13314: What is an encoding vector?  
What is an encoding vector? Definition of encoding Encoding vectors are tables of character sets. These 
tables are used to help the keyboard match a keypress with a character slot. Most of the characters in 
slots 0 -31 are pre-empted by 
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#03713: Encoding vectors FAQ  
Encoding vectors FAQ Question Why do special characters print with symbols instead of the special 
characters? I've created a wonderful font that has some special characters in the upper 128 range of 
characters (the shift-option- and option- 

#13434: Custom Encoding Tutorial  
Custom Encoding Tutorial Issue Some keystrokes refuse to respond when a character is placed in a 
particular slot. Solution The first thing to do is check tech note 3713 (applies to Mac and PC) and make 
sure that the font was opened with its 

#13433: Crossover Chart for Cross-platform Characters  
Crossover Chart for Cross-platform Characters Which characters are used to build a cross-platform 
encoding vector? Beginners who want to make their own custom encoding vector may want to use this 
chart as a good starting point. This chart 

#08174: Defining Unicode Characters  
Defining Unicode Characters There are no automatic tools to create Unicode fonts. Unicode fonts are 
prepared by manually defining the needed character names and Unicode numbers in a font database. 
The simplest way to create a Unicode font 

#15460: Creating a non-Unicode font with international character shapes  
Creating a non-Unicode font with international character shapes --> Issue Some applications are not fully 
Unicode compliant. Unicode fonts using international characters will not function properly in these 
applications, even if a Unicode 

#13304: How to add a Euro Character to a Macintosh font  
How to add a Euro Character to a Macintosh font Question How can I add the Euro character to my 
font? Which slot should it go in? Answer 1 A Font Designed on Macintosh and staying on Macintosh 
Replace the "currency" character (decimal 219) 

#13303: How to add a Euro character to your PC font  
How to add a Euro character to your PC font Issue How can I add the Euro character to my PC font? 
Which slot should it go in? Solution 1 Non-Unicode / Windows Encoded Font This method is suggested 
for developers who do NOT require their 

#12312: Creating Symbol fonts for Windows  
Creating Symbol fonts for Windows PC Symbol encoding is normally used for fonts which must work 
with application features such as Microsoft Word's "Insert Symbol". Follow these steps to create a PC 
Symbol encoded font: 1 If building from an 

#03700: Inaccessible characters in Windows fonts  
Inaccessible characters in Windows fonts Sometimes, certain characters that you create may not show on 
screen or print, while all the other characters are fine. This only occurs with characters outside the main 
keyboard locations. This is 

#03704: Missing characters in Windows  
Missing characters in Windows When generating a Truetype font for Windows in Fontographer 4.0.4, 
some fonts will lose the hyphen, periodcentered, or mu characters. Typically this will occur when the 
source font is a Truetype or is a 

#12950: Why doesn't Adobe Expert Encoding work in TrueType Fonts?  
Why doesn't Adobe Expert Encoding work in TrueType Fonts? Adobe Expert fonts CANNOT be 
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generated as Truetype fonts with Adobe Expert encoding on the Macintosh or Windows platforms. The 
problem is that Adobe Expert encoding uses unique 

#12910: Creating Outline or Keycaps fonts  
Creating Outline or Keycaps fonts Introduction Fontographer uses display PostScript to show the outlines 
on the screen. Type 1 and TrueType fonts use the PostScript interpreter's winding fill algorithm to display 
and print fonts. A winding 

#13222: Latin countries - keyboard layouts  
Latin countries - keyboard layouts Issue How do I create international Windows fonts with proper 
keyboard layouts in Fontographer? Solution To make a Unicode font starting with an empty database: 1 
Switch the preview encoding under Element 

#13191: International Fonts for Macintosh  
International Fonts for Macintosh Issue International font displays the wrong characters after editing it in 
Fontographer. Solution 1 Open the font with original encoding as described in tech note 3713 . 2 Go to 
File>Generate>Advanced and 

#13228: Master list of international keyboard layouts  
Master list of international keyboard layouts Issue How do I create international Windows fonts with 
proper keyboard layouts in Fontographer? Solution Choose from the following list of keyboards and 
follow the instructions for defining 

#12324: Problems with Quote or Apostrophe Characters  
Problems with Quote or Apostrophe Characters The wrong character is displayed when a smart 
apostrophe (’) or quote characters (”) are typed. Smart quotes (also known as curly quotes) are fancy 
characters which make text look better compared 

#08163: Two-byte fonts  
Two-byte fonts Fontographer does NOT open or generate two-byte fonts. Font designers who need to 
work with two-byte characters can try the following suggestions: 1 Fontographer Macintosh users can use 
File > Import Truetype Character to 

#12948: Hacking Fontographer to open 2-byte fonts  
Hacking Fontographer to open 2-byte fonts How to create an MMSZ resource which allows Fontographer 
to open two-byte fonts The following procedure is offered for Fontographer user's who want to attempt 
to open a two-byte font. Macromedia 

#15783: Fontographer for Windows cannot generate Arabic fonts with reliable character shape 
substitution  
Fontographer for Windows cannot generate Arabic fonts with reliable character shape substitution Issue 
An Arabic font generated by the Windows version of Fontographer does not reliably display characters in 
text editors. Reason Arabic fonts 

#03727: Creating offset accented characters  
Creating offset accented characters Issue Many fonts don't have enough room to fit additional accented 
characters. Solution Most fonts can be built with offsets in order to increase the amount of additional 
accented characters available. 

#13276: Unrecognized characters in Macintosh Arabic fonts  
Unrecognized characters in Macintosh Arabic fonts The Macintosh version of Fontographer displays a 
lack of robustness in handling the yacute (dec 8) and multiply (DEC 29) for Arabic fonts. This range of 
characters is commonly used for 
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#13628: Reserved characters in modern Windows encoding  
Reserved characters in modern Windows encoding Issue Unable to use decimal slots 128, 142 and 158 
in font encoding. Solution Do not use these slots for encoding fonts which are used under Windows 98 
or Windows 2000 These slots have always 

#12334: Symbol substitution issues in Adobe Standard Encoding  
Symbol substitution issues in Adobe Standard Encoding The correct behavior when we open an Adobe 
font with Original encoding is that it will PRINT Symbol substitution characters (see Encoding Options in 
the Fontographer User Manual ). 

#13827: Adobe encoded characters in Windows  
Adobe encoded characters in Windows Issue Adobe encoding is used whenever possible for cross-
platform fonts and documents. However, there are some characters which are found in Adobe encoding 
which will not be available on a given platform. 

#03732: Mu and Mu1 character definitions in Windows 95 fonts  
Mu and Mu1 character definitions in Windows 95 fonts The Mu character doesn't display when using the 
Alt-0181 keystroke. Microsoft changed the Truetype Specifications. In TTF Spec 1.6.6 you will find that 
character 181 is now defined as the 

#13428: Accessing special characters in Windows 95 encoding  
Accessing special characters in Windows 95 encoding Issue Windows 95 encoded font doesn't allow 
keyboard access for the special characters above 256. Solution International keyboard support is 
provided by the Multilingual Support Package. 

#13225: European keyboard layouts  
European keyboard layouts How do I create international Windows fonts with proper keyboard layouts 
in Fontographer? Use the following steps to make a Unicode font starting with an empty database: 
Switch the preview encoding under Element > 

#13226: Scandanavian Keyboard Layouts  
Scandanavian Keyboard Layouts Issue How do I create international Windows fonts with proper 
keyboard layouts in Fontographer? Solution Use the following steps to make a Unicode font starting with 
an empty database: 1 Switch the preview 

#13221: East European keyboard layouts  
East European keyboard layouts Issue How do I create international Windows fonts with proper 
keyboard layouts in Fontographer? Solution Use the following steps to make a Unicode font starting with 
an empty database: 1 Switch the preview 

#13218: Balkan Keyboard Layouts  
Balkan Keyboard Layouts How do I create international Windows fonts with proper keyboard layouts in 
Fontographer? Use the following steps to make a Unicode font starting with an empty database: Switch 
the preview encoding under Element > 

#13219: Baltic Keyboard Layouts  
Baltic Keyboard Layouts Issue: How do I create international PC fonts with proper keyboard layouts in 
Fontographer? Solution: To make a Unicode font starting with an empty database: 1. Switch the preview 
encoding under Element>Font 

#13227: Slovak keyboard layouts  
Slovak keyboard layouts Issue How do I create international Windows fonts with proper keyboard 
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layouts in Fontographer? Solution Use the following steps to make a Unicode font starting with an empty 
database: 1 Switch the preview encoding 

#13211: Japanese & Korean keyboard layouts  
Japanese & Korean keyboard layouts Fontographer was not designed to create two-byte fonts. The 
following information is provided for users who need to know how to locate Japanese and Korean 
keystrokes on the keyboard. For more information 

#13220: Cyrillic keyboard layouts  
Cyrillic keyboard layouts How do I create international Windows fonts with proper keyboard layouts in 
Fontographer? Use the following steps to make a Unicode font starting with an empty database: Switch 
the preview encoding under Element > 

#13223: Mideast keyboard layouts  
Mideast keyboard layouts Issue How do I create international Windows fonts with proper keyboard 
layouts in Fontographer? Solution These instructions are only for Turkish fonts. Fontographer cannot 
create fonts which are guaranteed to work 

9. Hinting, Bitmaps and Embedding  

#12313: Font Embedding in Fontographer 4.1 Windows  
Font Embedding in Fontographer 4.1 Windows Issue Embedding levels of a Windows TrueType font are 
not recognized by Adobe Acrobat. Reason Embedding is the practice of inserting a parameter into a font 
so that it can be recognized by Adobe 

#12574: Embedding fonts with Macintosh Fontographer  
Embedding fonts with Macintosh Fontographer Issue When creating a PDF file, Adobe Acrobat does not 
recognize the embedding level of a Macintosh font. Embedding Adobe Acrobat creates a PDF file which 
allows users to view textual information. 

#03734: Setting monospace Truetype parameters  
Setting monospace Truetype parameters Regenerating an existing font causes the font to lose its 
monospaced attribute. Reason Monospaced fonts are fonts which see every character as having the same 
width. Fontographer doesn't read or set the 

#08178: Fontographer Hinting FAQs  
Fontographer Hinting FAQs Typical questions asked during a Hinting Troubleshooting call: 1. I've added 
a logo to a Roman font and the logo looks terrible. Rehinting doesn't help. 2. My character has one stem 
larger than the other after it 

#03718: Hints on Hinting in Fontographer  
Hints on Hinting in Fontographer Issue How can I design my font in a way that will allow it to be 
effectively hinted? Solution In general, hinting instructions will affect only: The appearance of a font on 
screen in Adobe Type Manager and 

#08185: Rehinting a Font  
Rehinting a Font Issue: "All I did was load an existing font, rename it and generate, now it looks terrible 
on screen at small point sizes." Reason: Many commercial TrueType fonts for Windows (several of 
Microsoft's and Monotype's) use 

#03722: Rehinting a font  
Rehinting a font Font displays poorly on screen at small point sizes. Many commercial TrueType fonts for 
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Windows use custom technology (referred to as delta hints) to improve the quality of the screen font. 
The TrueType instructions do most 

#12916: Using FPEDIT with Fontographer  
Using FPEDIT with Fontographer FPEDIT is part of the publically available set of Microsoft's OpenType 
utilities. It allows you to change the following parameters in your Truetype font's properties: 1 FPEDIT 
allows designers to add a link to 

#12310: Creating and installing FONs  
Creating and installing FONs Issue How to create and install FON files. Solution When generating a 
TrueType font for Windows in Fontographer it will be noticed that sometimes the screen display is not 
satisfactory. The primary reason that 

#03716: Generating Windows FON Bitmaps  
Generating Windows FON Bitmaps After generating a TrueType font for Windows in Fontographer, 
sometimes the screen display of the characters is unsatisfactory. The unsatisfactory display of the font on 
the computer screen may be occurring 

#12561: Using SBIT32 with Fontographer  
Using SBIT32 with Fontographer Issue How can I make a reliable screen font on the PC? Reason FON 
files produce erratic behavior which is difficult to control [see Generating Windows FON Bitmaps 
(TechNote 03716)]. Solution Use Microsoft's 

#12997: BDF files for X 11 Windows  
BDF files for X 11 Windows Issue I want to generate a bitmap font for X11 Windows. How can I do that? 
Solution The font is generated as BDF screen font from Fontographer. The screen or bitmap font will 
work for onscreen use only; it will 

#12959: Troubleshooting BDF Font Files  
Troubleshooting BDF Font Files What is a BDF? BDF is the Bitmap Distribution Format used on all Unix 
platforms (including Aux and AIX and X-Windows) to produce a screen font. Our files are only partly 
useful in that they are fixed at the 72 

10. Other Issues  

#13629: Macintosh Fontographer screen redraw problems  
Macintosh Fontographer screen redraw problems Fontographer exhibits screen redraw problems under 
Macintosh OS 8.0 and above. They are usually manifested as the cursor leaves trails of itself in some text 
entry fields. Fontographer is 

#12912: Quadra 840AV conflicts and Fontographer  
Quadra 840AV conflicts and Fontographer Here is a partial list of things that can cause a Quadra 840AV 
to have problems: Superclock 3.9.1 NOW utilities 4.0.1 ATM before 3.6 AfterDark before 2.0.x 
DiscDoubler 3.7.7 or older AutoDoubler 2.0 

#03725: Large format fonts in Fontographer  
Large format fonts in Fontographer Fontographer cannot open or create large character set fonts. 
Fontographer was created before large format fonts became popular and was not designed to open or 
create these fonts. How many characters a 

#03731: Creating Truetype fonts with line draw characters using Fontographer  
Creating Truetype fonts with line draw characters using Fontographer Line drawing fonts have characters 
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which are used to create borders and lines in both the horizontal and vertical directions. Special efforts 
are needed to make sure that 

#03706: Fontographer and sounds  
Fontographer and sounds Adding new sounds, changing sounds, turning off sound in Fontographer. 
Fontographer can sound to let the user know when you snap to a point or snap to a guide in the Outline 
Window, and it plays a sound whenever the 

#12320: Fontographer 4.1 Windows Printer Conflicts  
Fontographer 4.1 Windows Printer Conflicts Issue 1 Can't print at 600 dpi under FOG 4.1 WIN using 
non-PostScript printer drivers to a hybrid printer. Solution Downgrade the printer driver properties to 
300 dpi and use a PostScript printer 

#12911: Creating PostScript Type 1 fonts for DOS  
Creating PostScript Type 1 fonts for DOS Adobe's installation program for DOS apps will install your 
custom fonts if you make it think they're just like Adobe’s font packages. This document will assist you in 
that. To obtain Adobe’s 

#12958: Disabling font style linking  
Disabling font style linking Some font designers want to prevent users from selecting a Bold or Italic 
style. The following hack has been known to accommodate this problem but is not for the faint-of-heart! 
Macromedia cannot offer tech 

#12328: Finding the lower right of a character  
Finding the lower right of a character The "lower-right of a character" like "T" would mean the bottom of 
the crossbar of the T. Regarding the "lower right", it is the right that gets precedence. Generally speaking, 
you want the origin 

#15218: Adobe fonts do not show the proper bitmaps after importing bitmaps  
Adobe fonts do not show the proper bitmaps after importing bitmaps Issue After importing the bitmaps 
for an Adobe Standard encoded font, the bitmaps do not match the outline for a particular character 
slot. Reason All bitmaps on a Macintosh 

#12915: Generating and Installing UNIX NeXT PostScript&reg; Type 1 Fonts  
Generating and Installing UNIX NeXT PostScript&reg; Type 1 Fonts Note: The following procedures apply 
ONLY to Macintosh Fontographer. Fontographer for Windows does NOT generate Unix fonts. In the 
"Generate fonts" window, there is an option 

#12914: Installing Windows fonts in OS/2 2.0  
Installing Windows fonts in OS/2 2.0 How to install the fonts: 1 From the OS/2 System window, double 
click on “System Setup.” 2 From the System Setup window, double click on “Font Palette.” 3 Click on 
“Edit Font.” 4 Click on “Add.” 5 Insert 

#12297: Can't perform Save or Save As  
Can't perform Save or Save As Can't perform a Save or Save As after loading in an old Fontographer 
database while running Fontographer 4.1 Windows under Windows 3.1.x. This can actually occur in a 
new font as well. Fontographer 4.1 Windows 

#13432: Conflicts with Macintosh Font Management Software  
Conflicts with Macintosh Font Management Software What might cause Fontographer fonts to have 
conflicts when installed with a font manager and used in Quark? I'm getting scrambled font metrics and 
conflicts. I've used this font manager for 
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#12909: Solving Stylemerger font family problems  
Solving Stylemerger font family problems What is Stylemerger? Stylemerger is a Mac-only utility which is 
used to place the four standard members of a font family into a *.FAM suitcase file. This procedure 
allows these fonts to work with 

#08191: Splash screen and/or Toolbox icons are garbled  
Splash screen and/or Toolbox icons are garbled I recently installed Fontographer and now my splash 
screen and/or Toolbox icons are not displaying properly. Fontographer installs a custom font on startup 
for displaying icons. In some cases, 

#12365: Spikes or spurs are displayed on paths  
Spikes or spurs are displayed on paths Issue What causes spikes, spurs, artifacts, dropout and other 
distortions to occur on paths? Solution 1 Paths are too complex or points are not at extrema. Use 
Element>Clean Up Paths repetitively until 

#03710: Erratic Printing or Display of Windows TrueType Fonts  
Erratic Printing or Display of Windows TrueType Fonts Some Windows Truetype fonts display on the 
screen erratically. Sometimes a font will display the right character, but at other point sizes it displays an 
empty rectangle. Also, the font 

#03717: Characters moving off the baseline  
Characters moving off the baseline All of the characters in a font get moved above or below the baseline. 
This is sometimes discovered as incorrect leading within an application. It is commonly caused by a stray 
point above the ascender or 

#14359: How can I draw the intersection of two shapes?  
How can I draw the intersection of two shapes? FreeHand, Fireworks and other drawing tools often have 
ways to make one shape change another shape, such as subtracting one shape from another, or finding 
their intersection. Although Flash 

#15723: An error message appears reporting the 'exception in module 10h'  
An error message appears reporting the 'exception in module 10h' A message box appears reporting the 
"exception in module 10h" error. You may receive this error message when using any of the following 
printers: Hewlett-Packard PhotoSmart 

#03726: Converting point sizes and picas to em units  
Converting point sizes and picas to em units Issue Is it possible to move a character within the em square 
the equivalent of one pica? How can a character be set to display in the screen at an exact point size? 
Solution First, choose the 

#13192: Fonts won't display or work incorrectly in Illustrator 7  
Fonts won't display or work incorrectly in Illustrator 7 Issue 1 Fonts are missing from font menu in 
Illustrator 7 Solution Illustrator 7 uses the AdobeFnt.lst file (found in the System>Preferences folder) in 
order to keep track of which 

#03735: Repairing corrupted fonts  
Repairing corrupted fonts Issue An error message appears which indicates that the font is corrupted. The 
font displays rectangles regardless of which character is typed. Reason Fonts may become corrupted due 
to disk errors or memory errors. 

#13725: PostScript Type 3 font tutorial  
PostScript Type 3 font tutorial How to create a Grayscale PostScript Type 3 font It is possible to create 
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"stroked" fonts (fonts which consist of a single open path) for PostScript Type 3 format. These fonts can 
also have normal closed 

#13448: Editing the Underline Position and Width  
Editing the Underline Position and Width Issue Editing the Underline Position and Width does not always 
work. Reason The Element>Font Info dialog has data entry fields for the Underline Position and Width 
but the use of these parameters is 

#13694: Kerning characters above decimal 256  
Kerning characters above decimal 256 Issue How can characters above decimal 256 be kerned? Solution 
Characters decimal are accessed via Unicode. The following steps can be taken to create Unicode kerning 
pairs: 1 Select Windows > Open 

#12908: Preparing fonts for Unix Systems  
Preparing fonts for Unix Systems Since there are many flavors of Unix, the first step is to identify which 
file format your project requires: PostScript Type 1 Font Sun computers (running Solaris or the X-
Windows OS) call for this font 

#08164: Outlines are missing - ATM error message  
Outlines are missing - ATM error message Error message: "Can't convert to paths because ATM is off or 
outlines are missing." This is usually due to the manner in which the font was installed. Refer to Font 
Installation on the Macintosh for 

#13017: Troubleshooting Font Problems in Microsoft Word  
Troubleshooting Font Problems in Microsoft Word Issue Word wrapping, spacing, hyphenation and spell 
checking problems occur when using a font in Microsoft Word. Solution All reported problems of this 
type have been due to conflicts between 

#12569: Why do characters not appear in the preview mode?  
Why do characters not appear in the preview mode? Paths are visible in outline mode, but choosing 
View > Preview causes them to disappear. First of all, check to make sure the tint value of the path is not 
0%. Do this by looking under 

#12769: Troubleshooting the Petrucci font  
Troubleshooting the Petrucci font Issue Petrucci's font metrics (ascent/descent) are not functioning 
properly. In order to function properly in the Finale music editing application, Tim Herzog had to design 
Petrucci with a strange em 

#12719: Special characters and kerning/metrics equivalence dialogs  
Special characters and kerning/metrics equivalence dialogs Issue Entering special characters into the 
Assistance and Metrics Equivalence dialogs. Solution The following list contains the allowable characters: 
The dash character ( - ) is 

#13475: Improper Screen Font Display on Macintosh  
Improper Screen Font Display on Macintosh After opening an existing font and re-generating it, the 
screen fonts look terrible. TrueType TrueType fonts will contain more points on the curves than the 
original drawings. The method for 

#12317: MMPC2MAC Utility & Size 8,11,14 Bitmap Conflicts  
MMPC2MAC Utility & Size 8,11,14 Bitmap Conflicts When I drag my font on top of the MMPC2MAC 
utility, I'm getting an error message: "MMPC2MAC can't process this file. Make sure it is a Macintosh file 
produced using Fontographer 4.1 Windows." 
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#12327: Screen font doesn't reflect changes to outline font  
Screen font doesn't reflect changes to outline font A font is edited and regenerated but the edits are not 
reflected in the screen font. There are two editors in Fontographer. The Bitmap editor and the Outline 
editor. The Recalc Bitmaps 

#12335: Troubleshooting the MMPC2MAC utility  
Troubleshooting the MMPC2MAC utility Issue 1 Where is the MMPC2MAC utility for converting fonts for 
Macintosh? Solution The user will NOT be able to see this utility on Windows. The user must have a 
Macintosh with a CD drive in order to 

#12364: Font displays rectangles instead of characters  
Font displays rectangles instead of characters Sometimes, when you install or use a font you will see a 
rectangle instead of the characters which should be there. If this is happening ONLY with the space 
character Open the Fontographer 

#12338: WIN95 font loads as Custom encoded  
WIN95 font loads as Custom encoded When I open a WIN95 font the encoding is often set to Custom 
instead of WIN95. Microsoft made some last minute changes to the WIN95 encoding vector. These 
changes affected the way Fontographer reads the 

#03714: Special Effects Fonts  
Special Effects Fonts Fonts with white filled counterspaces Issue: I need a font which can be used in a 
graphics program with a color background. The problem is, I don't want the color to show through the 
insides of the characters. All the 

#12325: Repairing corrupted fonts  
Repairing corrupted fonts While trying to install (or open) my font, I got an error message which 
indicates that my font is corrupted -what can I do about it? I'm getting rectangles in place of characters 
when I try to use my font. Fonts 

11. Other Resources   

#03796: Fontographer Publications  
Fontographer Publications The following is a list of books for Fontographer as well as on fontography, 
created by Macromedia and others. The list may be incomplete but should be useful as you design fonts 
and integrate them into your 

#03797: Fontographer Websites  
Fontographer Websites The following is a compilation of available websites for Fontographer and fonts, 
in general. This directory is in no way complete, but you may find the consolidation of the material 
helpful as you develop applications 

#03798: Fontographer online forums  
Fontographer online forums Please consult your Fontographer manuals, search Macromedia's site for 
keywords, and scan the Fontographer TechNotes before posting to the online forum. Read the 
information in the List of online forums if you 

#03799: Fontographer-related mailing lists  
Fontographer-related mailing lists Macromedia Online Forums provide places for developers of all 
experience levels to share ideas and techniques. Macromedia Technical Support personnel and members 
of the product development teams frequent 
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#03728: "#3728- Online Font Sources"  
"#3728- Online Font Sources" OnLine Resources CompuServe: Macromedia forum (GO MACROMEDIA), 
DTPFORUM, JWORLD (Jerry's World) America Online: Macromedia forum (Keyword: Macromedia), 
Computing and Software forum, MDP forum, FONTBANK 

#03729: Fonts and Copyrights  
Fonts and Copyrights What are the copyright issues involved while using commercial fonts in 
Fontographer? The Copyright Notice field in Fontographer may direct you to the copyright holder, but 
be aware that this field may be blank, or may 

#03730: TrueType Information on the Internet  
TrueType Information on the Internet Issue I'm designing a TrueType font, so where do I find out more 
about the TrueType Specification? Solution TRUE TYPE SPECIFICATION 
ftp://ftp.microsoft.com/developr/drg/truetype/ttspec.zip This is 
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The Technotes 

#03500: General Macintosh troubleshooting 

Introduction 

This TechNote suggests some general troubleshooting techniques for problems or unexpected behaviors 
with Macromedia applications running on Apple Macintosh OS X. It is broken up into three main 
sections: 

1. Macintosh OS 9.x Troubleshooting. 

 

Collecting Information 

Troubleshooting problems with Macromedia applications is generally easier when complete 
information about the problem and conditions for reproducing the problem are available. Some 
of the information which helps narrow down the problem can be found using some of the items 
below: 

o http://www.macromedia.com/software/. Please see the example system requirements for 
Dreamweaver below: 

 Dreamweaver MX 2004:  
500 MHz Power PC G3 processor 
Macintosh OS X 10.2.6 and later, 10.3 
128 MB computer RAM (256 MB recommended) 
275 MB available disk space 
You must have at least 800 x 600, thousands of colors monitor, although 1024 
x 768, millions of colors is recommended. 
Note: This product must be activated over the Internet or phone prior to use. 
Visit the Product Activation Center to learn more about activation. 

 Dreamweaver MX:  
A Power Macintosh G3 or better 
Macintosh OS 9.1 and higher or Macintosh OS X 10.1 and higher 
96MB RAM (128 MB recommended) 
275 MB of available disk space 
You must have at least 800 x 600, thousands of colors monitor, although 1024 
x 768, millions of colors is recommended. 

Will the older Macromedia applications run on Macintosh OS X? 

After extensive testing, we have determined that older Macromedia applications operate 
in the Macintosh OS X's classic mode without any new problems. For specific product 
statements see Macromedia product support for Mac OS X (TechNote 15224). 

Which applications are starting up with the computer? 

The operating system programs that are executed when the computer starts are located 
in /System/Library/StartupItems. These files are essential to the operation of OS X and 
should not be altered. Some applications may install files in /Library/StartupItems. This 
folder is not part of the default installation of OS X. Certain applications installed for a 

http://www.macromedia.com/software/
http://www.macromedia.com/software/activation/
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single user need to write files in /Users/USERNAME/Library/StartupItems. Because of this 
it may be created during the installation of an application. To see if one of these 
programs is interfering with your Macromedia application, please move the files from 
/Library/StartupItems and/or /Users/USERNAME/Library/StartupItems and restart the 
computer. 

Which applications are starting up with the computer / which applications are 
running before the Macromedia application starts? 

As with previous Macintosh operating systems, OS X allows you to force quit 
applications by pressing Option-Apple-Escape. In OS X, when you press that key 
combination a Force Quit Application window appears listing the running applications. 
You can Quit each program by selecting it and clicking Quit. Depending on your system 
configuration all of the running applications may not appear here. 

Note: For advanced users, the ProcessViewer utility (found in /Applications/Utilities) 
provides some information about currently running applications, but the names of the 
applications may be missing. Additional information can be found by running the Unix 
command top in the terminal window which shows the name of the application. Please 
see Apple's article Mac OS X: How to View Memory Usage With the "top" Utility for 
more information. Background information about processes and daemons can be found 
in Apple's article Mac OS X Server: Processes and Westwind Computing's Mac OS X: 
What Are All Those Processes?. 

Is there any way to get detailed reports about crashes? 

Apple includes a utility for viewing technical messages from Macintosh OS X 
applications called the Console. To turn on crash logging, start the console (found in 
/Applications/Utilities/Console), choose Console> Preferences, choose the Crashes tab 
and check "Log crash information in ~Library/Logs/". The log file is 
/Users/USERNAME/Library/Logs/<macromedia product name>.crash.log, for example. 
These .log files will be comprised of text messages and can be opened and viewed in 
TextEdit. 

 

Isolating the problem 

After confirming that the system requirements are met, and collecting information about 
what applications are running at the same time as the Macromedia application, you can 
begin to isolate the problem: 

 106667 describes switching between Macintosh OS 9.x and Macintosh OS X.) 

If the problem cannot be reproduced in Macintosh OS 9.x, then further 
investigation should determine if the problem is with the Macromedia 
application installation (use a new account with admin privileges to see if the 
problem reproduces), other applications running (turn off other 
applications/Startup Items), or with Fonts (remove third party fonts). 

Note: Macromedia products released since mid-2003 do not run in Classic 
mode or on any non-Carbonized operating system. Check your application's 

http://docs.info.apple.com/article.html?artnum=106415
http://docs.info.apple.com/article2.html?artnum=60053
http://www.westwind.com/reference/OS-X/background-processes.html
http://www.westwind.com/reference/OS-X/background-processes.html
http://www.info.apple.com/kbnum/n106667
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minimum system requirements to determine if this troubleshooting step will 
work for you. 

Does the problem happen when Classic mode is not running? 

The Classic mode is Macintosh OS 9.x running as a separate process on top of 
Macintosh OS X. One useful troubleshooting technique is to turn off Classic 
mode and try reproducing the problem. If multiple non-OS X programs are 
running please stop those programs and then quit the Classic mode. To turn off 
Classic mode, start System Preferences (Apple> System Preferences), Classic 
(View> Classic) and click Stop (and if that does not work then click Force Quit). 
If the problem happens only when Classic mode is running, then test for an 
extension conflict. 

Is there a conflict with another application? 

Close all other applications and verify that the problem still happens if your 
Macromedia application is the only program running. A list of currently running 
applications can be viewed in the Force Quit Applications window by pressing 
Option-Apple-Escape. If you are an advanced user the ProcessViewer utility 
(found in /Applications/Utilities) provides some information about currently 
running applications. 

Does the same problem happen with other accounts on the same 
computer? 

Each user account contains a large number of files used for configuration, 
preferences, fonts, and other purposes. Those files can interact to cause 
problems, and by logging in as a newly created user those problems can be 
eliminated. Before creating a new user, please copy or move the document files 
to a location which can be read by other users: 

1. Choose System Preferences from the Apple menu. 
2. Choose View> Users. 
3. Choose New User. 
4. Give the new user a name and a short name. 
5. On the Password tab, give the user a password. 
6. Select "Allow users to administer this computer". This makes the user 

an Admin user. 
7. Choose OK. 
8. Log out and then log in as the new user. 
9. Launch your Macromedia application, open the document file in the 

selected local folder, and try reproducing the problem. 
 
If the problem goes away there may be some problem with the original 
account. Continue to use the new user account and copy any 
documents/folders from the other, old account. 

If the problem goes away then another test would be to create a new user 
without admin privileges and perform the same test. If the problem goes away 
then one option would be to start using that user account, and copy any 
documents/folders as needed to the new user account. 
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Could the problem be with the preferences file? 

The preferences file for Macromedia applications 
(/Users/USERNAME/Library/Preferences/Dreamweaver MX Prefs, for example) is 
generally updated more frequently than other Macromedia application files, so 
the chance of that file becoming corrupt is greater. To test if the problem is with 
the Macromedia application preference file, simply move the file to a different 
directory (or the desktop) while the application is not running, and then restart 
the application and try to reproduce the problem. The Macromedia application 
will create a new preferences file if the file is missing. 

Is there a problem with permissions? 

If the problem cannot be reproduced when using the Macromedia application 
with a new user account with admin privileges the problem might well be with 
individual file or folder permissions. Apple computer has a utility for download 
which can reset the permissions for files and directories used by Macintosh OS X 
10.1.5. 

Corrupt fonts - or is there a problem with DiamondSoft Font Reserve or 
Extensis Suitcase? 

Research has shown that corrupt fonts are frequently the source of 
crashes/problems on the Macintosh. Brief testing of Extensis Suitcase v10.1.2 
and DiamondSoft Font Reserve has shown no problem with Macromedia 
applications on Macintosh OS X. If your Macromedia application exhibits any 
unusual behavior while either of these applications are running then the 
problem is likely caused by a corrupt font. In either application close all open 
fonts and restart your Macromedia program - if the problem does not continue 
then the problem is almost certainly a corrupt font. Please refer to the 
documentation for these products for troubleshooting techniques for problem 
fonts. the general idea is to identify which font is corrupt and replace the font 
with a working copy or simply not use that font.  

Macromedia application help is not working. 

First, does help work outside of Macromedia application? In the finder, select 
"Mac Help?" from the Help menu. If Help is working outside of the application 
then check if the aliases pointing to the Macromedia application Help files are 
located in /Library/Documentation/Help - if the files are missing reinstall the 
application. 

Where did the sites, or extensions, go when I logged in as a different 
user? 

Macromedia applications were designed to allow different users to set different 
preferences, define different sites, install different extensions, and otherwise 
customize your application. As a result different users may have different sites 
defined, and different extensions installed. The site definitions are stored in the 
preferences, for example: /Users/USERNAME/Library/Preferences/Dreamweaver 
MX Prefs. Please log in as different users to locate the sites that may be missing. 

 

http://docs.info.apple.com/article.html?artnum=106900
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Searching for a workaround 

Some problems with Macromedia applications can be fixed once the problem 
has been defined. Other problems may require reinstalling, or disabling a 
corrupt font. 

10. Knowledge Base document 106417 

Additional information 

For application specific troubleshooting for Macintosh see the support 
page for the specific application. 

Third-party resources: 

 Macintosh Knowledgebase  
http://kbase.info.apple.com/  

 Troubleshooting Solutions for the Macintosh  
www.macfixit.com  

 The Ultimate Macintosh Page  
http://www.ultimatemac.com/  

Third party links 

Although links to external web sites are provided as a resource, the web 
sites are not part of Macromedia. Please see the Macromedia policy 
regarding links to third party web sites in the Legal Notices and 
Information section. Pages to external web sites will open in a new 
browser window. 

 

#03700: Inaccessible characters in Windows fonts 

Issue 

 
Sometimes, certain characters that you create may not show on screen or print, while all the other 
characters are fine. This only occurs with characters outside the main keyboard locations. 

Reason 

 
This is because there are certain slots (character positions in Fontographer's Font window) that you 
cannot use in an ANSI encoded Windows font. If your character was placed in one of those slots, when 
Fontographer creates the font, it must reposition the character at the end of the font. 

Note that anything placed prior to the space character (decimal 32) will not be usable, as Windows has 
no access to characters in slots 0 - 31. 

The following character slots are not usable for a font with the standard ANSI character set.  

http://kbase.info.apple.com/
http://www.macromedia.com/support/
http://www.macromedia.com/support/
http://kbase.info.apple.com/
http://www.macfixit.com/
http://www.ultimatemac.com/
http://www.macromedia.com/help/copyright.html#disclaimer
http://www.macromedia.com/help/copyright.html#disclaimer
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Decimal  Keystroke  

127  delete  

128  not defined 

129  not defined 

141  not defined  

142  not defined  

143  not defined  

144  not defined  

157  not defined  

158  not defined  

160  non-breaking space  

Solution 

 
Obviously, it is best to simply avoid these character slots. 

If you are pressed for just eight more characters that just have to fit into your font, there is a solution. For 
this purpose, we supply a special encoding vector named OEM or OEM Encoding. 
 
Follow these steps to create an OEM encoded font:  

1  Select File > New font then, select Element > Font Info > 
General (Element > Font Info on Macintosh) to set the Preview 
Encoding to OEM. 

The font may become corrupted if the Preview Encoding is not 
set before generating the font. 

2  Click OK and then copy and paste the characters into the new 
font. 

3  This may have to be done in stages, as Windows often runs out 
of memory when trying to copy and entire database of 
characters 

4  All of the reserved characters except for 127 and 160 can be 
used in an OEM encoded font.  

Additional Information  
If you have previously been advised to use Symbol encoding, we want you to know that we now 
recommend OEM over Symbol. A Symbol encoded font will not allow for kerning pairs. 

Be advised that Microsoft is reclaiming some of the reserved character range as discussed in Reserved 
Characters in Modern Windows Encoding. 

Additional Information 
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If you have previously been advised to use Symbol encoding, we want you to know that we now 
recommend OEM over Symbol. A Symbol encoded font will not allow for kerning pairs. 

Be advised that Microsoft is reclaiming some of the reserved character range as discussed in Reserved 
Characters in Modern Windows Encoding. 

 

#03701: Creating a complex logo font 

Issue 

 
A logo imported into Fontographer and generated as a font will not display or print properly. At some 
point sizes the logo appears fine but at others the logo is replaced by a vertical bar or an empty box. This 
may occur when viewing onscreen and/or printing.  

Solution 

 
Open up your screen so the following dashes and arrows are completely visible.  

Step 1 - Breaking the logo apart  

In order to avoid problems with complex logos it becomes necessary to break up the parts of the logo 
into separate character positions. In so doing, the logo will still look the same, but since it is a composite 
of simpler parts it will now print. Make sure that you choose character locations which can be accessed 
with the keyboard and are not control character sequences. (control characters are found in 0-31 of the 
Fontographer font window.)  

Beginning with this complex logo imported from an EPS: 

 
- we broke it into five character positions. This is the most confusing part of the example because some 
thought must go into deciding just where to make the breaks. This example of our department logo is 
more complex than most because it requires breaking apart paths. In most cases, paths will remain 
intact, but words will be broken across different characters. It is important to note when copying and 
pasting the parts into new characters, never move the parts after they have been pasted. To do so now 
will make the spacing work done at the end much more tedious!  

First, we should explain why this example is so complex. In this case, the original EPS includes strokes 
and paths. Since we are interested in making a Type 1 or Truetype font (where strokes are not allowed) 
we will be doing some extra work in Fontographer to turn those stroked paths into outlines by using 
"Expand Stroke." 
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Also, the circle in this logo, along with its "Macromedia" against the black background and "Service Plus" 
against the white, has to be divided into four sections which must meet precisely when typed out. After 
completing the circular border with the first four characters, the "M" will be typed, centered in the circle. 
Notice the two finished sections of the circle below. Each section is in one character cell, in this case the F 
and G characters. We have turned Preview mode off in Fontographer to better see the points in the 
character. 

 

Notice how the semicircular border around the "Service Plus" consists of two paths; one outer and one 
inner, creating a stroke effect when seen in Preview mode. In the original EPS, the path had a stroke 
weight applied. We duplicated that for use in a font by using Fontographer's Expand Stroke command. 

Step 2 - Getting the Paths just right  

Often the eps will have paths which overlap, or even have points in a path on top of other points in the 
same path. This is no problem for a drawing program such as Macromedia FreeHand, but it means 
trouble for a font. We used Remove Overlap on this artwork in order to get rid of all these problems. 
Another problem is paths with superfluous points. Fontographer contains a new feature found under 
Element > Clean Up Paths which will remove all those unnecessary points without disturbing the shape 
of the path.  

Finally, we turned the preview mode back on, which revealed one last problem, illustrated below 
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The left picture shows just the black semicircle with no "white" letters: Not at all what we hoped for! We 
must select "Correct Path Direction" under the Element menu in order to correctly display the the 
unfilled "Macromedia" against the black background of the semicircle. This is important because the 
paths must be set so that the first path is clockwise, the next path counterclockwise, the next path (in this 
case a counter within a letter) clockwise, etc. Correct Path Direction does this automatically. 

Step 3 - Spacing the parts to look as one  

Now that we have the five parts in five characters and have cleaned up all the original paths to work 
properly as a font, it is time for the final step; spacing the 5 characters so that they look just like one 
when seen in the document.  

Select "Open Metrics Window" under the Windows menu. This window can be used to preview the 
character positioning. Type in all the logo characters. 

The window should look something like this: 

 
See how each part has maintained the same point locations it possessed when it was a part of the whole 
logo? Also, each character still has the same width as the original. This makes getting the spacing perfect 
very straightforward Ñ if you are going to be using this font on a Macintosh!  

For the Macintosh font, simply set the width of the first four characters to zero. Leave the M alone with 
the full width. Then when you type the first four, the cursor will stay put while all the parts collide to 
form the circle. When the M is typed, it will appear centered in the circle, and the cursor will jump 
ahead to the full character width. 

However, if you are using your font in Microsoft Windows you will not be able to set your characters to 
a zero width. You will have to manually set the width of your characters in the metrics window by 
estimating the amount of em units needed for the logo to display correctly. 

Windows printer drivers do not appreciate the concept of a zero width character. They seem to like all 
characters to have some advance width, so when a character with a zero width setting is encountered, 
Windows will automatically advance the cursor, like it or not. For our purposes, we do not like it. So it 
becomes necessary to set up each part in the logo to have a width setting. Here are the simple steps. 
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Set all characters to a width of 100 except for the last one. This width will be the amount that the cursor 
advances after a character is typed. Then to offset for the cursor advance, move the part in the character 
cell by 100 em units to the left. 

Character 1 - advance width 100 ems 
Character 2 - advance width 100 EMS then Move horizontally -100 
Character 3 - advance width 100 EMS then Move horizontally -100 x 2 = -200 
Character 4 - advance width 100 EMS then Move horizontally -100 x 3 = -300 

Where the x 2 and x 3 equal the number of characters moved beforehand. Drag the right-hand 
sidebearing of the last character out to the right until it is just beyond the right-hand edge of the logo. 
The cursor will advance to this position after the logo is typed. 

The finished product will now appear in the Metrics window below: 

 

Step 4 - Saving and Generating Logo Font Files  

1  Go to "Font Information" under the Element menu, give the font 
a Family name and select the proper encoding for the project.  

2  Select "Save As..." under the File menu in order to create a 
Fontographer database.  

3  Print your logo from Fontographer for testing purposes. 

4  Select "Generate Font Files" under the File menu. Be sure to 
enter some bitmap sizes to output or you will not generate a 
screen font for the logo.  

5  Install as appropriate for the destination platform (Macintosh or 
Windows).  

6  As you type the keystrokes you will notice that the characters 
are displayed on top of each other. When you are finished 
typing the logo characters will automatically position themselves 
correctly.  
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Check for correct display as well as printing at different point sizes.  

 

Troubleshooting  

Text in my EPS doesn't show up in Fontographer  

Answer: You didn't convert the text to paths when you created the EPS.  

I get an error "Path too complex Error ID = 11500"  

Answer: The image has too many points. The image is too large and must be made smaller by removing 
objects or points.  

Syntax Error ID = 11200  

Answer: Results from trying to import an image which has no paths. If you are working with an image in 
Freehand or Illustrator which is a scan or TIFF or PICT you must do an AutoTrace in order to convert this 
image to a path form.  

Additional Information  
Bezier Control Points (BCPs) or other points may lie within or on top of other points and may not be 
visible. This is why we break the artwork into separate characters. 

Make sure your Preferences (under File Menu and Point Display) are set to "Show Coordinates for 
Selected Points" and "Hilite Adjacent Points That Overlap". 

Use "Next Point" (Command-/) under the View menu to manually inspect the path direction. 

If you are following the path in the font Outline Window (using Command-/) and suddenly don't see a 
point selected but the next point is selected you have narrowed the problem to within two points. 

You should use "Merge Points" under the Points menu or drag a suspected point out of the way and 
delete the underlying point. 

Additional Information 

Bezier Control Points (BCPs) or other points may lie within or on top of other points and may not be 
visible. This is why we break the artwork into separate characters. 

Make sure your Preferences (under File Menu and Point Display) are set to "Show Coordinates for 
Selected Points" and "Hilite Adjacent Points That Overlap". 

Use "Next Point" (Command-/) under the View menu to manually inspect the path direction. 
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If you are following the path in the font Outline Window (using Command-/) and suddenly don't see a 
point selected but the next point is selected you have narrowed the problem to within two points. 

You should use "Merge Points" under the Points menu or drag a suspected point out of the way and 
delete the underlying point. 

 

#03702: Commonly asked questions  

How long has Fontographer been on the market?  
Since its introduction in 1986, Fontographer has remained the industry-standard for font-creation 
software.  

What type of fonts does Fontographer generate?  
Fontographer can generate different kinds of fonts for both platforms, as follows: 

 Fontographer for Macintosh: 

 Type 1 PostScript language fonts (for Macintosh 
and Windows)  

 Type 3 fonts (for Macintosh and Windows)  

 TrueType (for Macintosh and Windows) 

 Multiple Master fonts (for Macintosh)   
 Fontographer for Microsoft Windows: 

 Type 1 PostScript language fonts for Windows  

 TrueType fonts Windows  

 Type 3 PostScript language fonts for Windows  

 Type 1, Type 3, and TrueType fonts for 
Macintosh (each requires the Macromedia 
MMPC2MAC utility supplied in the box) 

 PostScript Type 1 for UNIX (NEXTSTEP and 
Solaris)   

Are Fontographer-created fonts compatible with Adobe Type Manager?  
Yes. 

Can Fontographer edit more than one character at a time?  
Yes. There are many transformations that can be applied globally, such as: change weight, change width, 
scale, skew, rotate, move, flip, auto spacing, and auto kerning. 

Can I scan a picture of my signature and make it a font?  
Yes. 
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How can I make a font out of a scanned picture of my company logo?  
After scanning your logo with a scanner, save the scanned image in the PICT or BMP file format 
(Fontographer will not accept TIFF files). After bringing the image into Fontographer, you can use 
Fontographer's autotrace feature to create character outlines. Then use the normal font-generation 
procedures to create a font. 

Can Fontographer autotrace more than one character at a time?  
Yes, but only if the characters are all in the same character window. 

Can Fontographer import my artwork from programs like FreeHand and Illustrator?  
Yes. Fontographer imports EPS files. 

Can Fontographer output my characters to Freehand and Illustrator?  
Yes, Fontographer generates EPS files that can be used in any other program which supports the EPS 
format. 

Can Fontographer create fonts based on other fonts in my system?  
Yes. Fontographer can do this in a couple of ways: 

 You can change the weight, angle, and shape of existing fonts. 
This one-command feature allows you to create a version of an 
existing font that is bolder, condensed, extended or oblique (or 
all of the above). 

 You can create a completely new font by blending between 
any two fonts in your system. 

Can Fontographer be used to create foreign language characters?  
Yes. Many of the foreign language fonts you see in use today were created in Fontographer. 

Can I use an existing font to make it into a foreign language font?  
You cannot automatically convert an English language font into a foreign language font. However, 
Fontographer is used by many professional type vendors to create foreign language fonts (either by 
modifying existing fonts or creating new fonts from scratch). 

How will I access the characters once I create them?  
After you generate your characters as a font, you will install the font in your operating system. In a text-
editing or graphics program, you access your Fontographer-generated font as you would any other font.  

Can you convert Windows fonts to Mac fonts?  
You can bring the font through a network, or put the font on a DOS disk and then use the Macintosh File 
Exchange feature to place the Windows font on the Macintosh. You can then use Fontographer for 
Macintosh to open the font. 

Will Fontographer accept an image in the TIFF file format?  
No. Fontographer will accept images in the PICT or BMP file format. 

What is the difference between Type 1 and Type 3 PostScript fonts?  
Type 1 fonts are smaller, faster to print, better looking, and work with ATM. However, Type 1 characters 
must be entirely black. Type 3 fonts, on the other hand, can have grayscale fills and strokes, as well as 
other special effects. Type 3 fonts are bigger, slower, look worse in very small point sizes or at low 
resolutions (up to 600 dpi). Further, Type 3 fonts do not work with ATM. In almost all situations, you 
will want to create Type 1 fonts. 
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Since I can already manipulate type in my favorite drawing program, why should I use 
Fontographer?  
Unlike a drawing program, Fontographer will create a font that can be used in any program with a font 
menu. This means you can use your fonts in programs such as FreeHand, Excel, QuarkXPress and Word. 

Will the fonts I create with Fontographer print at my service bureau?  
Yes. Many of our users need to output their work on high-end imagesetters. Fontographer can create 
PostScript font files that will image at the highest resolution of the printer. 

Can I assign graphics or characters to any keystroke I want?  
Yes. Fontographer also prints out a key map showing the location of all the characters (in case you forget 
where you placed them). 

Will Fontographer allow me to adjust character spacing for a headline or package design?  
Yes. Fontographer will automatically adjust both the spacing and the kerning of your entire font. You can 
also manually adjust the spacing and kerning yourself. Or, if you would prefer to have complete control 
over every aspect of your font, you can take advantage of the advanced spacing and hinting options.  

Is Fontographer just for people who want to create an entire font?  
Most users purchase Fontographer so they can modify or add to the fonts that they already have. Many 
designers or publishers discover, after spending hundreds�”if not thousands�”of dollars on PostScript 
and TrueType fonts, that they still need a tool to modify their fonts for special circumstances. (For similar 
reasons, designers normally purchase clip art that they can edit or manipulate to suit their needs.) 

Although a Fontographer user may be creating brand new fonts (and some do!) in order to start up a 
new type foundry, most find Fontographer an easy way to make modifications. These modifications can 
include adding characters (such as symbols, dingbats, or logos), globally changing a font (such as making 
it bolder), or preparing a font to be moved from one platform to another. 

  

  

 

#03703: Out of Memory Errors in Fontographer for Windows  

Issue: 

1) Import a .bmp into Fontographer's Edit window to Autotrace and get an Out of Memory error. 
2) Attempt to Autotrace the back ground image and get an Out of Memory error. 

Reason: 

The Out of Memory message which Windows gives when tracing a scanned image or importing an EPS or 
bitmap, is sometimes invalid, that is, Windows is not really out of memory. When this happens, it is due 
to the system using up all of its allocated Break Points. 

Solution: 

This situation can generally be averted by adding the following line to the [386enh] section of the 
SYSTEM.INI, exactly as follows:  
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MaxBPs=768 

Credit where credit is due: 
This helpful hint is from an article in Infoworld (Windows Manager by Brian Livingston). 

 

#03704: Missing characters in Windows 

Issue 

 
When generating a Truetype font for Windows in Fontographer 4.0.4, some fonts will lose the hyphen, 
periodcentered, or mu characters. Typically this will occur when the source font is a Truetype or is a 
Macintosh encoded PostScript font. When opening an Adobe PostScript font, this will usually not occur.  

Reason 

 
This may seem like an atrocious oversight by our testing department, but there is an interesting 
background to this problem. When Windows 3.1 and the Truetype spec was being developed, Microsoft 
was careful to make the encoding compatible with Word for Windows. This required them to designate 
different glyphs for these three characters than what the original Truetype spec called for. So, rather than 
fixing Word for Windows, Microsoft chose to kludge the Truetype spec. We knew about this after it 
happened and created a workaround, but late changes to the UGL encoding in 4.0.4 short-circuited the 
workaround. Now you know the rest of the story!  

Solution 

 
First, go to Font Info and change the number of characters allowed in the font to include an additional 
three characters. Also change the encoding to Custom. Be sure to also use Custom when generating the 
font.  

For Hyphen:[-]  

1  Choose one of these new slots and copy the hyphen into this 
cell. Get the character information (Command-I) and change the 
name to hyphenminus.  

2  Then choose Set Unicode. Press the OK button to close the 
dialog. 

3  If you set the Font window to View by: Unicode, the number 
002D will appear above the newly placed hyphen at the end of 
your font. Don't worry that it is out of place or duplicated. For 
Windows, the unicode number is all that matters. We don't 
recommend that you change the character information on the 
real hyphen because then the font will not work on a Macintosh 
with Macintosh encoding. 

For Periodcentered: [·]  
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1  Choose one of the new slots at the end of your font and copy 
the periodcentered into this cell.  

2  Get the character information (Command-I) and change the 
name to bulletmath. Then press the Set Unicode button. 

3  Click OK to close the dialog. If you set the Font window to View 
by: Unicode, the number 2219 will appear above the newly 
placed periodcentered character. 

For the Mu: [μ]  

1  Choose one of the new slots at the end of your font and copy 
the mu into this cell.  

2  Get the character information (Command-I) and change the 
name to micro. Then press the Set Unicode button. 

3  Click OK to close the dialog. If you set the Font window to View 
by: Unicode, the number 00B5 will appear above the newly 
placed mu. 

4    

 
Generate your Windows Truetype font with Custom encoding. The once missing characters should 
function correctly after installation on Windows. The other font formats you make from this same 
database will also continue to work unchanged.  

 

#03705: Error= -11501, Could not open file- unknown format  

Issue: 

When trying to open a file in Fontographer 4.x for the Mac, you get the error, "Could not open the file 
because it is in an unknown format error = -11501"  

Reason: 

1. Trying to open the bitmap font instead of a printer font file or truetype font suitcase. 
2. Trying to open a Postscript Type 3 font which was not generated by Fontographer. 
3. Trying to open a Printer font that has in some way been damaged. 

A: Fontographer will not open a Macintosh font suitcase with only Bitmaps in it, EVEN THOUGH this 
suitcase is selectable from the Open... dialog. To determine whether Fontographer will be able to 
successfully open a Font Suitcase, go back to the Finder and open up the suitcase. If this suitcase contains 
an icon with THREE A's (which shows that a TrueType font is present in this suitcase), then Fontographer 
will be able to open it. If the suitcase contains ONLY icons showing a single A (which signifies a Bitmap 
font) and has no icon with THREE A's, Fontographer will not be able to successfully open this font file. 

B: A type 3 font file will not reside in a Macintosh font suitcase. If you encounter such an error opening a 
font which you know to be a printer font, it is probably a Type 3 in an unknown format. This would 
commonly occur with fonts from "The Art Importer" or very old commercial fonts from foundries such as 
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Bitstream. Fontographer 4.x should be able to open Type 3 fonts from Fontographer version 2.1 and 
later. If Fontographer cannot open the font, you may want to print the characters from another 
application and scan the printout, then convert the scanned image into a font. 

Solution: 

Locate the original outline font and use it. You will need to find the printer font file associated with this 
particular bitmap font. This printer font file will have a truncated name and will probably reside in the 
same folder as your bitmap file, or possibly in your "Extensions" or "Fonts" folder (in your System 
Folder). 

 

#03706: Fontographer and sounds 

Issue 

 
Adding new sounds, changing sounds, turning off sound in Fontographer. 

Reason 

 
Fontographer can sound to let the user know when you snap to a point or snap to a guide in the Outline 
Window, and it plays a sound whenever the "Please Wait" dialog closes. 

Solution 

To turn sounds on:  

1  Locate the Fontographer Sounds file. Depending on which 
version of Fontographer you have, it may be found on 
Fontographer Disk Two, or you may need to reinstall to retrieve 
it.  

2  Place the file into the same folder as Fontographer. 

3  Don't change the name of the file, because Fontographer looks 
for that name specifically. 

To change sounds using ResEdit:  

1  Find the sound file you wish to use.  

2  Convert the sound into an snd resource if necessary. 

3  Use ResEdit to paste the snd resource into the Fontographer 
Sounds file. 

4  Then use ResEdit to name the resource as one of the following: 
 
Snap to point 
Snap to guide 
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Operation done 

The spelling must be exact. 

To stop sounds from being used in Fontographer remove the "Fontographer Sounds" file from the 
Fontographer application folder. 

 

#03707: Fontographer and RAM Optimization 

Issue 

Macintosh Fontographer uses a lot of RAM. 

Reason 

When a font is opened, it is retained completely in RAM. A font database can easily exceed 500K. 

Solutions 

1.     If you want to work on four fonts at once with several Outline Windows open, the 
recommended 3,500K may be inadequate. 

To increase your memory partition, simply close Fontographer, go to the Finder, select the 
Fontographer icon, choose "Get Info" from the File menu, and increase the suggested memory 
setting to 4,000K or more. 

2. To save memory, use the "Preferences..." dialog to reduce the number of undos. 

3.     To get faster performance in the Outline Window, turn off "Snap to Points" in the View menu. 
Also, go to the Preferences dialog's "Point display" pop-up menu and turn off "Show points 
while dragging paths." 

If you are running in 24-bit color mode, get a bit flipper which will turn that down to one bit 
when Fontographer is running, or go to your Monitor Control Panel and select "Black and 
White". 

  

 

#03708: Steps to help blending fonts 

Issue 

 
Blending Plain and Bold faces to create a medium face. 

Solution 
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In order to blend a font, the two source characters being used must have the same number of paths or 
Fontographer won't blend them. 

1  Turn on the radio buttons for "Correct path direction first" and 
"Insert points to force match."  

2  Check to see if any characters look bad or are missing in the 
destination font. They will look bad due to mismatched path 
order or mismatched origin points. You will need to fix those 
manually. 

3  Now try "Blend Fonts" again on that character. Click the radio 
button for "Select characters of destination font." Click off the 
check box for "Correct path direction first" and "Insert points to 
force match." 

If that does not solve the problem then other measures are necessary: 

1  Select from "Preferences" the point display pop-up menu that 
shows labels for all points. This will let you to see the order of 
the points.  

2  Insert similar kinds of points in the same order and position in 
each source character and try again. This time also turn off the 
check box "Insert points to match." Keep it off from here out. 

3  If your fonts do not have the same ascent/descent you may have 
to change these settings in the "Font Info" dialog. You also may 
have to adjust how the characters fit on the baseline. 

 

#03710: Erratic Printing or Display of Windows TrueType Fonts 

Issue 

Some Windows Truetype fonts display on the screen erratically. Sometimes a font will display the right 
character, but at other point sizes it displays an empty rectangle. Also, the font will sometimes print a 
rectangle to the printer, instead of the character. 

Solution 

This is a compilation of techniques we have developed over the years to coax Windows Truetype fonts to 
print and display. Problems are usually due to the Truetype rasterizer which ships with Windows. If you 
are having problems with complex characters (logotypes, signatures, etc.) displaying on the screen or 
printing, here are a few things you can do to try to remedy the problem. 

• Trick Windows into using the big rasterizer, thus allocating more memory to the font. 

Max X: Windows determines how much memory to allocate to font rendering by checking the 
Max X setting in the font. Max X is the point with the largest horizontal value. If your font is 
based on an em of 1000, then scroll out to near the right hand edge of the window (at about 
7700 ems) and insert a single point. 
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When Fontographer generates that font, it will insert the new value but it will not display the 
loose point. When the font is installed, the Truetype font rasterizer will allocate more RAM to 
render characters in that font. 

Avg X: Windows averages the width of all the lowercase characters, and the space character, to 
determine how far to place the cursor after each keystroke. If your lowercase characters are not 
defined, the average is zero. In this case, open each lowercase letter, and assign a width 
appropriate to your large, uppercase characters. This will cause Windows to allocate more 
memory for each keystroke. 

• Try generating the font without hints. In complex images, hinting can do more harm than 
good. 

• Rearrange your logo into multiple keystrokes, as described in Creating a complex logo font 
(TechNote 03701). 

When a single character is just too complex to print, break the logo into parts which can be 
placed into multiple keystrokes. In Windows, it is necessary to set the first character's width to 
more than zero. If you can set it to 100 EMS, that would be sufficient. To get the whole logo, 
you will then have to type several characters, each of which will pile on top of the last one, until 
the final character in the series finally moves the cursor to the right to give the character its true 
width. This feat is best accomplished in the metrics window. 

However, if for some reason you must have the character print using only one keystroke, divide 
the character into two or more parts, for example, in the X and Y character slots, and spacing as 
described above. 

Then, use the Get Part (or Link Reference in Fontographer 4) command on the X character, and 
paste the contents of the clipboard into the A slot. Perform the same operation with the Y slot. 
This creates a composite character and fools the printer into printing because all the information 
is really in two slots, not one. 

 

#03711: Scanning and autotracing in Fontographer  

Many font developers use scanners to create bitmap images of their lettering and artwork. Fontographer 
can use these scanned images as a basis for creating outlines for characters in a font. 

Basic Process  
Below is a summary of the basic process for using scanned artwork to create vector outlines in 
Fontographer: 

1  The font developer creates artwork for the font's characters.  

2  The artwork is scanned on a scanner to produce a series of 
bitmap images. 

3  The bitmap images are opened in a bitmap editor, such as 
Fireworks, Photoshop or Paint. 

4  In the bitmap editing program the images are prepared to be 
pasted into Fontographer by placing them inside a consistent 
bounding box so the appropriate scaling for each character will 
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be preserved.  

5  The bitmap images are copied in the bitmap editor.  

6  The bitmap images are pasted into Fontographer. After being 
pasted from the Clipboard, the images reside on the Template 
layer of the Outline Windows.  

7  Fontographer traces each bitmap image to create vector outlines 
for the characters.  

8  The path outlines for each character are smoothed and corrected 
using Fontographer's pen tools and menu options.  

9  A test printing of the font is examined to see if further tweaking 
is needed.  

Step 1: creating the artwork for the font's characters 
The drawing for each character should be at least 2 to 4 inches high. If necessary, enlarge your drawings 
on a copy machine. The cleaner the original artwork, the better the results from scanning (and the better 
the results in Fontographer). 

Step 2: scanning the images 

 Resolution  
Scan each character at 300 dpi. Don't try to scan a small 
character at 1200 dpi�”that will be too much information for 
Fontographer's Auto Trace tool. The largest scanned image you 
would want to try to use with Fontographer is one that is 4 
inches tall at a resolution of 400 dpi.  

 Placement of the image on the scanner.  
Be very careful to place the artwork page on the scanner so 
that the resulting bitmap images are not at an angle or skewed. 
It may be difficult to restore them to the angle or uprightness 
that you originally intended.  

 Set scanning depth to Black and White 
Once the bitmap image is pasted into Fontographer, variations 
in color will be ignored. Scan at a depth set to to Black and 
White or 1-bit. 

 Saving the image after scanning  
After the scan is finished, save the image as a PICT file for 
Macintosh or a BMP file for Windows.  

Step 3: opening the bitmap images in a bitmap editor 

 Macintosh  
Using a recently-released paint 
program, open the PICT file. Don't 
use a program which will decrease 
the resolution, such as MacPaint. 
Canvas 2.0, Fireworks, PhotoShop, 
or Digital Darkroom will work.  
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 Windows  
Open a BMP file in the Paintbrush 
utility supplied with Windows or 
with a bitmap editor such as 
Fireworks or Photoshop. To open 
the Paintbrush program supplied 
with Windows, navigate to Select 
the Start > Programs > 
Accessories > Paint.  

  

 To open a file, choose File > 
Open. Navigate to find your 
bitmap image. You may want to 
use some of the bitmap editing 
tools to smooth out your drawings. 
You can see how the scanned 
images first appear in Fireworks in  

To scale to the em 
square. 
Choose Edit > Paste. 

 To scale between the ascent 
and baseline. 
While pressing Shift-Option 
(Macintosh) and Shift-Alt 
(Windows) choose Edit > Paste.  

  

 To not scale at all 
While pressing the Option key 
(Macintosh) or Alt key (Windows), 
choose Edit > Paste.  

  

4 Repeat steps 1 through 3 for each character.  

Fontographer automatically pastes the image into the Template layer where it will be shown as a solid 
gray image. See Easy  
This option keeps the default Curve fit to 5. The tighter your curve fit, the more points you'll have on 
your character. It is better to have as few points as possible to preserve your shape. Advanced  
See "Advanced Tracing Options" (pages 32 - 34) in the Fontographer Users Manual for more information 
about these additional choices.  

Step 8: cleaning up 

  

 Removing the bounding box.  

1  With the Outline Window open for the character, select 
the Outline layer on the Layers palette.    

2  To be able to see the outlines clearly, make sure that 
View > Preview is not checked.    

3  Choose View > Show Points to display the paths' 
points on the character.   

4  Click the Selection tool.   

5  The bounding box should have two paths: an outside 
one and an inside one. Select one of the paths by 
double-clicking on the edge of the path. When points 
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are selected, they turn from solid black to a black 
outline. The path should have all of its points selected 
(small black outlines).  

6  Press the Shift key and double-click on the path of the 
second path of the bounding box. Now both paths 
should be selected. You can see the two selected paths 
in  

Adjusting the path outlines  
In all likelihood, you will want to do some additional tw
the characters' paths after the Template images have be
the background image to judge how close the trace is to
scan. Points can be moved by dragging them with the S
curved point can be converted to a corner point by sele
and then choosing Points > Curved Point. (And vice ver

 Re-scaling  
If a bounding box was not created around the 
character before importing the bitmap, then it will be 
necessary to scale and move the image now. Do this 
using the "Scale" and "Move" items in the Element > 
Transform dialog for just one character in the font. Use 
the Undo command liberally while finding the correct 
Scale/Move settings. 

Notice the exact scale and value and apply that scale to 
every character by using "Select All" in the font 
window. 

  

 Cleaning up paths  

1  With the Outline window open for a character, 
choose Edit > Select All to select all the points.  

2  Choose Element > Clean Up Paths. 

3  Select Insert points at extrema and simplify paths. 

4  Make a choice between Less and More.   

  

 Deleting unnecessary points  
Due to the scanning process and that fact that 
Fontographer had to trace a bitmap image, you may 
find odd kinks in your paths (see  

Adjusting the BCP handles. 
You may also want to change or adjust a curve by: 

1  With the 
Selection 
tool, 
click the 
curve 
point on 
the 
path. A 
curve 
point 
will have 
two BCP 
handles, 
as 
shown 
in  

Deleting the Template image. 
Once you are through tracing, you should
Template image.  

1  Select the Template layer in the Layer

2  Click inside the Template image. Whe
Template image is selected, you will s
outline surrounding the image with sm
cross-hairs in each corner. 

3  Press Delete or Edit > Cut.  
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Step 9: test printing  
You may want to do a test printing to see how the chara
remember that the test printing is only an approximatio
text will look like as a generated font. There are many o
Print Sample dialog box (File > Print), all of which are e
detail in Fontographer's User Manual (pages 176 -179). 

  

  

#03712: Large font families in Windows 

Issue 

ATM for Windows only allows four fonts in a font family. 

Reason 

The styles it allows are Roman, Bold, Italic, and Bold Italic. (The Roman style may be called Normal, or Plain, or Book
Therefore, when you need to use all six weights of Adobe's Garamond, for example, Windows can't accommodate yo
workaround for Truetype fonts is to rename the family. 

This will allow you to assign a different family name for the extra weights in a font family so you can access them from
your favorite Windows applications. But the downfall of this method, is cross platform compatibility. A document form
Mac with "AdobeGaramond-BoldItalic" will not display on the Windows if the font name has been changed to 
"AdobeGaramondBold-Italic". 

Solution 

Fortunately, there is a more effective solution for PostScript fonts. 

Let's assume we are working with the six member Adobe Garamond family. When you have converted your Adobe Ga
to Windows PostScript fonts, open (or generate) the *.INF files for all six fonts. 

The fields we will be interested in are: MSMenuName and VPStyle. 

1  Look first at the MSMenuName field. They are all the same 
right now, but we need to change them in the -Bold and -
BoldItalic INF files. This field determines how the fonts will 
appear in the font menu in Windows applications.  

2  Change the MSMenuName for both the -Bold and -BoldItalic 
INFs to "Adobe Garamond Bold", or anything your desire. This 
will differentiate it from the base four fonts so that ATM can 
install all six.  

3  Now look at the VPStyle field. This uses the following code: 
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Plain = N, Bold = B, Italic = I, and BoldItalic = T. As 
generated, the INF for the Semibold and the Bold fonts both 
have B. Having changed the MSMenuName, we now must 
change the VP style for the Bold to N, and the BoldItalic to I. 
Doing this will cause ATM to designate these as the normal 
and Italic styles for the Adobe Garamond Bold menu "family".  

Having completed this exercise, you are almost ready to install the fonts. You may have noticed that we have been ch
file and ATM uses the PFM and PFB to install a PostScript font. 

The trick here is to generate ONLY PFB, AFM and INF files -no PFM! ATM will "see" the .inf and automatically build a 
info supplied in the AFM and INF files. ATM will display the six fonts by MSMenu Name, with a style appended to it i
style is derived solely from the VPStyle. When the fonts are installed, run any app which uses fonts and you will see tw
font menu, with the styles tucked safely away inside. 

Now your fonts have full compatibility across platforms and you can have as many PostScript fonts from one family in
Windows as you do on your Mac! 

  

 

#03713: Encoding vectors FAQ 

Question 

Why do special characters print with symbols instead of the special characters? 

I've created a wonderful font that has some special characters in the upper 128 range of characters (the 
shift-option- and option- characters on a Macintosh) and the characters look fine on screen, but when I 
print them out to a PostScript printer, I get really weird results, with Symbol characters appearing in 
place of the nice characters I put in the font. 

Answer 

You've chosen "Adobe Standard Encoding" in the Generate font files... dialog. You should never do this 
for Macintosh fonts, unless you want the characters from the Symbol font substituted for your own 
characters. Try using "Macintosh" encoding and all will work well. The character positions which are 
impacted are Dec (decimal) values 173, 176, 178, 179, 182-186, 189, 195, 197, 198, 215, and 240 in 
the Macintosh encoding vector. Any character which you may have in these locations will remain in the 
font, but will not be printed to PostScript printers. Instead, the Symbol font substitute character will 
print. 

Question 

How do I keep my custom encoded font from getting re-encoded to Macintosh? 

Answer 

In the File menu, select Preferences.... In General Preferences, set the preferences like this: 
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When the user types a key to choose a character: 

Use the font's original encoding to choose the character (Note: PC only) 

Unless this font is being created on a Macintosh, in which case the following setting is used: 

Use Macintosh encoding to choose the character (Note: Mac only) 

When reading an outline font: 

Keep the font's original encoding 

Also, when generating the font after you have completed your edits, if you use the "Advanced" settings, 
be sure to select "Original" from the "Encoding" pop-up menu. 

Question 

Can Fontographer edit the Symbol or Dingbat fonts? 

I want to edit a Symbol or Dingbat font, but when I open it in Fontographer, all the characters are in the 
wrong places, beginning at Decimal 256. Or, similarly, in the Keystroke or Character view, a double 
asterisk (**) appears in the label above most characters. 

Answer 

Yes, this relates to keeping the fonts original encoding. Even on the Macintosh, there are many specially 
encoded fonts. This would include any font which uses special character names not found in the 
Macintosh encoding vector. A tip off that you are opening a custom encoded font appears in the "Please 
wait" dialog. If you see the message "Reading glyph encoding" then you've got a font format 
unrecognized by Fontographer 4.x. 

If you have your Preferences set to "Re-encode each character to Macintosh encoding" then 
Fontographer will put each character in the font in the appropriate position for the Mac encoding. But 
since your custom font has non-Mac character names -- as is the case with Zapf Dingbats -- none of the 
characters fit into the Mac encoding. So they were all put down at the end of the font window, with their 
custom names retained. By selecting "Keep font's original encoding," Fontographer will keep the 
characters in the positions assigned for them by the encoding vector. 

Even if you retain the fonts encoding, you still may have cause for confusion. In the General Preferences, 
the default setting is "Use Macintosh encoding to choose the character." However, this is the wrong 
setting for custom encoded fonts since many of their characters don't fit into the Mac encoding vector. 
By changing the option for viewing keystrokes to "Use the font's encoding to choose the character," 
Fontographer will give your the correct keystroke and character label above each character. 

Question 

How do I create a font for the Macintosh for use with a particular language (script)? 

Answer 
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For a Type 1 font: When you Generate Font Files..., switch to Advanced mode, set BITMAP ID: to a value 
in the script range for that language (see User's Guide pg. 194 for script ID ranges), and Generate. For 
TrueType, set the Outline font ID: and Bitmap ID: to a value in the script range. 

For a complete listing of all the language scripts implemented by Apple, consult Inside Mac, Volume 6. 

  

 

#03714: Special Effects Fonts 

Fonts with white filled counterspaces 

Issue: 

I need a font which can be used in a graphics program with a color background. The problem is, I don't 
want the color to show through the insides of the characters. All the Type 1 and TrueType fonts I have 
tried this with, show the color of the background through the inside of the characters. 

Solution: 

What you are referring to is commonly known as an "opaque counter" font. The counter refers to the 
inside paths of characters. This effect has long been relegated to the domain of Type 3 fonts, since Type 
1 fonts can't have non-black filled characters. Thanks to David Jenkins, a veteran Fontographer user, we 
now have a better solution in a Type 1 font format. There is a prior requirement, however. The font will 
only have the opaque counter effect in programs which support colors and kerning. Since most graphics 
programs include these features, this should not be an issue. The good part of this is that this font will 
operate in a perfectly normal Type 1 manner in apps which do not support kerning and/or colors. 

To help you more easily understand this rather long process, we have included the font used in our tests 
in the sample fonts directory. It is named "Opaque Counters." 

Select the font you want to use. The characters with inner paths will be copied into other character cells. 
For brevity, we will look only at the numbers with inner paths for our example. Typically, that will 
include 0, 4, 6, 8, and 9. Now for the steps: 

1. Copy the 0, 4, 6, 8, and 9 to new locations. Make sure these locations can be accessed with the 
keyboard. For instance, don't use the Control characters (0-31 decimal) or 32, 127, or 202 in 
the Macintosh encoding vector. For our example, we will put them in the Option key 
equivalents-O0 (as in Option-zero), O4, O6, O8, O9. 

2. Open the edit window and delete the outer paths of all these characters. 
3. From the font window select the 0, 4, 6, 8, and 9 you have copied into the Option locations and 

choose Correct Path Direction from the Element menu. Then immediately select Transform? 
Scale Uniformly, Center of Selection, at 104%. 

4. This scale will change the widths of the Option characters. Now select the original 0, 4, 6, 8, and 
9 and Copy Widths from the Edit menu. Then paste into the new Option character locations. It 
may be a bit confusing, but after Copy Widths is chosen, all that will paste into the new 
characters is the widths just copied. 
 
Now you have done all the editing of the outlines; the rest of the work will be in the metrics 
window. 
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5. In the Metrics window text entry field, type the following string, but without the commas and 
spaces: Opt-0, 0, Opt-4, 4, Opt-6, 6, Opt-8, 8, Opt-9, 9. 

6. Then, place your cursor in the kern field of the Opt-0 metrics and press Tab to go to the next 
character. The kern value will be highlighted. 

7. All that remains is to set the kern value for each pair to equal the width of the character. In the 
above example, type "-553" into the highlighted field. Then tab twice to get to the next pair. 
and type "-436." Repeat these steps until all the number are kerned to their respective counters. 

8. Generate the font as either PostScript with bitmaps or as TrueType. Then install the font. For 
more information on font generation or installation, refer to chapters 7 and 9. 

Reasons: 

Now for the background on why you are doing all this. Since Type 1 and TrueType fonts are filled only 
between paths, we must make a path which will be placed behind the real character and can be colored 
to obliterate the image yet behind it. When two characters are kerned together like this, the first 
character is BEHIND the second character. The reason we made the counter a little bigger is to allow for 
any error in printing calibration, so that no color from the back ground could show through the cracks. 
When you kern these characters, they will look like you have filled inner paths in the metrics window. 
That is why we need to color the counter path, so that the inside of the 0 will be white -or whatever 
color you choose. 

Using your opaque counters font in graphics applications 

1. Open Aldus FreeHand, Quark Xpress, or whatever you are using, set up your background color 
and text block, but don't choose the opaque counters font yet. 

2. We are going to type the numbers 404. So precede the numbers with their Opt-0 and Opt-4 
counters. This is not the opaque counters font, so it will not kern nor will it look at all correct. 
That's OK for now. 

3. Select the cent sign (Opt-4) and color it white. Then the (Opt-0) and the cent sign again, 
assigning them the color you have chosen. 

4. Now, select the whole text string and select your opaque counters font. 

Presto chango! If your application has kerning turned on, you will see the results as you type those 
characters with kerning pairs. Refer to your documentation of your graphics program to see how auto 
kerning is switched on. 

Now the fun begins! You can give the counters any color you want. The same is true for the actual 
character. Of course, this font will still work just fine in programs which do not support kerning. Also, the 
characters without inner paths do not need any special treatment; they cover the background color by 
nature. 

We hope this will help you in using your fonts in applications when you need to cover the background 
color. 

Making drop shadow fonts 

Issue: 

I want a font with a real shadow effect, not the kind I get from my word processors Style menu. Can I do 
that in Fontographer? 

Solution: 
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Fontographer 4 will let you create drop shadow characters that you can then generate as Type 3 fonts for 
use on the Macintosh. It's really very simple to do. 

1. Open your existing font. 
2. Select the characters that you would like to have drop shadows from the font window. 
3. Use the Copy command to copy those characters into alternate character slots. 
4. Save your font. 
5. Reselect the characters in the alternate slots, go to the Element menu and choose Selection info. 
6. Set the Fill to an amount of 30%. (Note: you can use any grayscale percentage you like.) 
7. Select each character (one at a time), use the Copy Reference command from the Edit menu, 

and Paste the character back into its original open character edit window (that character now 
becomes a composite character). 

8. The composite character in the character edit window will be active. 
 
Note: it is covering your original outline character. Go to the Element menu and choose 
"Transform..." Select Move as the Transformation. 

9. Enter a horizontal offset of -40; enter a vertical offset of -40. 
 
Fontographer moves your composite character to the bottom left. 

10. Move the composite character to the back with Arrange:Send to Back. from the Element menu. 
If you open the metrics window, you'll be able to see that Fontographer has created a drop 
shadow character. 

11. Repeat this process for each character. 
12. Save, generate as a Type 3 font, and install your font. (Note: Type 3 fonts are not compatible 

with ATM or QuickDraw printers, nor are their special effects visible on screen.) 

Now, for something a little different... 

How to create a Type 1 outline style font with drop shadows 

1. Open an outline window for the character. 
2. Expand the stroke of the character. 
3. In the outline window, change the View mode to Preview. 
4. If you want your shadow on the lower right, select all the control points on the right side and on 

the bottom. 
5. Move them southeast to the appropriate depth. 
6. Adjust the control points as necessary for correct appearance. 

 

#03715: Importing font metrics into Fontographer 4.1 

Issue 

 
Font loses leading, spacing or kerning. 

Reason 

 
When Fontographer opens a font file, it reads all the pertinent information in that file. It does not search 
for related files. When opening a TrueType font, Fontographer gets all the relevant metrics data. 
However, when opening a PostScript font, there is some useful data missing. It is missing from the file 
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which Fontographer opened, but can be found in related files, such as the .afm and .pfm, or the 
Macintosh bitmap file. Since certain metrics information is found only in the related files, it is important 
to know how to get that into your font. 

Solution 

 
In order to make sure that your font will behave correctly it is wise to use Fontographer's File > Import 
Metrics feature immediately after opening a font. The valid input files are .afm, .pfm, .ttf, .bmap, and 
.met. Here is a list of the various options under the Import menu: 

 

Import Ascent/Descent 
This will allow you to have accurate leading by importing the exact ascender/descender values for the 
font. This is more of an issue on the Mac than in Windows due to the peculiar ascender and descender 
values in the bitmap file. However, importing ascent and descent from a pfm may result in different 
values than what was interpreted in your PostScript font. 

Import Spacing and Kerning 
Since kerning information is not in the PostScript font, you'll want to extract whatever pairs were set in 
your original font. This will save you from having to make your own kern pairs and keep you from 
needing to adjust the letter and word spacing for your font in applications which support kerning. 

Importing TrueType metrics 
TrueType fonts have complete metrics and kerning data which will give you the ascender/descender in 
em units. Fontographer should automatically import these values when opening a TrueType but 
sometimes changes to the font will change your metrics. If you suspect something is wrong with the 
metrics you should manually import them. 

Importing metrics from the bitmap (Macintosh only) 
On the Macintosh, if you want your modified font to have the exact metrics information as the original, 
you must import the metrics from the FOND in the Macintosh bitmap font. Apple has decreed that the 
FOND's ascender/descender should add up to a total of 4096. This is not a value in em units but an 
Apple determined value. Quark for the Mac sets the baseline for the first line in a text block from the 
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values in the FOND. This would be no problem, except that some font manufacturers do not adhere to 
the Apple guidelines for the ascender + descender = 4096. 

Importing hand-edited bitmaps 
It's also a good idea to import the bitmaps which come with a commercial PostScript font. These hand 
edited bitmaps are often of fairly high quality and are to be preferred over ATM rendered bitmaps. You 
will find the bitmaps in the screen font suitcase. You can Select All or just import one of the point sizes. 

After having imported the bitmaps, it is important then to recalculate the bitmaps on the characters you 
have modified. For instance, let's say you flipped all the vowels backwards. If you don't recalculate the 
bitmaps (set to retain shape) on the vowels, they won't come up on screen reading correctly, i.e., not 
backwards, when you use them at the heights specified by the bitmap. 

Fontographer's automatic bitmap generator will give you more than adequate results, but not PERFECT 
results (after all it is a machine, not a highly trained lettering artist or type designer skilled in the painting 
of bitmaps) So you may wish to go into the bitmap editing window and "clean up" the bitmaps that 
Fontographer provides you, for optimal results. 

When you are generating the font you would enter the size(s) of these bitmaps in the Bitmap Font to 
Output field. When this font is used in an application you will get the bitmaps at the size(s) you imported 
but all other sizes will be rendered by Adobe Type Manager or the TrueType rasterizer 

 

#03716: Generating Windows FON Bitmaps 

Issue 

After generating a TrueType font for Windows in Fontographer, sometimes the screen display of the 
characters is unsatisfactory. 

Reason 

The unsatisfactory display of the font on the computer screen may be occurring because Fontographer 
generates a display of 72 dpi and Windows displays at 96 dpi. You can create and install your own FON 
files for displaying your font at particular point sizes on the screen. Below you'll find instructions on how 
to create and install FON files. 

Display can also become unsatisfactory due to a conflict with your computer's video card driver. 
Changing the driver to the generic VGA driver in the Display Control Panel settings may resolve this 
problem. 

Solution 

Before creating your FON files, you will need to decide which point sizes you are aiming for. Then you 
will have to generate FON files that are larger than the display point sizes you are aiming for. You can 
determine the larger size by applying the "4/3 rule." For instance, if you want to create a FON file 
specifically to display your font at a point size close to 12 points, then you will need to create a 16 point 
FON file (this can be done when you are generating the font). After installing the font and the FON file, 
you can select the font and the 16 point size in your text-editing application so that the font will display 
close to 12 points. 
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The"4/3 rule"  
The 4/3 rule will help you anticipate the larger size FON file you need to generate to better control the 
display of the font on your screen. 

1  Choose the point size you need to display. Divide this number 
by 3 and then multiply by 4. (For instance, 12 divided by 3 = 
4, and 4 x 4 = 16).  

2  Generate a 16 point in order to display it at 12 points on 
Windows. The most popular FON file sizes are: 16,24,32,48. 
For odd sizes (such as 10 pt.), you should round up.  

 
3  When generating fonts, be sure to select TrueType and FON. 

Type in the desired sizes as well. Fontographer will generate a 
*.ttf file as well as the FON files. Both or all of these will need 
to be installed in the Control Panel. *.fnt files are the 
bitmapped point sizes inside the FON which can't be seen or 
edited.  

  Note: For proper font installation, see Font Installation on 
Windows (TechNote 3649). However, see the instructions 
below before installing the FON files.  

Installing FON files 

1  FONs will be listed at 96 dpi in the font control panel.  
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2  FONs will not display correctly (when installed without a TTF) unless 
the Default Printer is set to a non-PostScript printer driver. You may 
be able to see the FON files without the driver in Paintbrush or Write 
but you will need the driver to see them anywhere else. The 
Windows TrueType rasterizer uses the Printer Driver to build the fonts 
(as well as the video card driver).  

3  Always install *.ttf files BEFORE installing the the FON files and do 
NOT install them together by doing a Select All or highlighting them 
together for installation. Do NOT use spaces in the name of your 
FONs.  

  FONs are installed the same way other fonts are, just make sure they 
are installed last.  

Other Issues for Macintosh and Windows-generated FONs  
How the FON files will display in different text-editing applications may vary somewhat. All font data is 
passed from the Windows printer driver to the application which is using the font. Windows text-editing 
applications may vary in their interaction with a given printer driver in such a way that one application 
will rasterize (for example) a 9 pt. FON at 11 pt. in order to display as a 9 pt. Another application may 
need to be selected as a 12 pt. in order to display as a 9 pt. 

If you cannot see the the FON files at the correct size, try switching printer drivers. The best solution is to 
create multiple FON file sizes in each application in order to find the best display for the target point 
size. 

Creating bitmaps for cross-platform use  
Because of the difference in monitor display resolution between Windows and Macintosh, the following 
charts should be used to create bitmaps at sizes which will display properly on both platforms. 

Using Macintosh Fontographer to create bitmaps for Windows 

Creating this size FON on 
Macintosh  

Displays this size FON on 
Windows  
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5  4  

7  5  

8  6  

9  7  

11  8  

12  9  

13  10  

15  11  

16  12  

17  13  

19  14  

20  15  

Using Windows Fontographer to create bitmaps for the Macintosh 

Creating this size NFNT on 
Windows  

Displays at this size NFNT on the 
Macintosh  

4  5  

5  7  

6  8  

7  9  

8  11  

9  12  

10  13  

11  15  

12  16  

13  17  

14  19  

15  20  

In order to confirm that the application will display a FON file at the size expected, open the TTF while 
running the PC Font Access utility which is in the Macintosh Fontographer folder. The lowestRecPPEM 
(which is referred to as the Minimum Pixels per em field in Fontographer 4.1 for Windows) setting 
should never be greater than the lowest point size of the FONs. 

For example, a 10 pt. FON should have a lowestRecPPEM setting of 9. This will keep Windows from 
substituting the MS San Serif font. Instead, the System will go out and look for a FON size above 9 point 
and will find the 10 point FON. 

Additional information  
Fontographer cannot be guaranteed to open FON files which were not created by Fontographer. The 
FON specification has had a wide variation of implementations which means that another application 
may create FONs which will not open in Fontographer. 
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When FON files refuse to work properly, the workaround is to embed the bitmaps inside of the 
TrueType. This method has its own problems and is discussed in Using SBIT32 with Fontographer 
(TechNote 12561). 

  

 

#03717: Characters moving off the baseline 

Issue 

All of the characters in a font get moved above or below the baseline. This is sometimes discovered as 
incorrect leading within an application. It is commonly caused by a stray point above the ascender or 
below the descender. Problem occurs in both PostScript and Truetype fonts. This should not occur in 
Quark, Pagemaker or FreeHand but will happen in most word processors.  

Solution 

1  Determine whether you have set custom leading in the Font Info 
dialog (Macintosh). Some applications (MS-Word or Quark for 
example) may have preferences turned on which ignore your 
custom leading.  

2  Verify whether or not you have changed the Ascent/Descent of 
your em square.  

3  Check for a stray point above the descender or ascender of one 
of your characters.  

4  For test purposes, generate a PostScript Type 1 font with an 
AFM file.  

5  Load the AFM file into any text editor which has a search 
function. Search for "FontBBox." This is the bounding box which 
tells you the extreme dimensions of your em square. Below you 
will observe a clipping from an AFM file.  

1  When diagnosing these numbers keep in mind that AFM files 
automatically normalize the em square to 1000 em units -
regardless of what your em square is within Fontographer. An 
em square of 1000 is a prerequisite for generating a Type 1 
font.  

2  Take special notice of the descender and the ascender values. If 
the ascender is over 1500 or the descender below -350, it is 
likely that there is a stray point in one of your characters which 
is well beyond the ascent or the descent. 

3  You can find this character by searching for the offending value 
via your text editor's search feature. 

For example: FontBBox -124 -730 1247 875 
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The -730 in the Descender is more than -350, so this is the value to search on. Your search would yield 
something like this: 

C 44 ; WX 280 ; N comma ; B 52 -730 229 639 ; 

... so, now you suspect that the stray point is in your comma character. Double-click on the comma 
position in the font window, "Select All," so that all points are selected. This makes the points stand out 
so that they are easier to see. Set your magnification to a small number like 12% so that you can view 
the entire drawing area. 

It is possible to have problems with more than one character so scan your AFM thoroughly. You can 
Reduce view all the way out on the PC (or using the Magnification menu on the Mac) to get a better 
view of the white space around the character. You can now use View Next character (and Select All) until 
you see a point above ascender or below the descender. 

Delete the stray point and regenerate the font. Check your bitmap window. If you had "Preserve 
Character shapes" set in the Recalc Bitmaps dialog, then it will be necessary to recalculate all of your 
bitmap sizes before generating your new fixed font and reinstalling it. 

 

#03718: Hints on Hinting in Fontographer 

Issue 

How can I design my font in a way that will allow it to be effectively hinted? 

Solution 

In general, hinting instructions will affect only: 

The appearance of a font on screen in Adobe Type Manager and the appearance of small text type sizes 
when printed on a 300 dpi laser printer. Characters which evade hinting because they do not fall within 
the size prescriptions described below will generally not be noticeable. 

1. If your version of Fontographer has the "Clean Up Paths" feature you should start by doing a 
Select All on the entire font and selecting this feature. Begin with a setting of 2, as this should 
not alter your path. This will reduce the number of points in your outlines and set points to the 
extrema of the path which will allow for more efficient hinting. 

2. ADJUST CURVE POINTS. Place a copy of the character into the background, then in foreground 
reassign curve points to the highest, lowest, farthest right and farthest left sections (the extrema) 
of each circle or portion of a circle. You will be able to see in the background image just where 
these places are: they will show up as flat areas in the curving line. Place the curve point in the 
center of the flat line section. 

3. ADJUST BEZIER CONTROL POINTS (BCPs). Not only do you need to place the curve points in 
the positions just described, you also need to adjust the Bezier handles which show up when you 
select a curve point. It is best that these Bezier handles be perfectly horizontal or vertical. Hold 
down the shift key while tugging on a Bezier handle and the handles will jump to and lock in 
either horizontal or vertical position. 

4. ADD POINTS IF NEEDED. If you have placed the points at the extreme positions and adjusted 
the vertical/horizontal handles, and your curve line still does not match the background image, 
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then you will need to add another point (not vertically/horizontally constrained) and adjust 
slightly to accommodate the curve. 

5. CHECK FONT FOR HIGH & LOW POINTS. To set up height normalization instructions, 
Fontographer will be looking at some specific characters. It will expect that all your capital letters 
have a height that is positioned between the top of the upper case "O" and the top of the upper 
case "H." It will expect the lower measurement of capitals to fall between the bottom of the "O" 
and the baseline. If a character (such as an exotic swash capital) happens to extend above the 
top of the "O" that character will not be height normalized. (This will not affect the hinting 
regularization of stem weight.) Lower case "x" height in small sizes will be similarly related to 
the differences in height and depth of the lower case "x" and "o." 
 
If a character's "x" height is not within these parameters, it will not be affected by height control 
regularization, though it will continue to be hinted for stem width. (Special case: if the lower 
case "x" happens to have a swashing arm that rises above the general "x" and "O" heights, the 
height regularization wizard will read the top of that swash as the upper "x" height and will 
automatically put the "O" height 5 units above it, which would give you one heck of a high "x" 
height for that typeface. Therefore: beware of exuberant arms on lower case "x." Consider 
putting the fancy "x" in an alternate key.) 

6. SERIF CUPS. Try to use a curve point between two corner points for your serifs. Serif 
regularization in small type sizes will work best if the serifs are the same shape, the points are in 
the same relationship to the baseline, and the height of the serif cup is not more than 6 units. 
Positioning the curve point on the baseline and corner points below it assures that the serifs fall 
in that character bottom alignment zone described in 4 above. Adobe generally puts their curve 
points on the zero baseline and corner points at -4. For a helpful visual description of a cupped 
serif, refer to the User's guide. 

Common Questions 

What happens to the hinting mechanism if a typeface has lower case ascenders which are higher 
than the upper case "O's" upper limit? Many typefaces are like this. 

Characters with ascenders higher than the cap "O" will not be normalized for height but the will still be 
hinted for stem width. 

Must upper case serifs be the same size as lower case? Sometimes they are larger with a 
different cupping height. 

No, this will be handled automatically. Shape them as you wish. 

If the circular shape is far from symmetrical so that pairs of top or side curve points are far from 
each other, will the hinting still work? 

It depends, how far is far? If one curve point is within the extended range of the BCPs of the paired 
curve point, yes. Where is that range? Look at the length of the extended horizontal or vertical BCP 
points. Does a line drawn through the extrema curve point in question at right angles to the BCP 
extended line touch that line? Then it's within range. 

What if lower case ascenders do not have matching stem widths? An "l" (lower case ell) might 
be slightly wider than a "k" for instance. Must a cap I and an upper case "L" have the same 
stem width? Must all ascenders in the entire font be the same width? 

No, Fontographer will pick the four most popular stem widths and allocate hinted widths accordingly. 
Fontographer will allow for up to 4 common stem widths in a font; two horizontal, and two vertical. 



– 58 – 

Should all Type 3 fonts be converted with the curve points redistributed as described above, or 
is this primarily important for fonts that are text fonts with regular and straight ascenders? What 
about display fonts that are highly calligraphic, italic versions of roman texts, and fonts not 
meant for printing in very small type sizes? 

Type 3 fonts generated by Fontographer 4.1 do not contain hints, so there is no requirement for 
normalization. Such fonts can be converted to Type 1 without changing the curve point positions, but it 
is preferable to change them. The subtle changes required will make the fonts look better. 

When we talk about hinting of "small type sizes" how large is small? 

It is a derivative of the printer resolution and the point size. When a factor is applied to that, then hinting 
is enabled if below a certain value, and disabled if above. Larger sizes are unaffected by hints. Hinting 
will typically occur on a 300dpi printer at sizes below 24 points. On a 600 dpi printer, the threshold 
would be about 12. On a 2540 dpi imagesetter, only sizes smaller than about 4 points would get 
hinting. 

A roman and bold face that show distinct differences at 24 points in Type 1 appear almost the 
same at 12 points. Does this mean that bold versions must be made considerably heavier to 
work as "bold" in small point sizes? Then they are possibly too heavy in the larger sizes. 

Experiment to find a compromise stem width that shows up as bold in small sizes but is not too heavy in 
24 point. Try increasing the stem width by 1% of the em square until you find a pleasant compromise. 

There are many other things which can affect screen appearance: 

• Open Paths: Under the File menu you can select "Point Display" preferences to highlight 
"Unclosed Paths" and "Adjacent Points." These settings will cause bulls eyes and circles to appear 
on open paths and points within a path which haven't become joined. Drag these highlighted 
points on top of adjacent end points to close the path. If you cleaned up the paths previously, it 
is still possible to have points on top of points in a closed path. The "Adjacent Points" option will 
make those no-no's readily visible. Remove overlap should be able to get rid of such problems 
in Fontographer 4.x. 

• Poor path design: If you have more points than is optimal to define a path, or have points 
incorrectly placed in the path (not at extrema), then begin by doing a "Select All" on the entire 
font then select "Remove Overlap" and "Cleanup Paths" (setting of 2 - 3) from the Element 
menu. When converting TTFs to PostScript fonts it is important to remember that the TTF will 
have extra points on curves which need to be cleaned up. Also, PostScript fonts which are 
converted to TTFs will gain extra points along curves. This is correct behaviour for TrueType 
paths. 

• Bad path direction: try "Correct Path Direction" and "Remove Overlap." 
• Video drivers: try switching to the generic VGA Windows driver. 
• Not importing bitmaps: hand edited bitmaps should be imported via the File/Import menu. 
• Incorrect metrics: Just to be sure, after you open a font your next step should be to Import 

Metrics. When you import the metrics be sure to get the Ascent/Descent and the Kerning/Spacing 
from the appropriate metrics file. These metrics will affect the hinting. For more information 
obtain TechNote tn_03715. 

 

#03719: Cross-platform font issues in Fontographer  

Here are some things to keep in mind when preparing a cross-platform project: 
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Macintoshes and Windows machines have different character sets  

ASCII is a 7 bit code which both platforms base their fonts on. The first 128 characters will be identical 
on both platforms. Each platform has unique characters (international characters, accented characters, 
special characters, etc.) in the extended (upper 128) range. ASCII, ANSI, alphanumeric and special 
characters in Dreamweaver is a good reference for understanding the difference between ASCII and ANSI 
characters. There are sometimes different character codes for the same character. See the Crossover Chart 
for Cross-platform Characters for a list of characters which appear on both platforms.  

Macintoshes and Windows machines use different encodings  

Encoding is the mapping of a character name to a specific keystroke or character position. See What is an 
encoding vector? for details.  

A Windows font can be opened on the Macintosh with the font's original encoding and the first 128 
characters will be in the right positions. 

Symbol encoding means that all bets are off. It's used for Wingdings, Dingbats and for the "Insert 
Symbol" feature used in some applications. 

Macintoshes and Windows machines have different screen resolutions  

When taking a font from Macintosh (72 dpi) to Windows (96 dpi ) - the pixels will be 1/4 smaller due to 
the higher resolution. So, you don't really want the font to be identical pixel for pixel.  

Guidelines for Cross Platform use of Fonts  

1  Proof your font on screen and printer for both platforms.  

2  Are all of the characters there? Test by using appropriate 
keystrokes to display characters on both platforms. 

3  Line breaks may not break at the same place for the same text. 
You will have to strip the carriage returns and linebreaks if you 
are using an ASCII text file. 

Cross-platform encoding does not work reliably on text files -it is 
designed for page layout applications. 

4  You may have to force carriage returns.  

5  Enter special characters on each platform  

6  Test for accurate hinting. Hinting tells the TrueType rasterizer or 
ATM how to render the font at small point sizes. For more 
details on this, See your Fontographer User's Manual and Tech 
Note 3718.  

7  Be advised that while Adobe Standard Encoding is the easiest 
method of creating a font which works with a cross-platform 
document -it only works optimally for PostScript fonts. 

If you are creating a Truetype font for cross-platform use, refer 
to Creating Portable Fonts. 
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#03720: Where to find Fontographer Updaters 

Issue 

Where can I find the latest update to my version of Fontographer? 

Solution 

Go to the Fontographerdownloads page to download updaters. 

Following is the list of available updaters: 

Macintosh 

• Fontographer 4.1 to 4.1.3 Power Macintosh updater 
Updates Fontographer PM version 4.1 to 4.1.3 

• Fontographer 4.1 to 4.1.3 FPU updater 
Updates Fontographer FPU version 4.1 to 4.1.3 

• Fontographer 4.1 to 4.1.3 NON-FPU updater 
Updates FontographerNon-FPU version 4.1 to 4.1.3 

Windows 

• Windows Fontographer 3.5 to 3.5.1 updater 
Updates Windows Fontographer from 3.5 to 3.5.1 

• Fontographer Windows 3.5.1 to 3.5.2 updater 
Updates Fontographer Windows version 3.5.1 to 3.5.2 

Notes 

Fontographer 4.0 to 4.0.4 updaters are available by request. 

Mac FPU updaters are only for machines which expect a socketed FPU chip. Power PCs have integrated 
FPUs. Therefore, do NOT use FPU updaters on Power PCs. 

There are NO online updaters for Fontographer 4.1 Windows. 

Additional Information 

The updaters listed above contain user interface enhancements and performance improvements. These 
updaters do not provide patches for problems with OSX, Windows 2000 or XP. 

OSX users will need to refer to Fontographer and OS X issues (TechNote tn_15928) if Fontographer fails 
to run properly. 

Windows 2000 or XP users will need to refer to Windows 30202 Error in Fontographer (TechNote 
tn_15709) if Fontographer fails to run properly.  

 

http://www.macromedia.com/support/fontographer/downloads.html
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#03721: Problems Importing EPS files into Fontographer  

Issue  
Problems importing an EPS. 

Reason Illustrator1.1 EPS format is the typical EPS format which Fontographer understands. 

Error -11200 on the Macintosh means that the EPS being imported has no path information. This usually 
happens in the case of a Photoshop EPS. Photoshop EPS files are bitmap files with a EPS wrapper which 
cannot be imported into Fontographer. 

Solution 1 for Illustrator 7 or 8 

1  Save the file in Illustrator as a 1.1 EPS.  

2  No strokes, fills, open paths, adjacent points are 
allowed in artwork brought into Fontographer. 
Also, errors have been reported when saving in 
some versions of Illustrator to EPS with guides. 
The guides will remain in the image when it is 
brought into FOG.  

3  If using Illustrator 7 or 8 on the Macintosh, the 
clipboard can be used. Refer to Using Illustrator to 
copy/paste into Fontographer (TechNote 12635) 
for troubleshooting the Illustrator clipboard. 

Solution 2 for Illustrator 9 

1  If using Illustrator 9, select File>Save 
As>Illustrator EPS then click the Save button and 
use the Compatibility pop-up to select Version 
3.0/3.2 EPS.  

2  Set the Save As options like this... 
 
Compatibility: Version 3.0 - 3.2 
Preview: None 
Uncheck "Document Thumbnails" 
PostScript: Level 1 
Transparency: Preserve Paths 

3  Finally, open Fontographer and use File>Import 
EPS to import the file into whichever slot you have 
highlighted. 

Troubleshooting 

Copy/Paste will not work  

Check Show Clipboard or use Scrapbook when cutting and pasting to make sure that the image resides 
within the clipboard. Make to hold down the Option key while selecting Copy or Paste from the Edit 
menu with the mouse. 
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When using the clipboard with Mac Illustrator 7, see Using Illustrator to copy/paste into Fontographer 
(TechNote 12635). The current versions of PC Fontographer cannot accept vectors from the clipboard. 

Pasted image is grayed-out  

Bitmapped artwork which is pasted in the background template layer must be autotraced in order to 
create an outline. 

Artwork is not editable  

Which layer is the artwork being pasting into? It is possible to paste line art into the background 
needlessly. To change layers click on the name of the layer rather than in the Check Box. The check box 
is only there to show the activated layers.  

The image is scaled incorrectly when pasted  

The entire artboard (or pasteboard) is being saved with the EPS. Adjust the size of the pasteboard to be 
only as big as the actual object, then save the file as an Illustrator 1.1 EPS. 

Error message or large filled box with Adobe logo displays when importing an EPS  

There is a 64K limit on EPS files which are brought into a Fontographer character slot. The EPS artwork 
may have to be split into two character positions in order to get around this barrier. 

Creating a complex logo font (TechNote 3701) explains how to "freeze" the cursor so that it will not 
advance until the second keystroke is typed. 

  

  

 

#03722: Rehinting a font 

Issue 

Font displays poorly on screen at small point sizes. 

Reason 

Many commercial TrueType fonts for Windows use custom technology (referred to as delta hints) to 
improve the quality of the screen font. The TrueType instructions do most of the work of adjusting a 
character's outline to the screen's grid, but sometimes the outlines fall in such a way that filling the 
outline would not turn on the desired pixel. 

Delta hints are a way of making a subpixel adjustment to a point such that the enclosed pixels get turned 
on or off as desired. These delta hints cannot be automatically generated�”they are manually applied to 
the outline by software engineers. The results of good delta hinting can be seen by taking a close look at 
Arial, CourierNew, and TimesNewRoman in Windows. When Fontographer reads a TrueType font it is 
unable to retain the delta hints. If Fontographer were to retain the table containing the delta hints, any 
modifications to any of the glyphs would void the outline sensitive delta hints. 
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Solution 

 
Use Fontographer's Hint Parameter features to recalculate the font's outlines, as detailed in the steps 
below. 

Note: A normalized em square is always 1000 in accordance with the Adobe Type 1 specifications for 
Postscript fonts and 2048 (or a multiple of 1024) for TrueType fonts. 

Rehinting a font in Fontographer 4.x for Mac or Windows 

1  Choose Edit > Select All to select all characters. 

2  Choose Hints > Vertical Alignment Zones > Recompute .  

3  Click OK after the recompute process finishes. 

4  Choose Hints > Hint Parameters > Recalc . If Recalc is disabled, 
then go to Step 6.  

5  Click OK after the recalculation process finishes.  

6  Choose Hints > Autohint to turn Autohint off and then 
immediately turn Autohint back on. 

Non-roman characters  
The manual points out that Fontographer averages the stem widths of the characters in order to calculate 
the hints. Dingbats, Wingding or logo artwork will not have Roman character stems so it is best to rehint 
the font without these types of characters present in the font. Put them in a temporary work font and 
paste them back in with the Roman characters after the rehinting process. Also, if the artwork in the font 
is displaying or printing strangely then turn off hinting before generating the font or generate it as a Type 
3. 

Additional Information  
If the above steps don't improve the character, then the poor display of a font's characters may occur 
because the font was manually hinted. Macromedia Technical Support cannot troubleshoot manual 
hinting. 

  

 

#03723: Troubleshooting font names  

PC Troubleshooting 

Fontographer's Type 1 PC font naming rules correspond closely to Adobe's file naming scheme. A legal 
family name is required in order for ATM to see the font correctly. 

1  The operating system uses eight characters for a 
file name followed by a three character 
extension. 

2  If you use a name shorter than eight characters 
Fontographer will pad the rest of the name with 
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underscores. 

3  MS-Windows treats numbers are treated as 
lower case. Don't use special characters in the 
name .  

PC uses a 4/1/1/1/1 naming convention (maximum). Be sure to use capital letters as delimiters; never 
start a font with a lower case letter. 

For example: 

A family name of "JimFontCondensed" becomes "JIFC_ _ _ _.afm" but keeps its full family name in the 
application. The same font would be renamed to "jimfc___.ttf" if it was generated as a TrueType font. 
The TrueType name comes from the Fontographer database name: JimFont.fog. 

Generate fonts to anywhere EXCEPT for the following two locations: 

  the WIN/SYSTEM directory (this is the location of TTFs) 

  the PSFONTS directory (this is the location of PostScript fonts) 

 
Microsoft Windows FAQ 

How can faces be included under the same family name?  
You need to set weight and style in Font Attributes dialog. MS-Windows uses the weight to determine 
the placement within a family. 

MS-Word shows all the font names in the menu instead of a family. How can a family be created 
for MS-Windows applications? 

To create a family for MS-Windows applications, do the following: 

1  Name the parent with the same Family Name 
and Full name. 

For example: Testing, Testing. 

2  Change the weight of the font so that it gives a 
bold appearance then generate the font with the 
same Family Name used in Step One followed 
by the word Bold (with a capital "B") Family 
Name: Testing Full name: TestingBold -now 
select Bold under Weight in the Font Attributes 
Window. 

3  Skew the font and generate with Family Name: 
Testing Full name: TestingItalic -now select the 
Italic box under Style in the Font Attributes 
Window.  

4  Change weight and skew, then generate with 
Bold weight and Italic selected in the Font 



– 65 – 

Attributes window, using the names: 

Family Name: Testing 
Full name: TestingBoldItalic 

See Large Font Families in Windows (TechNote 
3712) for further information. 

Mac Troubleshooting 

Printer font names must be at least 6 characters long and must start with a capital letter but should not 
be entirely capitalized. 

PostScript takes first two letters of the first "word" (a word starts wherever there is a CAP) plus the name 
then the first letter of each additional "word". If there are no CAPS after first "word" then the name will 
be filled with underscores after the first CAP -like this: TT________.PFB 

Periods (and anything which follows) will be stripped off during font generation. 

Special characters are OK on the Mac but should be avoided if this font might later be used on a PC. 

The Macintosh Print Manager uses Adobe's 5/3/3 naming convention for PostScript (using Capital letters 
as delimiters). Thus: A family name of "PacificClipperBookBold" becomes "PacifCliBooBol" 

The TrueType version of this font would be "PacificClipperBook-Bold.suit" -there is a limit of 31 
characters. 

Before installing, be sure to uninstall or remove the old version of the font. Follow all the stricter naming 
rules for PC fonts so that you can generate fonts for Mac and PC from the same database by simply 
changing the encoding. 

Always pick a style name with the mouse rather than typing one into the Style field. Once you've 
selected a style with the mouse you are free to overtype the style name.(See the Addendum p.28) 

Macintosh Q&A: 

Attempts to load fonts into the application menu are unsuccessful; they default to original font 
instead. 
To resolve this issue, add a dash in family style name. 

I have used the Save As feature, but the name remains 'untitled'. 
Make sure to create a name in Font Info dialog box. 

Why doesn't PageMaker recognize subsets of family?  
In order for PageMaker to identify the family, it must be dan AdobeType Reunion compatible family. 
See Chapter 8, page 230 for instructions on how to create this. 

After modifying Geneva, I have renamed it to GENEVA B MAP. It is not working as expected. 
Do not use this name! It is already used in Apple ROM, along with Chicago and Monaco. Change the 
name to something that differs more from the original name. 
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#03724: Creating a Bold or Oblique font 

Issue 

Instructions for creating bold styled fonts. 

Solution 

Here are some tips on creating a bold font which is technically and artistically uniform when compared 
to the Plain version of the same font. 

Before taking these steps it's a good idea to load a commercial Bold font into the template layer of 
Fontographer and then load that same font's plain version into the outline layer. If you use a serif font 
like Garamond you will see several issues which need to be addressed when viewing the outline over the 
template. 

You will notice that the vertical parts of a character's design will gain weight faster than the thinner parts, 
it is not uniform. This is also true of the serifs, they will also gain in thickness at a faster rate than the 
narrower stressed portions of a character. Also, it is common for the serifs to become a bit longer. 

You'll note that the serifs become thick in relation to the thinnest stem in the character. Wide stems grow 
wider and are now out of proportion to thin stems. The stems will grow taller so now the character 
needs to be moved down in relation to the baseline. 

The above scenario isn't as prevalent in evenly weighted or unstressed fonts, such as Avant Garde, 
Helvetica, or Futura. But they are noticeable in the condensed versions of these faces, as condensing the 
font will often create stresses, especially where bowls and loops connect to the stems. Characters should 
be scaled in order to remain perfectly sized in relation to the em square. 

Follow these steps to use your Plain font as a basis for building a Bold font: 

1. Select all (except composites). 
2. Change Weight (try about 70% of the difference between the existing font's width and the 

width you desire). 
3. Keep all boxes checked on: Path Direction, Don't change horizontal or vertical. 
4. Note serifs and stress points for uniformity. 

Finally, it's impossible to tell you exactly what to do because these instructions will differ for font 
characters which have both thick and thin stems versus a font which has uniform size stems. 

The Change Weight feature can cause stems to grow in such a way as to overlap other parts of the 
character, counters can become filled, etc. . 

Additional Information 

Windows font families need to be prepared with the techniques described in Creating PC font Families 
and Large Font Families in Windows. 
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Macintosh font families are created by using the Stylemerger utility found in the Fontographer user 
folder. 

 

#03725: Large format fonts in Fontographer 

Issue 

 
Fontographer cannot open or create large character set fonts. Fontographer was created before large 
format fonts became popular and was not designed to open or create these fonts. 

Reason 

 
How many characters a font can have in Fontographer depends on the platform you are using. 
Fontographer has the following character limits per database: 

 Windows: 4, 095 characters  

 Macintosh: 8,192 characters  

Solution 

 
If you are designing a font which requires more characters than is possible on your platform, then you 
will need to create more than one font in Fontographer in order to get all the characters you need. 

Because of Fontographer's character limitation, many creators of large format fonts (OpenType or CID-
keyed fonts, for instance) use Fontographer to create the font outlines and then process the font in 
software that allows for large font formats.  
 
Additional information  
See also Two-byte fonts (TechNote 8163). 

  

 

#03726: Converting point sizes and picas to em units  

Issue  
Is it possible to move a character within the em square the equivalent of one pica? How can a character 
be set to display in the screen at an exact point size? 

Solution  
First, choose the exact point size desired. If you want several sizes, it is necessary to make separate fonts 
(or bitmaps) for each size. 
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Then, determine how much you want to move the character in points or picas. There are 12 points in a 
pica. 

To move a symbol character one pica (or 12 points) higher (vertically) within the em square. Use the 
above formula for your font by determining: 

1  What is the desired point size? 72 pt. 12 = ___% of 72? 
Answer is: 16  

2  What is the height of the character within the em square? 450 
em units 

3  What percent of the em square would this value be in em units? 
450 is what percentage of the em square? Most PostScript fonts 
are 1000 ems / Truetypes are normally 2048. 450 = 45% of 
1000 

4  16% of 1000 = 160 em units  

5  What percent of that point size is the move? Move the character 
up 160 em units. Select all and use the arrow keys to move 
incrementally.  

The character is now positioned at 450 (old height) plus 160 ems which is one pica higher than it was 
originally. 

 

#03727: Creating offset accented characters  

Issue Many fonts don't have enough room to fit additional accented characters. 

Solution 
Most fonts can be built with offsets in order to increase the amount of additional accented characters 
available. 

Instructions for creating offset accent characters: 

Step One  

Make sure that the font was opened with its original encoding via File>Preferences>General. Set BOTH 
radio buttons to refer to the font's original encoding. Next, select Edit>Unlink References in order to 
make sure that there are no composite characters in the font. Select Windows>Open Metrics Window 
from the menu. 

Step Two 

Type a vowel (or whatever character you intend to accent) in the text entry field at the top of the Metrics 
Window. 

Then, type the keystroke for the desired accent. 
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PC users will need to know the decimal number of the accent character. For example, Adobe fonts would 
have the "acute" accent in slot 194. In order to enter extended characters in the Metrics Window's text 
entry field the Alt key must be held down while typing (for example) 0194 on the numeric keypad. 

Mac users would use the keystroke for the needed accent character. When viewing the entire font via the 
Font Window, change the "View By" pop-up to "Keystroke". Adobe fonts would display the "acute" 
accent with the Option-lowercase "l" keystroke. 

Characters which are entered into the Text entry field will appear below that field as large glyphs. 

 

Step Three 

Now click on the glyph for the accent character. A set of lines will appear. Do NOT click on any of these 
lines. Position the mouse on top of the glyph and drag it to the left so that it appears on top of the 
previous character. 

Step Four 

Next, drag the "R" line of the accent character until it is one em unit away from the "L" line. This can 
done more precisely in the Outline window. The "R" line represents the right-hand sidebearing (RSB) or 
the advance cursor width. This means that wherever the "R" line is the cursor will come to rest there 
after the character is typed. 

The idea is to cause the cursor to be positioned in such a way that it is displayed as close as possible to 
the same place it was when the first character (Example: "o") was typed. This is important because it is 
not a good idea to drag the right-hand sidebearing on top of the left-hand sidebearing. The safest 
method is to allow at least one em unit of width. There are situations (PostScript fonts only) where it is 
permissible to drag the sidebearings on top of each other (known as zero-width characters) but this is for 
advanced users. 

After the font is generated and installed, the user would type "o" and then Alt-0194 (Option-l for Mac). 
The result would show the acute accent on top of the "o". The accent character is now offset so that 
when it is typed it will always appear on top of any previously entered characters and the cursor will 
come to rest as if it only the first character had been typed. 
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Additional Information  

It may appear that there is not enough room in the font to accommodate all the needed accented 
characters. Try to use unneeded character slots such as the Pound Sterling, Yen, Trademark, etc. Replace 
these characters with characters which need accents or with diacritic marks. If there are still not enough 
characters then a Unicode font will be needed. Tech note 13694 discusses the methods used for kerning 
PC Unicode characters (above decimal 256) in the Metrics Window. 

Leading or line spacing may be an issue for some fonts. Sometimes accents are designed to appear above 
capital letters in such a way that they may touch the previous line of text. Tight leading would allow the 
accents to touch characters in the line above. Loose leading would require more white space between 
lines. Leading control is discussed in tech note 12651 for PC and 12652 for Mac. 

Power users may want to bring an entire set of accents from one font into another. This can be done via 
copy/paste. After the characters are in the new font they can be moved up or down with the 
Transform>Move dialog. 

Certain accents (example: cedilla)may need to become part of the character they are accenting. In this 
case, do not use the above procedures. Instead, place the accent and the desired character into a slot 
which is not needed (but which IS defined by the current encoding, undefined character slots have 
double-asterisks ** above them). Next, position the accent on top of the character's outline and use 
Element>Remove Overlap to merge the shapes. 

  

 

#03728: Online Font Sources 

OnLine Resources 

CompuServe: Macromedia forum (GO MACROMEDIA), DTPFORUM, JWORLD (Jerry's World)  
 

America Online: Macromedia forum (Keyword: Macromedia), Computing and Software forum, MDP 
forum, FONTBANK 

 

http://www.quixote.com/serif/about.html 

 

http://babel.uoregon.edu/yamada/fonts.html 

 

http://www.knowledge.co.uk/xxx/mpcdir/ 

 

http://www.typeart.com 

http://www.quixote.com/serif/about.html
http://babel.uoregon.edu/yamada/fonts.html
http://www.knowledge.co.uk/xxx/mpcdir/
http://www.typeart.com/
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http://www.letterror.com 

 

electronic newsletter for discussion of typographical issues. 

enter: subscribe typetalk in the message or subject line. 

typetalk@hookup.net (Newsgroup) 

 

Other Resources 

Fontographer: Type by Design  
Stephen Moye, MIS Press. (ISBN 1-55828-447-8) 
800-488-5233 

How to Boss Your Fonts Around  
Robin Williams, Peachpit Press (ISBN1-56609-102-0) 
800-283-9444 

BMUG Shareware Disk Catalog  
by Noah Potkin from Addison-Wesley 

Mac Shareware 500 by Ruffin Prevost from Ventana Press (four disks included) 

The Font Catalog from Hyperactive Software 612-724-1596 

Scriptorium Font Library from Ragnarok, P.O. Box 14033, Austin, TX 78714 

Multilingual Computing Magazine 

111 Cedar, Sandpoint, ID 83864 
208-263-8178 
info@multilingual.com 

* Your FOG Sample Fonts Folder has Public Domain fonts: Civitype, Goudy Hundred, Livia, Final Roman, 
Opaque Counters 

  

Copyright 1996 Macromedia Inc. 

 

http://www.letterror.com/
http://www.macromedia.com/support/fontographer/ts/documents/mailto: typetalk@hookup.net
http://www.macromedia.com/support/fontographer/ts/documents/mailto: info@multilingual.com
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#03729: Fonts and Copyrights  

What are the copyright issues involved while using commercial fonts in Fontographer?  
The Copyright Notice field in Fontographer may direct you to the copyright holder, but be aware that 
this field may be blank, or may have been altered. Unless you know otherwise, you should assume all 
fonts to be copyrighted are works that are someone's property, and treat them as you would any other 
software.  
 
First of all, call the creator or publisher of the font and ask for any details you may need in the font's 
licensing agreement. 
Typeface design is protected in many countries by intellectual property laws, this includes Design Patent 
in the USA, and copyright and other forms of protection in other countries (the European Union aims to 
harmonize its intellectual property laws by means of a Directive). Copying the designs of protected work 
is illegal and may leave you liable to legal action. 

You must treat a font as you would any other software licensing agreement. The vector coordinates of 
the character shapes are copyrighted. It is illegal and unethical to copy characters and regenerate them 
as a font for commercial purposes. It is not illegal to edit a commercial font in Fontographer and 
regenerate it for in-house usage. 

The use of any commercial font is governed by the terms of its manufacturer's End User License 
Agreement (EULA). Many foundries allow their fonts to be altered, as long as these altered versions are 
used in keeping with the terms of the original's EULA. If you have questions about what can or can't be 
done with a font, you should contact that font's manufacturer. 

 

#03730: TrueType Information on the Internet  

Issue  
I'm designing a TrueType font, so where do I find out more about the TrueType Specification? 

Solution  

TRUE TYPE SPECIFICATION  

ftp://ftp.microsoft.com/developr/drg/truetype/ttspec.zip  

This is Microsoft's TrueType Font File Specification in Word 6 format. It?s quite lengthy- 388 pages. 

 

TRUETYPE OPEN SPECIFICATION  

ftp://ftp.microsoft.com/developr/drg/truetype/ttospec.zip  

Much like TrueType GX, True Type Open is an extension to the basic TrueType spec. It permits support 
for multilingual fonts and other aspects of advanced type design. This is also rather lengthy- 170 pages 
and is in MS Word 6 format. 

 

ftp://ftp.microsoft.com/developr/drg/truetype/ttspec.zip
ftp://ftp.microsoft.com/developr/drg/truetype/ttospec.zip
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TRUE TYPE SDK  

ftp://ftp.microsoft.com/developr/drg/truetype/ttsdk.zip  

If you are creating or testing TrueType fonts, the tools in this file are very useful. They were designed for 
use inside of Microsoft, and neither Microsoft or Macromedia will support them, or be responsible for 
their use, appropriate or otherwise. The warning states that the tools are copyrighted, and their 
distribution is restricted. 

 

TRUE TYPE OPEN SDK  

ftp://ftp.microsoft.com/developr/drg/truetype/ttosdk.zip  

If you are creating or testing TrueType fonts, the tools in this file are very useful. They were designed for 
use inside of Microsoft, and neither Microsoft or Macromedia will support them, or be responsible for 
their use. There is a warning stating that the tools are copyrighted, and their distribution is restricted. 
Contact Microsoft for further information. 

  

 

#03731: Creating Truetype fonts with line draw characters using 
Fontographer 

Issue 

 
Line drawing fonts have characters which are used to create borders and lines in both the horizontal and 
vertical directions. Special efforts are needed to make sure that these characters line up properly in both 
directions so that there are no gaps between adjacent characters or successive lines of characters. This 
note describes what should be done as these characters are built using Fontographer so that a TrueType 
font can be generated that will behave properly.  

The IBM PC extended character set includes a number of characters that can be used to create borders 
and lines in a document. Figure 2 shows the line drawing characters in the Fontographer Font window. 

 

Figure 1. The line drawing characters.  

ftp://ftp.microsoft.com/developr/drg/truetype/ttsdk.zip
ftp://ftp.microsoft.com/developr/drg/truetype/ttosdk.zip
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These characters can be difficult to draw so that they look good at various point sizes. For example, the 
characters must have their horizontal lines match so when they are used side by side, they align. The 
characters must also align vertically so they can be used on successive lines of text. There are some word 
processors and other applications that control the line spacing by inserting white space called "leading" 
between lines of text. Leading may thwart all efforts to use the vertical matching line drawing characters 
because a gap will always exist between characters.  

There are several things to keep in mind when designing and drawing the line drawing characters. First, 
all the characters must be drawn using identical coordinate values for the end of the lines. When 
TrueType fonts are produced, each character is built with instructions which tell the TrueType Font Scaler 
(a system program that converts the characters to pixels on the screen or dots on the printed page) how 
to modify the character outlines so that they match the display device pixel grid. This process is known as 
"grid fitting." If these instructions were not executed, the resulting characters would not look good at all. 
Since these instructions result in the movement of points based on the point size being displayed, special 
care must be taken to make sure that matching parts of all the line drawing characters are instructed in a 
consistent way. 

Solution 

 
Creating the outlines The most important thing to remember when drawing the line drawing characters is 
to be consistent. Obviously, all of the characters must have the same width. This includes the space 
character since it will probably be used to create white space in between the line drawing characters.  

 

Figure 2 Line drawing characters extend beyond normal character boundaries.  

Figure 2 shows the double line cross character as it might be drawn. Notice that unlike most other 
characters, the outlines of the line drawing characters extend beyond the normal boundaries of the 
character. This is necessary because the grid fitting process may shrink the outline slightly. With the lines 
extending a small amount beyond the normal boundaries, the lines will overlap with those of the 
surrounding characters.  
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Each feature such as horizontal and vertical lines must be drawn in exactly the same position. 
Fontographer provides help in accomplishing this task. Before you create the line drawing characters, 
create guidelines and use the Snap to Guides feature to simplify this task. Figure 3 shows the guidelines 
that can be used to draw both the double and single line characters. The outline of the double line cross 
character is also shown. The character origin is identified by the marker just to the right of the layers 
palette. 

 

Figure 3. Guidelines for line drawing characters.  

All of the line drawing characters in Figure 1 should be drawn such that their "outside" points are on 
these guidelines.  

Additional Considerations.  

Even after the outlines have been drawn as described in the previous section, the TrueType font 
produced will probably not give the desired results for all point sizes. This is due to the grid fitting that is 
done before the bitmaps are generated by the TrueType rasterizer. The procedure described in this 
section will make sure that all of the line drawing character outlines will be grid fitted in the same way so 
that their outlines will match at all point sizes.  

Fontographer uses "hints" which can be automatically generated by Fontographer or manually edited to 
build instructions for the TrueType Font Scaler. These instructions are executed by the Font Scaler to alter 
the character outlines to fit them to the pixel grid of the output device. Figure 4 shows one of the line 
drawing characters from the hint. 
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Figure 4. Character Hints.  

The hints are shown as arrows to the right and above the character outlines. These hints indicate which 
points should be on pixel boundaries. When the TrueType Font Scaler executes the instructions which 
Fontographer generates from the hints, points in the outline may be moved. The lines may end up 
thicker or thinner than they were originally drawn. The lines should however be an integral number of 
pixels in width after the grid fitting process.  

If you are using Fontographer 4.1 or a later version, you have control over how the character hints will 
be applied to generate instructions that the TrueType font scaler will use to fit the character outlines to 
the pixel grid. In earlier versions of Fontographer the hints are always applied toward the center of the 
character. From the Fontographer 4.1 Font window, select the range of characters that comprise the line 
drawing characters. Then choose the Hint parameters? item from the Hints menu. Figure 5 shows the 
dialog that you can use to control the hints. 
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Figure 5. Hint Parameters.  

By choosing the order in which the hints are applied and the direction of the hints to be Bottom to top 
and Left to right, for all of the line drawing characters, you make sure that the hints will generate the 
same instructions for every character. Fontographer also generates TrueType instructions which adjust the 
top and bottom and the left and right sides of characters.  

These instructions may, however, not have the desired effect for the line drawing characters. For 
example, come characters might be shifted up since if it is a "short" character and a taller character 
might be shifted down since it is "tall." This would result in those characters not matching vertically when 
they are used together. Similar behavior would result for characters which are predominantly "left" or 
"right-sided". The easiest way to eliminate this problem is to make the bounding boxes of all the line 
drawing characters the same. The bounding box of a character is the rectangle that completely encloses 
all the points of the character. The bounding box of the �˜ character is the largest of all the line drawing 
characters. To make all the other line drawing characters have the same bounding boxes as the �˜ 
character, simply insert single point paths at the corners of the characters that don't extend into that 
region. 
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Figure 6 Single point path in upper right.  

Figure 6 shows the c5446 character with a single point path in the upper right corner of the character. 
This point extends the bounding box to match that of the horizontal character. All of the line drawing 
characters except two require only one additional single point path. Those two characters require two 
additional paths. Figure 7 show the c5444 character with its extra paths.  

 

Figure 7. Single point paths in upper and lower right.  

Summary  

To construct a TrueType font that has line drawing characters, use the following guidelines so the 
characters will align properly: 
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1  Make all the advance widths of the line drawing characters (and 
the space character) the same.  

2  Draw the line drawing characters by using exactly the same 
coordinates. This is greatly simplified by creating guidelines and 
using Snap to guides.  

3  If you are using Fontographer 4.1, set the Hint parameters for 
all line drawing characters so that they are ordered and directed 
from left to right and top to bottom. 

4  Add single point paths at the corners of characters as needed to 
make sure the bounding boxes of all the line drawing characters 
are exactly the same.  

  

 

#03732: Mu and Mu1 character definitions in Windows 95 fonts 

Issue 

 
The Mu character doesn't display when using the Alt-0181 keystroke.  

Solution 

 
Microsoft changed the Truetype Specifications. In TTF Spec 1.6.6 you will find that character 181 is now 
defined as the Mu1 character and the Mu has been moved to decimal slot 455.  

If decimal slot 181 is empty but there is a glyph in slot 455 you will get the glyph from 455 when you 
enter Alt-0181. This glyph will display and print as if it were located in decimal slot 181. If slot 181 has 
a glyph in it there will be no substitution. 

Additional Information 
If you are loading a non-Fontographer font into Fontographer 4.1 for Windows 95 you should set your 
preferences under the File menu to Open the font with the "Font's Original Encoding." 

You should also set the preferences so that when the user types a key the "Font's Original Encoding" will 
be used. This will cause the old Mu character in slot 181 to be moved to 455 when the font is loaded. 

 

#03733: Fontographer 4.1 Windows issues  

Top Issues 

• email support option by sending an email with a postal address and Fontographer serial 
number. 

http://www.macromedia.com/support/email/complimentary
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 5. Widths of accented characters are no longer valid when using Adobe 
Standard Encoding 

Reason 

We are dealing with an issue within Fontographer's generation of composite widths. The widths 
become confused when using Adobe encoding. 

Solution 

The solution is to use Adobe Type Manager to make a PFM file for your font. You must have an 
AFM and INF file for your font in order for ATM to create a PFM. The PFM will be created 
automatically when the font is installed via ATM 3.x. The problem can be avoided by trying 
another encoding vector. 

There is a Fontographer 4.1.5 Windows updater which addresses this issue and is available for 
mailing by request. Requests may be made via the email support option by sending an email 
with a postal address and Fontographer serial number. 

 

#03734: Setting monospace Truetype parameters 

Issue 

Regenerating an existing font causes the font to lose its monospaced attribute. 

Reason Monospaced fonts are fonts which see every character as having the same width. Fontographer 
doesn't read or set the correct value in the Panose TrueType Table. 

Reason 

Monospaced fonts are fonts which see every character as having the same width. Fontographer doesn't 
read or set the correct value in the Panose TrueType Table. 

Solution 

Follow these steps to reset the Panose TrueType table to the correct value. 

1  Select Element > Font Info > Panose.  

2  Enter a value of "9" in the "Proportion:" field.  

3  Generate and install the font to make sure that it now functions 
as a monospaced font.  

http://www.macromedia.com/support/email/complimentary
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#03735: Repairing corrupted fonts  

Issue  
An error message appears which indicates that the font is corrupted. The font displays rectangles 
regardless of which character is typed. 

Reason  
Fonts may become corrupted due to disk errors or memory errors. 

Solution  
You'll need to create a new font using the old font's character outlines. This process can be sped up by 
copying and pasting all of the font characters into the new font window. Because one of the slots which 
appears empty may contain data which is causing the corruption, you should only copy the slots in the 
font window that contain characters. Not copying empty slots reduces the chances that you will be 
transferring corrupted information from the old font to the new. The steps to create a new font with the 
old outlines are below: 

1  Open the font which appears to be corrupted.  

2  Choose Edit > Select All, then Edit > Unlink Reference. This will make sure 
that there are no composite characters in your font. 

3  In the character window, shift-click only on slots that have characters in them. 
When you come to a blank slot, you should not copy it (other than Decimal 
32, the space character). Skip empty slots and only highlight contiguous 
characters. When you are through shift-clicking, your character window will 
look similar to the illustration below:  
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4  Choose Edit > Copy to copy the selected characters to the Clipboard. 

5  Now you'll create a new font with the old font's character outlines. Choose File 
> New to open a new font window. 

6  In the empty new font window, shift-click only on slots which correspond to 
the same positions in the old font window.  

7  Choose Edit > Paste to paste the characters from the Clipboard into the 
highlighted slots in the new font window. Instead of transferring all the 
character outlines at once, you may prefer to break this process up into several 
steps�”copying and pasting several sets of contiguous characters back and 
forth between the new font and the old several times.  

8  Compare the new font window with the old font window to ensure that all 
characters were copied to the correct locations.  

9  Import the metrics into the new font window, as outlined in Importing Font 
Metrics into Fontographer (TechNote 3715).  

10  To avoid problems, set the width of the space character (Decimal 32) to make 
sure that inter-word spacing doesn't change. Changing the width of the space 
character is one way to make sure that the Decimal 32 slot has been defined.  

11 Generate the new font. Install it in your operating system and then test to see 
if the error message reappears.  

  

 

#03796: Fontographer Publications  

The following is a list of books for Fontographer as well as on fontography, created by Macromedia and 
others. The list may be incomplete but should be useful as you design fonts and integrate them into your 
projects. 
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  Fontographer Related Books 

Title: Fontographer: Type By Design  
Publisher: MIS: Press 
Author: Stephen Moye 
User level: Intermediate - Macintosh and Windows 
ISBN: 1-55828-447-8 
Pages: 275pg book 
Price: $29.95 US; $39.95 CDN 

Fontographer: Type By Design is out of print, but some book locator services have successfully found single 
copies. 

Title: Macromedia FreeHand Graphics Studio Skills  
Publisher: Hayden Books / Macmillan Computer Publishing 
Author: Don Parsons, William W. Hurley II, Sebastian Hassinger 
User level: Accomplished - Expert for Macintosh and Windows 
ISBN: 1-56830-302-5 
Pages: 343 page book with companion CD-ROM 
Price: $45.00 US; $63.95 CDN; L41.50 NET UK 
To Order: 
Phone: 800-428-5331 
Web: mcp.com 

Contains some Fontographer procedures and tutorials. 

Title: Digital Type Design Guide  
Publisher: Hayden Books 
Author: Sean Cavanaugh 
User level: Accomplished - Expert for Macintosh and Windows 
ISBN: 1-56830-190-1 
Pages: 275 page book with companion CD-ROM 
Price: $45.00 US; $63.95 CDN; L41.50 NET UK 
To Order: 
Phone: 800-428-5331 
Web: amazon.com 

Contains some Fontographer procedures and tutorials. Excellent section on understanding font encoding 
in Fontographer. 

Title: The Elements of Typographic Style  
Publisher: Hartley & Marks Publishers 
Author: Robert Bringhurst 
User level: Accomplished - Expert 
ISBN: 9-780881-791327 
Pages: 350 page book 
Price: $24.95 US; $29.95 CDN 
To Order: 
Web: amazon.com 

This book is the Bible of Typography. Traces the ancestry of font families and explains typographic 
terminology. 

http://www.mcp.com/hayden
http://www.amazon.com/
http://www.amazon.com/
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Title: How to Boss Your Fonts Around  
Publisher: Peachpit Press 
Author: Robin Williams 
User level: Beginner - Intermediate - Macintosh 
ISBN: 1-56609-102-0 
Pages: 150 page book 
Price: $12.95 US; $19.95 CDN 
To Order: 
Web: peachpit.com 

Great book on understanding Macintosh font issues. 

  

 

#03797: Fontographer Websites  

The following is a compilation of available websites for Fontographer and fonts, in general. This directory 
is in no way complete, but you may find the consolidation of the material helpful as you develop 
applications and create media. 

The following websites provide useful information to customers using Fontographer. These sites are not 
affiliated in any way with Macromedia and, while Macromedia employees may occasionally post 
messages or reply to messages on these sites, Macromedia does not commit its employees to monitoring 
these sites and/or replying to messages on them. Likewise, Macromedia has no editorial control over 
content found there and makes no guarantees as to the accuracy or veracity of any information found 
there. Please read any FAQs that these sites make available and observe any etiquette that these sites 
require. 

Support and More  
This is a site devoted to people using Fontographer to edit or create fonts. 
http://www.supportandmore.com/ 

Microsoft Typography  
This is the main page to Microsoft's site devoted to Typography. It is the entry to content and utilities 
devoted to fonts for the Windows OS. 
http://www.microsoft.com/typography/default.asp 

Unicode Site  
http://www.unicode.org 

Phil's Fonts  
http://www.philsfonts.com/  

 

#03798: Fontographer online forums  

Please consult your Fontographer manuals, search Macromedia's site for keywords, and scan the 
Fontographer TechNotes before posting to the online forum. 

http://www.peachpit.com/books/
http://www.supportandmore.com/
http://www.microsoft.com/typography/default.asp
http://www.unicode.org/
http://www.philsfonts.com/
http://www.macromedia.com/support/search/powersearch.html
http://www.macromedia.com/support/fontographer/technotes.html


– 85 – 

Read the information in the List of online forums if you haven't already. 

If you are new to using the online forums, please read the Using Macromedia online forums document. 

Macromedia online forums  
Fontographer - Discussion of issues relating to the font creation and manipulation software, 
Fontographer. [news://forums.macromedia.com/macromedia.fontographer] 

General.info - This group discusses general information regarding Macromedia products that doesn't 
pertain to the other forums. Such topics might include non-technical questions, press releases, and other 
Macromedia news. [news://forums.macromedia.com/macromedia.general.info] 

Job.opportunities - Open group for users to post opportunities for consulting and offering of services 
related to Macromedia products. 
[news://forums.macromedia.com/macromedia.general.job.opportunities] 

 

#03799: Fontographer-related mailing lists  

Macromedia Online Forums provide places for developers of all experience levels to share ideas and 
techniques. Macromedia Technical Support personnel and members of the product development teams 
frequent the many Macromedia forums. Moreover, our Team Macromedia members also lend their 
knowledge and "real-world" expertise. 

Fontographer discussion forum  
Go the the Macromedia forums page to subscribe to the Fontographer forum (or any other forum of 
interest to you). 

Third-party discussion forums  
Below is a list of other discussion forums specifically relating to Fontographer or font development. These 
lists are operated by a third-parties and Macromedia has no direct affiliation with the lists except that 
Fontographer may be among the products discussed on the list. You may see posts from Macromedia 
employees, but Macromedia does not commit to employees reading or responding to all posts. We list 
these discussion forums here so that you are aware of other Fontographer resources available to you. 

If you need direct support from Macromedia, consider the various Macromedia support plans. 

 Typo-L  
Typo-L is a discussion forum for type designers in the form of 
an Internet mailing list. You "subscribe" to the list so that you 
can send and receive e-mails (or "posts") from other users who 
are also subscribed to the list. Any e-mail that anyone sends to 
the list is also sent to you and, likewise, any e-mail that you 
send to the list is sent to others who subscribed to it. Many of 
the netiquette issues described in the Macromedia Newsgroup 
Guidelines also apply to this mailing list.  

You can subscribe to the list and then post your question. To 
subscribe to the mailing list, e-mail the following message: 

http://www.macromedia.com/support/forums/forums.htm
http://www.macromedia.com/support/forums/using.htm
http://www.macromedia.com/support/fontographer/ts/documents/news:/forums.macromedia.com/macromedia.fontographer
http://www.macromedia.com/software/fontographer
http://www.macromedia.com/support/fontographer/ts/documents/news:/forums.macromedia.com/macromedia.general.info
http://www.macromedia.com/support/fontographer/ts/documents/news:/forums.macromedia.com/macromedia.general.job.opportunities
http://www.macromedia.com/support/forums/team_macromedia/
http://www.macromedia.com/support/forums/
http://www.macromedia.com/support/programs/
http://gmunch.home.pipeline.com/typo-L/index.htm
http://www.macromedia.com/support/general/ts/documents/newsguidelines.htm
http://www.macromedia.com/support/general/ts/documents/newsguidelines.htm
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SUBSCRIBE TYPO-L 

to this e-mail address: LISTSERV@LISTSERV.HEA.IE. 

 OpenType discussion forum  
This e-mail based OpenType discussion forum has been set up 
at the Topica.com Web site specifically to help people working 
on the development of OpenType fonts and associated 
technologies.  

To subscribe to this OpenType Mailing List, send an e-mail to: 
 
opentype-subscribe@topica.com 

 Microsoft communities supporting font developers  

 The Font Tools Community has been set up for 
general type tool discussion. Membership of this 
community is not restricted.  

 The Microsoft Typography section has also set up 
four MSN Web community sites serving licensed 
users of its type tools and technology.   

Third party links 
Although links to external Web sites are provided as a resource, the Web sites are not part of 
Macromedia. Please see the Macromedia policy regarding links to third party Web sites in the Legal 
Notices and Information section. Pages to external Web sites will open in a new browser window. 

  

 

#08163: Two-byte fonts  

Fontographer does NOT open or generate two-byte fonts. 

Font designers who need to work with two-byte characters can try the following suggestions: 

1. Fontographer Macintosh users can use File > Import Truetype Character to import one character 
at a time into a font database. 
 
This is only practical for creating a limited font character set since importing characters for a 
30,000 character Korean font would take forever and Fontographer databases can accommodate 
no more than 8,192 characters. 

2. Some two-byte CJKV (Chinese, Japanese, Korean, Vietnamese) fonts can be found in 1-byte 
format in older Apple Language Kits. 

3. If you only want to OPEN a two-byte font on the Macintosh see Hacking Fontographer to open 
two-byte fonts. 

4. Another method is to become familiar with the CID font specifications found at: 
http://www.adobe.com in TechNote 5092. 
 
CID fonts cannot be edited in Fontographer but there are several other methods available to 

http://www.macromedia.com/support/fontographer/ts/documents/mailto:LISTSERV@LISTSERV.HEA.IE?subject=SUBSCRIBE%20TYPO-L
http://www.microsoft.com/typography/otspec/otlist.htm
http://www.topica.com/
http://communities.msn.com/FontToolsCommunity/_whatsnew.msnw
http://www.microsoft.com/typography/links/news.asp?NID=1122
http://www.macromedia.com/help/copyright.html#disclaimer
http://www.macromedia.com/help/copyright.html#disclaimer
http://www.adobe.com/
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manipulate these fonts -including the use of a text editor. More tools can be found at 
http://fonts.apple.com/tools. 
 
The classic work on the subject is: Understanding Japanese Information Processing by Ken Lunde. 
Ordering information may be found at: http://www.ora.com  

 

#08164: Outlines are missing - ATM error message 

Issue 

 
Error message: "Can't convert to paths because ATM is off or outlines are missing." 

Reason 

This is usually due to the manner in which the font was installed. Refer to Font Installation on the 
Macintosh for instructions on proper font installation. 

If the font was installed properly and ATM is turned ON then it is very likely that this is a bogus message 
and can be ignored. Bogus instances of this message have been reported to Adobe and they are working 
on the problem. 

 

#08165: Bold Italic style problems 

Issue 

Manually entering Bold Italic style parameters 

Reason 

Sometimes the font information which is needed in order to update a font's attributes is not being 
written correctly by Fontographer. 

Solution 

The proper parameters need to be placed in the font's TrueType tables. The temporary workaround is to 
enter them manually. 

1. Do NOT use the pop-up box under Element > Font Info > General dialog to select Bold Italic. 
2. Go to Element > Font Info > OS/2 Data, type 700 in the Weight field. In the Selection field type 

$0021. 
3. Go to Element > Font Info > TrueType Post and enter -12 (for example) in the Italic Angle field. 

  

 

http://fonts.apple.com/tools/
http://www.ora.com/


– 88 – 

#08166: Bringing images into Fontographer  

Issue 1  
Fontographer won't import EPS 

Reason  
Some EPS files (such as PhotoShop EPS files) contain bitmap images within an EPS wrapper. 
Fontographer can only import an EPS file which has path information. 

Solution  
The image should be traced by some application software and saved as an Illustrator 1.1 EPS before 
being brought into Fontographer. Now, use the File > Import > EPS menu to import the EPS. 

Notes: It is not necessary to import EPS files from Macintosh FreeHand. Macintosh Freehand vector art 
can be copied to the clipboard and pasted directly into Macintosh Fontographer's outline window. Older 
versions of Macintosh Illustrator can Option-Copy to Macintosh Fontographer but newer versions of 
Illustrator will need to export a older format EPS and then import that EPS into Macintosh Fontographer. 
See Problems Importing EPS files into Fontographer for further details. 

No strokes, fills, open paths, adjacent points or guides are allowed in artwork brought into 
Fontographer. 

Troubleshooting: 

"Nothing happens when I copy the image to the clipboard." - Check Show Clipboard or use Scrapbook 
when cutting and pasting to make sure that the image resides within the clipboard. Make sure you are 
holding down Option while selecting Copy or Paste from the Edit menu with the mouse. 

"All I see is a grayed-out image." - Are you pasting bitmapped artwork into the template layer? A 
Photoshop EPS is a bitmap with an EPS wrapper around it. Bitmapped artwork which is pasted in the 
template layer must be autotraced in order to create an outline. 

"I can't edit the artwork." - Which layer are you pasting to? It is possible to paste line art into the 
background needlessly. To change layers, click on the NAME of the layer (Outline, Template, Guides, 
Hints) in the Layers Palette rather than in the Check Box. The check box is only there to show activated 
layers. 

"The image is scaled incorrectly when I paste it." - If Option-Copy and Option-Paste aren't working you 
can put a bounding box around the character and bring it into Fontographer with the box around it. This 
will cause it to scale correctly. For an example of a bounding box, see Scanning and autotracing in 
Fontographer. 

If you are importing an EPS and the image isn't scaling correctly it's because the entire artboard (or 
pasteboard) is being saved with the EPS. Adjust the size of the pasteboard to be only as big as the actual 
object, or crop the image, then save the file as an Adobe 1.1 EPS. 

"I get an error message or a large filled box when I import an EPS into Fontographer 3.5.x. Windows" - 
There is a 32K limit on EPS files which are brought into Fontographer 3.5.x Windows. You may have to 
split your EPS artwork into two character positions in order to get around this barrier. 

Issue 2  
Procedure for bringing a bitmapped image into Fontographer for Windows. 
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1  Use a bitmap image editing application to save the image as a 
*.bmp file.  

2  Select the image in a bitmap application. For Windows users, 
Microsoft Paint is the easiest way to do this. 

Note: anything which is displayed on the screen in Windows can 
be captured to the clipboard via the "Print Screen" key located 
on the top row of the keyboard. Once the screen is captured it 
can be pasted into Microsoft Paint and edited. 

3  Now, paste the image. The image will be automatically pasted 
into Fontographer's template layer. 

4  Now, switch to the Outline layer and select Element > 
Autotrace. 

 

#08174: Defining Unicode characters  

There are no automatic tools to create Unicode fonts. Unicode fonts are prepared by manually defining 
the needed character names and Unicode numbers in a font database. The simplest way to create a 
Unicode font is from an existing Unicode font. In many cases, an existing Unicode font can be found 
which only needs a few characters defined. Another suggestion is to paste preferred character into the 
slots of an existing font. 

Characters are defined by highlighting a slot and then using the Element>Selection Info dialog to enter 
character names and Unicode numbers. The proper character names and Unicode numbers may be 
found in the "Unicode Standard" book from Addison-Wesley or at www.unicode.org. WIN 95 and NT 
recognize the entire Unicode book whereas Windows 3.1.1 only recognizes ANSI Unicode values. 

The Element>Font Info>General menu is used to edit the "Number of characters allowed in font" field. 
Fontographer has a limit of 8,192 characters per database. The Unicode Glyph List encoding vector 
allows glyphs to be pasted into 2,163 pre-numbered Unicode slots. This makes life a lot easier for those 
who are using standard systems such as Cyrillic, Hebrew and most European characters. 

This procedure ONLY defines the characters in the font. There are several parameters which must be set 
in order to cause a font to work in conjunction with a specific keyboard driver and application software. 
For information on how to enter these parameters, use this database to search for: truetype or code 
page. 

Third-party international keyboard drivers are available from: Eastern Language Systems (801-377-
4558) or Unitype. 

Windows 95 and Windows NT allow you to install Microsoft's international keyboard drivers via the 
Control Panel and the Multilingual Support Package. The Windows Task Bar will display the "EN" 
(English) keyboard. Clicking on "EN" will pop-up the list of installed keyboards. Use this Keyboard 
Switcher to access international characters in Unicode fonts. 

 

http://www.unitype.com/


– 90 – 

#08178: Fontographer Hinting FAQs  

Typical questions asked during a Hinting Troubleshooting call: 

1. I've added a logo to a Roman font and the logo looks terrible. Rehinting doesn't help. 

2. My character has one stem larger than the other after it is hinted and generated as a font. 

3. Some characters have been stretched or squashed but others look fine. 

4. What happens to the hints when a font is opened in Fontographer? 

5. What causes thickening or thinning of stems when printing? 

6. My character vanishes at smaller point sizes. TN3710 doesn't help. 

7. Why does my font lose the overshoot on certain characters? 

8. Why do my stems move closer together on characters like "m"? 

Issue 1: I've added a logo to a Roman font and the logo looks terrible. Rehinting doesn't help. 

Reason: Fontographer autohinting is designed to work on characters with horizontal and vertical stems, 
such as the Roman alphabet. 

Solution: 1. First, double-click the slot which contains the logo character. 

2. Now, switch to the Hints layer by clicking on the WORD Hints. (Note: the checkboxes in the Layers 
Palette are for displaying the active layer NOT for switching to a layer.) The Hints layer is enabled when 
the word "Hints" has white characters on a black highlighted background. 

3. You will see arrows both above and to the right of the logo. Click on a hint and then press the Delete 
key to clear out all the hints from the logo character. This will turn OFF Autohint. 

4. This method allows you to retain hints in your Roman characters while deleting them from the logo. 
Be aware that logos which have Roman-like shapes may look better when retaining the hints. 

Issue 2: My character has one stem larger than the other after it is hinted and generated as a font. 

Reason: This can be caused by improper path direction which causes the white space (rather than the 
stems) to become hinted. 

Solution: You can determine which portion of the character is being hinted by holding down Alt (or 
option on the Mac) when the hint is selected. If the beginning and ending point of the hint correspond 
to the white space in the character then the white space is what is being hinted. Usually, Correct Path 
Direction will fix this. 

Issue 3: Some characters have been stretched or squashed vertically but others look fine. 

Reason: Most likely, the font needs to be rehinted. The placement of the points was not recognized by 
the Vertical Alignment zones and so no "Ghost Hints" were applied. 
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Solution: 1. Turn on Autohint, then make sure that there is at least one point in the bottom zone of your 
character. Zones are identified by the "hourglasses" at the left of the character. 

2. Follow the procedures found in Tech Note 3722 for rehinting a font in order to apply a Ghost Hint to 
this character. 

3. You can try reversing the direction of the hints by clicking on them in order to achieve the effect you 
desire. Normally, you want your hints to face inward. 

4. If it still doesn't look right then stretch the zone up or down a little (or add a point or a horizontal 
hint) in the offending zone. You can check to see if a point falls within a zone by clicking on the top or 
bottom of one of the "hourglasses" which will display a horizontal line defining the zone. Then, check 
the bitmap editor in order to observe how the grid fit changes on this character when you click on the 
Recalc from Outline button. 

Note: this would not apply to a serif font because serifs don't get Ghost hints. 

Issue 4: What happens to the hints when a font is opened in Fontographer? 

Reason: Some hinting information is proprietary. There are also other hints, such as Substitution Hints on 
PostScript fonts and Delta Hints on TrueTypes, which Fontographer doesn't have the ability to read. 

Solution: Here is a breakdown of what happens to the hints when a font is opened in Fontographer: 

PostScript 

Does not need Autohint on because all (except for substitution hints) hints are preserved. In other words 
it doesn't need Autohint because it already HAS hints. 

Does not recognize serif or diagonal hints. 

When a PostScript is converted to TrueType the hints are translated to TrueType "instructions." Close, but 
not the same as hints. 

Since a PostScript font doesn't have diagonals the resulting TrueType will not have diagonal hints unless 
a rehint is performed. 

TrueType 

Has no original hints to read in (other than Deltas, which Fontographer doesn't read). Autohint is 
automatically turned on when a TrueType is being opened. If characters shapes are edited the font will 
need to be rehinted. The resulting TrueType will recognize serif (and diagonal hints if the outline is at a 
45 degree angle). If a PostScript font is generated from a TrueType it will get new hints but will not 
recognize diagonal hints. 

Issue 5: What causes thickening or thinning of stems when printing? 

Reason: This is usually caused by bad path information (open paths, adjacent points, bad path direction). 
It also has been seen when a particular printer driver doesn't work well with the hints in the font. 

Solution: Use Element>Correct Path Direction or try a different printer driver. Try turning hints off or 
Generating the font as a Type 3 font to verify the nature of the problem. 



– 92 – 

Issue 6: My character vanishes at smaller point sizes. TN3710 doesn't help. 

Reason: The TrueType spec (page 178) states that the relationship between the PPEM and the placement 
of points can cause characters to deflate and disappear at small point sizes when unaccompanied by 
Delta hints. 

Solution: Delta hints used to be an expensive proposition and Fontographer currently can't create them. 
We refer customers who need Deltas to The FontSource. They will add Deltas to your font for about half 
the price normally charged in the industry. Contact them at: 423-522-8059. 

It is possible that you may be able to move your character stems up or down or change the placement of 
points and get your character to work. Also, sometimes this problem is solved by adding extraneous 
points at the intersection of the ascender and the RSB as noted in Tech Note 3731. 

Issue 7: Why does my font lose the overshoot on certain characters? 

Reason: The Adobe Type One spec states (page 39) that this occurs "for point sizes that occupy fewer 
pixels per inch than the BlueScale value results in for a given device." 

Solution: Scale your character up or down and retry. If the overshoot is still being suppressed you should 
ask Tech Support to send you a copy of FOG 4.0.3 (for Mac only). It is possible to hack the POST 501 
resource (via ResEdit) in Fontographer and change the Bluescale value that is set there but there is no 
Tech Support for this hack. 

Issue 8: Why do my stems move closer together on characters like "m"? 

Reason: This occurs when your font has stems of differing widths. Fontographer's Autohint is set up to 
perform stem width normalization when the hints are applied. The Adobe Type One spec states (page 
54) that the vstem3 command sorts the vertical alignment zones such that the distance from the center 
of a stem must be equal to the center of any corresponding stems. The same logic applies for the letter 
"E" and hstem3 hints. 

Solution: You will either need to make all of your stems the same width (and the distance from center to 
center of the stems) or manually hint your font. 

Notes: 

Fontographer uses Nimbus Q hints which attempt to normalize stem widths by calculating the placement 
of points within the Blue Zones. These calculations are used to create hints (or instructions for TrueType) 
which will "grid fit" the characters to the resolution of the screen. 

Since there can be no half pixels the hints are used to nudge the stems in the proper direction to achieve 
grid fit. 

Fontographer's Nimbus Q hints will NOT be applied to any character with an em square larger than 
2048. 

Stems can only be satisfactorily hinted if they are 90 degrees or 45 degrees. Uneven angles may look 
jagged. 

TrueType fonts look best when the em square is an even number or a mulitple of 1024. 

PostScript fonts look best when the em square is a mulitple of 1000. 
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Stem hints should never be placed head to head. Allow at least 3 em units between hints. 

Stems or serifs may not hint properly if there are extraneous points on the paths. Use "Clean Up Paths" 
to place points at the extrema. Try placing a tangent point where a straight line meets a curve. Make 
your BCP handles equidistant from each other. 

Hints which are closest to the outline are processed first in order of hinting. 

Spurs may sometimes be eliminated by adding a couple extra points at the area of the path where the 
spur occurs. Having said this, keep in mind that some spurs may be caused by hinting the white space 
(i.e., if the spur is equivalent to the counter or white space between stems) and this will only be resolved 
by Correcting the Path Direction. 

Troubleshooting of a font may reveal that there are extraneous hints which cause certain characters to 
move up/down, etc. Take a look at the hints and you may see a hint which doesn't make sense such as a 
stem hint above an area where there is no stem. Delete extraneous hints. 

For diagonal stems which are getting incorrect widths you can try reversing the hint or changing the 
width of the hint. 

Stem width normalization takes place at 18 pt and below. 

Bad hinting may be causing font corruption. Follow procedures for fixing a corrupted font (Tech Note 
3735) to eliminate this possibility. 

You should hardly ever apply hints to a script font. Hints can decrease the quality of these fonts and 
make them look worse. 

 

#08185: Rehinting a Font  

Issue: 

"All I did was load an existing font, rename it and generate, now it looks terrible on screen at small point 
sizes." 

Reason: 

Many commercial TrueType fonts for Windows (several of Microsoft's and Monotype's) use custom 
technology -referred to as delta hints, to improve the quality of the screen font. Delta hints are small, 
sub-pixel modifications made to the outline in order for the outline fill to do the 'right' thing with the 
pixels it's filling. The TrueType instructions do most of the work of adjusting the outline to the grid, but 
sometimes they fall in such a way that filling the outline would not turn on the desired pixel. Delta hints 
are a way of making a subpixel adjustment to a point such that the enclosed pixels get turned on or off 
as desired. These delta hints cannot be automatically generated, but are manually applied to the outline 
by software engineers. The results of good delta hinting can be seen by taking a close look at Arial, 
CourierNew, and TimesNewRoman in Windows. When Fontographer reads a TrueType font it is unable 
to retain the delta hints. Were it to retain the table containing the delta hints, any modifications to any 
of the glyphs would void the outline sensitive delta hints. 

Solution: 
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Fontographer 4.x for Mac or Windows 

1. Do a "Select All" of all characters. 

2. Go to Hints, Vertical Alignment Zones, Recompute, click "OK" when the recompute is done. 

3. Next go to Hints, Hint Parameters, Recalc, "OK" (If recalc is disabled then you don't need to recalc.) 

4. Finally, turn Autohint (under the hints menu) Off and back On. 

5. Make sure that the "blue zones" (areas between the "hourglasses" seen on the left) have at least one 
point in the font outline to calculate on. The character may need to be moved into a "blue zone" in 
order to be hinted. 

6. Now, go back to Vertical Alignment Zones, Recompute: and then Hint Parameters, Recalc, Autohint 
Off and back On. 

Fontographer 3.5 for Mac or Windows 

1. Do a "Select All" of all characters, Go to Special, Expert, Hinting Setup and "Enable Manual Hinting." 

2. Then, click "OK" and double-click on a character to open it. 

3. Click on the toolbox layer buttons until the "H" hints layer is displayed. 

4. Make sure that the "blue zones" (areas between dotted horizontal lines) have at least one point in the 
font outline to calculate on. The character may need to be moved into a "blue zone" in order to be 
hinted. 

5. Now, go back to Hinting Setup and click on the "Recalc" button and then the "Rehint" button. 

Notes: 

The manual points out that Fontographer averages the stem widths of your characters in order to 
calculate the hints. Dingbats, Wingding or logo artwork will not have Roman character stems so it is best 
to rehint the font without these types of characters present in the font. Put them in a temporary work 
font and paste them back in with your Roman characters after the rehinting process. Also, if the artwork 
in your font is displaying or printing strangely you should turn off hinting before you generate the font 
or generate it as a Type 3. 

The default or normalized em square is always 1000 per the Adobe specifications. (2048 or an even 
number for TTFs.) The hinting may be causing the font corruption. 

Here are some alternatives if rehinting doesn't sufficiently improve the appearance of your font: 

1) If you've been creating paths from scratch or creating manual hints buy: Fontographer Type by 
Design, Stephen Moye 800-488-5233. 

2) Contact Wade Farrell, Monotype's OEM Sales Manager, at 800-MONOTYPE (312-855-1440 in IL) or 
by e-mail at oemsales@monotypeusa.com for more information. Minimum fee to rehint via delta hints is 
$500 (US) per point size. 

http://www.macromedia.com/support/fontographer/ts/documents/mailto:oemsales@monotypeusa.com
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3) Fontsource (423-522-8059) offers competitive pricing on Delta hinting and font design. 

They may be contacted at: http://www.fontsource.com 

 

#08191: Splash screen and/or toolbox icons are garbled 

Issue 

I recently installed Fontographer and now my splash screen and/or toolbox icons are not displaying 
properly. 

 

Reason 

Fontographer installs a custom font on startup for displaying icons. In some cases, the font information 
supplied by the system becomes confused and gives Fontographer the wrong font order. We have found 
this to be related to the font list status for TrueType fonts. 

Solution 

Set the operating system's fonts control panel to allow non-TrueType fonts. The general steps are as 
follows: 

1. Choose Start > Settings > Control Panel. 
2. Open the Fonts control panel. 
3. Choose Tools > Folder Options (on older operating systems, Options may be available under the 

View menu). 
4. Make sure the checkbox for "Show only TrueType Fonts" is unchecked. 

http://www.fontsource.com/
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#12067: Fontographer 4 Release Notes  

June 24, 1993 
 
Welcome to Fontographer 4! Since we went to press with the User's 
Guide, we have come up with a few special notes we'd like you to be 
aware of. It is very helpful for you to read this document before any 
questions with the program arise. If you don't see the answer here or 
in the User's Guide, then please examine the "Technical ReadMe" before 
calling for Technical Support. 
 
*** GENERAL NOTES *** 
 
-The Fontographer installation requires about 3100K of disk space. The 
installation is very simple. Just double-click on the "Installer" file 
on "Install Disk 1" and then follow the instructions. Installer 
instructions are included in the package should you need to consult it. 
 
-The first time you run Fontographer, it will display a Personalization 
dialog. Consult the Key and Serial Number card in your box for the Key 
Number which will allow you to use Fontographer. 
 
-Fontographer 4.0 has balloon help for all menus, tool palettes, and 
windows, but not for dialogs. Hopefully that will be all you need. 
 
-If you want to know our technical support phone number look in the 
about box (It's 214-680-2093). Look in the same place for your serial 
number which will be requested when you call Technical Support. 
 
-To open several files at once, drag them directly onto the application 
icon in the Finder (System 7 only). 
 
-If you liked the way Fontographer 3.5 handled Snap-to-point, use the 
"Preferences" dialog to "Automatically align with all points." 
 
-Option-Select All will select everything in the Font Window-even slots 
that are empty 
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-If you change encoding vectors in "Font Info," you must use the 
Advanced Mode of "Generate Font Files�¦" to actually output the font with 
that encoding. 
 
*** MEMORY USAGE IN FONTOGRAPHER 4 *** 
 
-While Fontographer 4 will run on System 6 with 2.5 mb RAM, it runs 
much better and faster with more RAM. When a font is opened, it is 
retained completely in RAM. A font database can easily exceed 500K. 
Therefore, do not expect memory management to work the same as it did 
in previous versions. If you want to work on four fonts at once with several 
Outline Windows open, the recommended 3,000K may be inadequate. To 
increase your memory partition, simply close Fontographer, go to the Finder, 
select the Fontographer icon, choose "Get Info" from the File menu, and 
increase the suggested memory setting to 4,000 or more. 
 
-To save memory, use the "Preferences�¦" dialog to reduce the number of 
undos. 
 
-To get the best performance in the Outline Window, turn off "Snap to 
Points" in the View menu. Also, go to the Preferences dialog's "Point 
display" pop-up menu and turn off "Show points while dragging paths." 
 
-Font names vs. File names 
When you save your database, you are offered a 
suggested filename. The suggested name is taken from the "Font Info" 
Family and Style fields. But you can enter any file name you like in the 
"Save As" dialog. Having several different file names and font names can 
become confusing, so be consistent and use careful planning in your 
file naming conventions. TIP: The "Save As�¦" command can be used to 
change the file name. The saved font will still reflect the old font name 
(since it hasn't changed) which is shown in the Font Window. 
 
*** SCANNING AND TRACING *** 
 
-HP ScanJet Plus Users 
If you want to use your scanner to scan images that you will paste 
into Fontographer 4, an upgrade to the ScanJet IIc software is 
necessary. Here is the contact information: Customer Service: 
800-233-5153. C1794-13900 is the part number for the new ScanJet 
package. On CompuServe, Go HPper: Misc files dir; get DSiie1.sea and 
DSiie2.sea 
 
-Pasting Bitmaps 
The User's Guide describes the process of pasting a PICT with the 
option key held down to get the image to scale between the baseline- 
ascent. The current version of Fontographer 4 supports the 
Option-Paste commands using the Edit menu, but not the Option-Command-v 
command from the keyboard. 
 
*** DISK CONTENTS NOT COPIED TO YOUR HARD DRIVE *** 
 
-"Fontographer Sounds" are on Disk 2. This file is not installed with 
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the application, so you'll need to copy it into the same folder as 
Fontographer to get a cool aural sensation while playing in 
Fontographer. 
 
-"TypeTerminology.sea" is on Disk 2. It is a HyperCard stack of our 
award-winning booklet about typographical terms (past and present). You 
must have the HyperCard application or a run-time version to use this 
stack. To move this stack to your hard drive, copy it first, then 
double-click the icon to decompress the file. 
 
*** IN CLOSING *** 
 
That's about it. Thank you for buying Fontographer 4.0. We hope you 
enjoy using it as much as we enjoyed creating it! 
 
The Altsys Font Products Team 

 

#12069: Fontographer 4.1 release notes  

February 25, 1996  
 
Welcome to Macromedia Fontographer 4.1 for Windows(TM)! If you run 
into a question and don't see the answer here, or in your 
documentation, then please examine the "4.1 TechNotes" frequently asked 
questions file (TechNote.wri) before calling for technical support. The 
file is in Windows Write/WordPad format. Open it in virtually any word 
processor, or import it into your page layout program. 
 
 
Our Internet address is http://www.macromedia.com. 
 
Macromedia has a fully-functional Web Site. For those of you with a 
Web Browser, you can access our Web Site 24-hours a day to download the 
latest update to your software, or find a TechNotes addressing a 
technical problem. 
While we still welcome your phone calls, you will likely find that roaming our 
Web Site and contacting us electronically will give you the most complete 
answer to your most common questions. 
 
 
 
Minimum System requirements: Windows 3.1 with 32s v1.3; 6 MB 
RAM; 5 MB HD space. 
 
 
 
There is some possibility that you may not get the correct program icon 
if you are installing onto Windows 3.1 and updating it to 32s at the 
same time. To get the correct icon, open the File Manager, go to File, 
Properties, and click "OK." 
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The first time you run Fontographer, it will display a Personalization 
dialog. Look at the Serial Number card in your box for the 18-digit 
Serial Number which will allow you to use Fontographer. 
 
If the serial number is not typed correctly, Fontographer will not run. 
Be sure to include the dashes. If you paste in your serial number 
rather than typing it in, the OK box will remain grey. Please type in 
your serial number -- you don't really want it cluttering up your disk, 
anyway -- and staple the serial number card into your manual! Please 
retain the card with your records, since you will need the information 
for technical support, or if you install Fontographer on a different 
machine. 
 
 
 
If you notice that Fontographer's sounds preferences is greyed out, 
this is because you either don't have a sound board, or the board you 
have is not asychronous. 
 
 
 
Windows User Interface Guidelines say that all Windows should be 
maximized when one is maximized. Therefore, when a font is maximized, 
an opened character or bitmap window will also be maximized. 
 
 
In characters with "counters" (like "o"), where the outside path should 
go clockwise and the other should be COUNTERclockwise, beware: if both 
paths go in the same direction, the character will print solid black, 
with no white center. To avoid unpleasant surprises like this, check 
your path directions -- or, use Fontographer's useful, time-saving 
function, "Correct path direction" -- before font generation. 
 
 
 
What settings do the "easy" kern and spacing functions use? Well, Easy 
AutoKern is equivalent to (but faster than) using Advanced Kerning when 
it is set on the default values, where the "Technique" pop-up menu is 
set to Examine Average Distance. 
 
Easy AutoSpace results are the same as Advanced, where the "Technique" 
pop-up menu is set to Examine Average Distance. 
 
 
  
If you create a font for the Macintosh using Fontographer 4.1 on your 
PC, use our Macromedia conversion utility (called MMPC2MAC) to finish 
the process ON THE MACINTOSH! This is a Macintosh application that 
builds Macintosh font files ONLY from files that are produced using 
the Windows version of Fontographer 4.1. If you are running Windows 
3.1, you will not see the $ appended to the name of the font as 
described in your documentation. This is because Windows 3.1 uses 
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the 8.3 naming convention. You will still be able to successfully 
convert your files. Note that you CAN'T convert the font files while 
they are on the diskette -- they must be copied to the hard drive of 
the Macintosh. 
 
 
When autotracing a bitmap, particularly a signature, it is possible 
to overflow the buffer. If your trace has lines sticking out all 
over it, undo it, undo the paste, and go back and break the bitmap up 
into sections. Then paste the sections into individual character cells, 
and trace. 
 
 
Sometimes when opening an existing font, the space character is not 
defined. Be sure that your space character has a width! Otherwise you 
may get bullets in your PostScript font! 
 
 
 
The Control key causes a demagnified move -- but it is also used for 
other key combinations. If you find, for example, that you want to 
temporarily switch to the arrow tool and drag-select an object, when 
you start moving the mouse it will go VERY slowly. As long as the 
Control key was depressed before you started dragging, you can let 
go of it and the arrow tool will still be selected -- which will 
move a lot faster! 
 
 
 
For non-Roman fonts, here are some sample entries for the 
Font Info/OS/2 Data/Code Page text field: 
 
00000004 - Cyrillic 
00000008 - Greek 
00000010 - Turkish 
00000020 - Hebrew 
00000040 - Arabic 
00000080 - Baltic 
 
 
 
If you open a symbol-encoded font and try to generate a new 
(non-symbol) font from it, the characters won't show when using the 
new font. This is because of the unicode numbers assigned to the 
symbols. In order to successfully regenerate the symbol font as a 
"regular" font, you will have to set the code page to default, or 
simply copy and paste the characters into a new empty font. 
    
 
Since certain characters (such as the curly quotes) don't exist in some 
Windows system fonts, when you type these characters into a field which 
uses that font (such as AutoKern/Advanced/Which characters), you will 
see only bars for your text. The characters will still get kerned, 
they just can't show up in the text field. 
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Your custom-named characters, and a few others which are not visually 
represented, will appear as a double asterisk (**) in the Font Window 
(when viewing by Character). 
 
 
PRINTING WITH FONTOGRAPHER'S PRINT COMMAND 
 
If you have difficulty printing via Fontographer's "Print" command, 
then you most likely have a print driver that isn't 100% Windows 
compatible, or you don't have the proper fonts installed. Below are 
some tips to help you print successfully. 
 
- Install Arial: Fontographer depends on the font "Arial" for 
 most of its printing. You should install this font from your 
 Windows disks if it is not already installed. 
 
- Always print a test page: When you install your print driver, 
 you should print a test page if the installer prompts you to 
 do so. This will test the basic operation of the print driver. 
 If you're running Windows95, the test page should contain about 
 half a page of information about your printer. If you only see 
 a small graphic at the top of the page, or less than one-third 
 of a page of information, then your driver probably isn't 100% 
 Windows compatible. 
 
- Choose a different print driver: Changing print drivers will 
 almost always solve your printing problems. In general, you 
 should switch to a driver with a similar name, and probably a 
 less complex name. For example, if you have trouble printing 
 to an Apple LaserWriter Pro 630, then switch to the basic 
 AppleLaserWriter driver. Consult your Windows user manual to 
 learn more about changing print drivers. 
 
- The "Apple LaserWriter" driver: This driver works well for most 
 PostScript laser printers, including the Apple LaserWriter Pro 
 series, the HP LaserJet 4M series, and many others. 
 
- Where to get new drivers: If you can't find a driver that works, 
 then contact your printer manufacturer. You can probably find 
 their phone number in the manual that came with your printer. 
 Printer manufacturers frequently release new drivers that fix 
 compatibility problems. 
 
 
 
If you are using pressure sensitive tablets with Fontographer, then be 
sure you have the most recent versions of the software drivers. In 
testing, we used the Wacom Art-Z tablet, the only tablet with an 
available Windows95 driver that we could get our hands on during 
development. 
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The Logitech PageScan (TM) Color Scanner will scan bitmaps directly 
into Fontographer's template layer. This may work quite well for you, 
or it may be better to scan them into Paint/PaintBrush, clean up the 
scan, select the area you want to trace, and then use copy and paste 
to get the bitmap into Fontographer. 
 
 
 
If you require 3.5" disks instead of a CD ROM, please refer to the 
Floppy Disk Request card in your box. 
 
 
 
If you need technical support, call 415-252-9080. MAKE SURE YOU HAVE 
YOUR SERIAL NUMBER ON HAND since it will be requested when you call 
Technical Support. 
 
 
 
Special thanks to Peter Belew, Erik Breiter, Michael Charness, 
James S. Clark, Mayrev Eleasari, Martha Forsyth, Bob Hallissy, Kelvin Ishigo, 
Nicole Josan, Ted Keener, Jim Link, Don Lyckman, Thomas Milo, 
Duane Roberts, Shannon Sidbury, Simon Smith and Bill Troop. 
 
 
 
IN CLOSING... 
 
That's about it. Thank you for buying Macromedia Fontographer 4.1 for 
Windows. We hope you enjoy using it as much as we enjoyed creating it! 
 
The Macromedia Fontographer Team 

  

 

#12094: Fontographer 4.1.5 Release Notes  

October 1, 1996  
 
Welcome to Macromedia Fontographer 4.1.5 for Windows(TM)! If you run 
into a question and don't see the answer here, or in your 
documentation, then please examine the "4.1 TechNotes" frequently asked 
questions file (TechNote.wri) before calling for technical support. The 
file is in Windows Write/WordPad format. Open it in virtually any word 
processor, or import it into your page layout program. 
 
Our Internet address is http://www.macromedia.com. 
 
Macromedia has a fully-functional Web Site. For those of you with a 
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Web Browser, you can access our Web Site 24-hours a day to download the 
latest update to your software, or find a TechNotes addressing a 
technical problem. While we still welcome your phone calls, you will likely find 
that roaming our Web site and contacting us electronically will give you the most 
complete answer to your most common questions.  
 
 
Minimum System requirements: Window 95 or NT 3.5.1, 6 MB RAM; 5 MB HD space.  
 
 
The first time you run Fontographer, it will display a Personalization 
dialog. Look at the Serial Number card in your box for the 21-digit 
Serial Number which will allow you to use Fontographer. Be sure to include the 
dashes. If the serial number is not typed correctly, Fontographer will not run. 
Please retain the card with your records, since you will need the information 
for technical support, or if you install Fontographer on a different 
machine. 
 
 
 
If you notice that Fontographer's sounds preferences is greyed out, 
this is because you either don't have a sound board, or the board you 
have is not asychronous. 
 
 
 
Windows User Interface Guidelines say that all Windows should be 
maximized when one is maximized. Therefore, when a font is maximized, 
an opened character or bitmap window will also be maximized. 
 
 
 
In characters with "counters" (like "o"), where the outside path should 
go clockwise and the other should be COUNTERclockwise, beware: if both 
paths go in the same direction, the character will print solid black, 
with no white center. To avoid unpleasant surprises like this, check 
your path directions -- or, use Fontographer's useful, time-saving 
function, "Correct path direction" -- before font generation.  
 
 
 
What settings do the "easy" kern and spacing functions use? Well, Easy 
AutoKern is equivalent to (but faster than) using Advanced Kerning when 
it is set on the default values, where the "Technique" pop-up menu is 
set to Examine Average Distance. 
 
Easy AutoSpace results are the same as Advanced, where the "Technique" 
pop-up menu is set to Examine Average Distance. 
 
 
  
If you create a font for the Macintosh using Fontographer 4.1 on your 
PC, use our Macromedia conversion utility (called MMPC2MAC) to finish 
the process ON THE MACINTOSH! This is a Macintosh application that 
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builds Macintosh font files ONLY from files that are produced using 
the Windows version of Fontographer 4.1. Note that you CAN'T convert 
the font files while they are on the diskette -- they must be copied 
to the hard drive of the Macintosh. 
 
 
 
When autotracing a bitmap, particularly a signature, it is possible 
to overflow the buffer. If your trace has lines sticking out all 
over it, undo it, undo the paste, and go back and break the bitmap up 
into sections. Then paste the sections into individual character cells, 
and trace.  
 
 
 
Sometimes when opening an existing font, the space character is not 
defined. Be sure that your space character has a width! Otherwise you 
may get bullets in your PostScript font! 
 
 
 
The Control key causes a demagnified move -- but it is also used for 
other key combinations. If you find, for example, that you want to 
temporarily switch to the arrow tool and drag-select an object, when 
you start moving the mouse it will go VERY slowly. As long as the 
Control key was depressed before you started dragging, you can let 
go of it and the arrow tool will still be selected -- which will 
move a lot faster! 
 
 
For non-Roman fonts, here are some sample entries for the 
Font Info/OS/2 Data/Code Page text field: 
 
00000004 - Cyrillic 
00000008 - Greek 
00000010 - Turkish 
00000020 - Hebrew 
00000040 - Arabic 
00000080 - Baltic 
 
 
 
If you open a symbol-encoded font and try to generate a new 
(non-symbol) font from it, the characters won't show when using the 
new font. This is because of the unicode numbers assigned to the 
symbols. In order to successfully regenerate the symbol font as a 
"regular" font, you will have to set the code page to default, or 
simply copy and paste the characters into a new empty font. 
    
 
 
Since certain characters (such as the curly quotes) don't exist in some 
Windows system fonts, when you type these characters into a field which 
uses that font (such as AutoKern/Advanced/Which characters), you will 
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see only bars for your text. The characters will still get kerned, 
they just can't show up in the text field. 
 
 
 
Your custom-named characters, and a few others which are not visually 
represented, will appear as a double asterisk (**) in the Font Window 
(when viewing by Character). 
 
 
PRINTING WITH FONTOGRAPHER'S PRINT COMMAND 
 
If you have difficulty printing via Fontographer's "Print" command, 
then you most likely have a print driver that isn't 100% Windows 
compatible, or you don't have the proper fonts installed. Below are 
some tips to help you print successfully. 
 
- Install Arial: Fontographer depends on the font "Arial" for 
 most of its printing. You should install this font from your 
 Windows disks if it is not already installed. 
 
- Always print a test page: When you install your print driver, 
 you should print a test page if the installer prompts you to 
 do so. This will test the basic operation of the print driver. 
 If you're running Windows95, the test page should contain about 
 half a page of information about your printer. If you only see 
 a small graphic at the top of the page, or less than one-third 
 of a page of information, then your driver probably isn't 100% 
 Windows compatible. 
 
- Choose a different print driver: Changing print drivers will 
 almost always solve your printing problems. In general, you 
 should switch to a driver with a similar name, and probably a 
 less complex name. For example, if you have trouble printing 
 to an Apple LaserWriter Pro 630, then switch to the basic 
 AppleLaserWriter driver. Consult your Windows user manual to 
 learn more about changing print drivers. 
 
- The "Apple LaserWriter" driver: This driver works well for most 
 PostScript laser printers, including the Apple LaserWriter Pro 
 series, the HP LaserJet 4M series, and many others. 
 
- Where to get new drivers: If you can't find a driver that works, 
 then contact your printer manufacturer. You can probably find 
 their phone number in the manual that came with your printer. 
 Printer manufacturers frequently release new drivers that fix 
 compatibility problems. 
 
 
 
If you are using pressure sensitive tablets with Fontographer, then be 
sure you have the most recent versions of the software drivers. In 
testing, we used the Wacom Art-Z tablet, the only tablet with an 
available Windows95 driver that we could get our hands on during 
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development. 
 
 
The Logitech PageScan (TM) Color Scanner will scan bitmaps directly 
into Fontographer's template layer. This may work quite well for you, 
or it may be better to scan them into Paint/PaintBrush, clean up the 
scan, select the area you want to trace, and then use copy and paste 
to get the bitmap into Fontographer. 
 
 
 
If you require 3.5" disks instead of a CD ROM, please refer to the 
Floppy Disk Request card in your box. 
 
 
 
If you need technical support, call 415-252-9080. MAKE SURE YOU HAVE 
YOUR SERIAL NUMBER ON HAND since it will be requested when you call 
Technical Support. 
 
 
 
Special thanks to Peter Belew, Erik Breiter, Sherman Canady, 
Michael Charness, James S. Clark, Shannon Easley, Mayrev Eleasari, 
Martha Forsyth, Bob Hallissy, Kelvin Ishigo, Nicole Josan, Ted Keener, 
Jim Link, Don Lyckman, Thomas Milo, Duane Roberts, 
Simon Smith and Bill Troop. 
 
 
 
IN CLOSING... 
 
That's about it. Thank you for buying Macromedia Fontographer 4.1.5 for 
Windows. We hope you enjoy using it as much as we enjoyed creating it! 
 
The Macromedia Fontographer Team 

  

 

#12207: Quick Tips for Fontographer  

Here are some fast and friendly tips for Fontographer users, courtesy of Macromedia Technical Support. 

1  To change layers, click on the NAME of the layer (Outline, 
Template, Guides, Hints) in the Layers Palette instead of 
clicking the check box. The check box indicates activated 
layers.  

2  Some EPS files (such as Photoshop EPS) contain bitmap 
images within an EPS wrapper. Fontographer can only import 
an EPS file which has path information. See Problems 
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Importing EPS files into Fontographer (TechNote 3721).  

3  In order to draw a perfect square or circle, hold down Shift 
while using these tools.  

4  Fontographer generated fonts for Windows Truetypes will not 
display satisfactorily below 12 pt without Delta hinting. Delta 
hinting can be applied to a font by a third-party vendor. See 
Rehinting a font (TechNote 03722).  

5  File > Save As creates a database. Fonts can only be created 
by using File > Generate Fonts. See Saving a database versus 
generating a font (TechNote 12326).  

6  Give your fonts a name via the Element > Font Info menu.  

7  When attempting to open a Windows font on the Macintosh 
using PC File Exchange, you must drag the font to the 
Macintosh hard drive in order for it to be processed by PC 
File Exchange. See Macintosh Fontographer cannot open 
Windows font (TechNote 12296).  

8  Truetype fonts may not print correctly to a PCL printer unless 
the printer driver settings are set to "Print Truetype fonts as 
Graphics". See Fontographer 4.1 Windows Printer Conflicts 
(TechNote 12320).  

9  When generating Macintosh Postscript fonts, you must 
update the screen fonts using Element > Recalc Bitmaps to 
reflect any changes made to the outlines. See Screen font 
doesn't reflect changes to outline font (TechNote 12327).  

10  Use Option-Copy and Option-Paste on the Macintosh in order 
to preserve the scaling of characters pasted into 
Fontographer.  

11  In order to avoid Postscript ID conflicts on the printer, you 
should assign an ID of zero when generating a Type 1 
PostScript font.  

12  Windows font families only display the name of the parent of 
the family in application menus. Select the Bold or italic 
variant using the Style option. See Creating PC font Families 
(TechNote 12319).  

13  You will get an error -11501 when trying to OPEN screen 
fonts in Fontographer. You must IMPORT screen fonts in 
order to get them into Fontographer. See Could not open file 
-unknown format (TechNote 03705).  

14  Fontographer 4.1 Key Numbers should be typed in with 
extensions off and Caps Lock on. Be sure to distinguish zeroes 
and capital-O's! See Fontographer 4.1 errors and extension 
conflicts (TechNote 12314).  

15  Fontographer 4.1 for PC can only print at 300 dpi. Change 
your printer driver settings via the Printer Control Panel and 
Printer properties. Fontographer 4.1 Windows Printer 
Conflicts (TechNote 12320).  
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16  Always open fonts with their original encoding. This option is 
set under the File > Preferences menu. See Encoding vectors 
FAQ (TechNote 3713).  

17  Use the File > Preferences menu to set your Point Display 
Preferences to "Highlight the ends of unclosed paths" and 
"Highlight adjacent points that overlap." These preferences 
will reveal path problems, if any exist.  

18  If your characters are not showing a correct fill you can use 
Element>Correct Path Direction to fix this problem.  

19  Macintosh Fontographer versions 4.1 - 4.1.2 are NOT 
compatible with Open Transport and require the free 
FOG413 updater available on our web site. See Where to find 
Fontographer Updaters (TechNote 3720).  

20  When troubleshooting a Macintosh font, one of the first tests 
is to check for a valid install. Apple recommends dragging a 
font on top of the System folder in order to properly install it.  

21  If you see a rectangle instead of the character you typed, 
then that character doesn't exist in the encoding vector which 
you used to generate the font. See Font displays rectangles 
instead of characters (TechNote 12364).  

22  If every character you type displays as a rectangle, then the 
font is corrupt. Copy contiguous slots of characters from your 
database into a new font database and regenerate the font. 
See Repairing Corrupted Fonts (TechNote 3735).  

23  If you can only see Truetype fonts in your applications, then 
it is likely that your Fonts Control Panel Options are set to 
"Show only TrueType fonts..." Uncheck this box in order to 
view PostScript fonts in Windows applications.  

24  A simple way of creating an outline font is to use Element > 
Expand Stroke on the outermost stroke of your characters and 
counters. Use Element > Correct Path Direction to make sure 
everything is right. See Creating Outline or Keycaps fonts 
(TechNote 12910).  

25  Many logo fonts will not display on Windows until the 
artwork is split into two character slots. Using a negative 
offset on the second character can allow a two-keystroke logo 
to rasterize properly and display seamlessly. See Creating a 
Complex Logo Font (TechNote 03701).  

26  Leading can be adjusted via the Element > Font Info dialog. 
Change the Acscent or Descent to provide the amount of 
leading you want. Ignore the Leading field.  

27  Windows fonts with leading problems can usually be fixed 
using the usWINascent parameter. This field can be edited on 
the Macintosh via the PC Font Access utility. Windows 
Fontographer 4.1 can edit this field via the Element > Font 
Info > OS/2 Metrics table. See PC Truetype Leading Issues 
(TechNote 12651).  
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28  In the Element> Font Info dialog, be sure to select Style 
names ONLY with the mouse when preparing a Windows 
font family using Macintosh Fontographer.  

29  If you want to make a font family, make the variations in 
Fontographer. Don't use the Style option in applications to 
fake a bold or italic.  

30  Don't skew a font and call it Italic. It's oblique, but definitely 
not italic.  

31  Despite the instructions in the documentation, it is not 
necessary to back up your CD onto floppies!  

  

 

#12296: Macintosh Fontographer cannot open Windows font 

Issue 

When attempting to open a Windows font file (PFB or TTF) located on a disk, an error message appears 
indicating "End of File -39." 

Reason 

Either of the following reasons may cause this error message to appear: 

• PC Exchange not processing the file  
Macintosh can open and edit Windows files with its Easy Open and PC Exchange features. Both 
of these features have been located on the File Exchange Control Panel since the Macintosh 8.5 
operating system. PC Exchange provides the ability to open files from Windows DOS disks with 
Macintosh applications. Sometimes the font file, when accessed from a removable disk, is not 
properly processed by PC Exchange. 
 
Solution To be sure that PC Exchange has properly processed the file, drag the Windows font 
file from the disk to the Macintosh hard drive. Then, in Fontographer, open the font file that is 
now located on your hard drive. 

• Corrupted font  
This error message will also occur if the font is corrupt. 
 
Solution See Repairing Corrupted Fonts (TechNote 3735) for steps to solve this problem. 

 

#12297: Can't perform Save or Save As 

Issue 

 
Can't perform a Save or Save As after loading in an old Fontographer database while running 
Fontographer 4.1 Windows under Windows 3.1.x. 
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Reason 

This can actually occur in a new font as well. Fontographer 4.1 Windows doesn't truncate a filename 
when that filename has a special character in it. 

DOS 8.3 naming convention example: filename.ttf vs. filename xxx.ttf 

Solution 

Delete any special characters from the font Family Name under the Element > Font Info > General 
menu. 

You may be able to use special characters in your font name by using the PCLT TrueType parameter for 
filenames. See Element > Font Info > TrueType PCLT. 

 

#12310: Creating and installing FONs  

Issue  
How to create and install FON files. 

Solution 

When generating a TrueType font for Windows in Fontographer it will be noticed that sometimes the 
screen display is not satisfactory. The primary reason that this happens is because Fontographer 
generates a display of 72 dpi and MS-Windows displays at 96 dpi. Display can also become 
unsatisfactory due to the video driver. Try selecting the generic VGA driver in the Display Control Panel 
settings. 

The 4/3 Rule - Use the following formula to compensate for the discrepancy: 

1  Select the point size needed. Divide by 3 and multiply by 4 (12 divided by 
3 = 4 x 4 = 16)  

2  
Generate a 16 pt. in order to display it at 12 pt. within MS-Windows. The 
most popular sizes would be: 16,24,32,48. For odd sizes (such as 10 pt.) 
round up.  

3  

When generating fonts be sure to select TrueType and FON. Type in the 
desired sizes as well. There will be a *.ttf file as well as the FON files. Both 
of these will need to be installed in the Control Panel. *.fnt files are the 
bitmapped point sizes inside the FON which can't be seen or edited.  

Installing FONs 

1  FONs will be listed at 96 dpi in the install window  

2  

FONs will not display correctly (when installed without a TTF) unless the 
Default Printer is set to a non-PostScript printer driver. FONs might be 
seen without the driver in Paintbrush or Write but you will need the driver 
to see them anywhere else. The Windows TrueType rasterizer uses the 
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Printer Driver to build the fonts (as well as the Video Driver).  

3  
Always install *.ttf files BEFORE installing the FONs and do NOT install 
them together by doing a Select All or highlighting them together for 
installation. Do NOT use spaces in the name of your FONs.  

4  

Sometimes FON files (and TTFs) will not show up in the Control Panel 
dialog. This problem may be solved by removing some fonts. Moving the 
font to the top of the win.ini file has also been known to work. If there are 
too many sizes or the FON is bigger than 64K it may not work correctly. 

Other Issues for Macintosh and PC generated FONs 

All font data is passed from the Windows printer driver to the application which is using the font. 
Windows applications may vary in their interaction with a given printer driver in such a way that one 
application will rasterize (for example) a 9 pt. FON at 11 pt. in order to display as a 9 pt. Another 
application may need to be selected as a 12 pt. in order to display as a 9 pt. 

If you cannot see the FONs at the correct size, try switching printer drivers. The best solution is to create 
a waterfall of all sizes in each application in order to find the best display for the target point size. 

Refer to the User Manual (check the index for FONs) for a chart on how cross-platform bitmap sizes 
translate. 

In order to confirm that the application will display a FON at the size expected, open the TTF while 
running the PC Font Access utility which is in the Macintosh Fontographer folder. The lowestRecPPEM 
(see the Minimum Pixels per em field in FOG 4.1 for Windows) setting should never be greater than the 
lowest point size of the FONs. 

For example, a 10 pt. FON should have a lowestRecPPEM setting should of 9. This will keep Windows 
from substituting the MS San Serif font. Instead, the System will go out and look for an FON size above 9 
pt. and will find the 10 pt. FON. 

Additional information 
When FONs refuse to work properly the work-around is to embed the bitmaps inside of the TrueType. 
This method has its own problems and is discussed in tech note 12561. 

 

#12311: Creating Handwriting Fonts in Fontographer for Windows  

This tutorial is designed to illustrate the easiest method of creating a handwriting font. Handwriting 
samples should be fairly large, 3 inches is ideal. If the sample handwriting is too small, make a 
photocopy and enlarge it. Keep in mind that your characters must be properly proportioned in order to 
appear correct in Fontographer. 

1. Open a new font using File > Open Font. 
2. Name your font under Element > Font info > General using the Family Name field. 
3. Scan the handwriting example at no more than 300 dpi. 
4. Using your scanner software, save it as a .BMP file. The Logitech PageScan Color Scanner will 

scan images directly into Fontographer�™s Template Layer as described in the Fontographer 
Readme.txt file in your Fontographer folder. 
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5. In Paint/Paintbrush: 
 
Open the BMP file in Paint or Paintbrush. 

6. Draw a rectangle which appears to be about twice the height of the capital letter M, and half 
again as wide. This will establish the tallest and widest character in your font (hence the term em 
square) and all your characters will be uniformly scaled on this rectangle when they are brought 
into Fontographer. Make sure the rectangle never touches the character and use the same 
rectangle for all of your characters. Positioning your characters in Fontographer will be easier if 
you create a hash mark, on the lower left edge of this rectangle, to represent the baseline. 

7. Using the Select tool, drag a marquee around a character and select Copy. 
8. Select Paste. This will place a copy of the character in the upper left corner of your document. 
9. The cursor will change to a four-pointed arrow. Position this over the newly pasted character. 

Click and hold the mouse button, and drag (while holding down the mouse button) the pasted 
character to the inside of your drawn rectangle. Position it so that the bottom of the character is 
about 1/3 of the way up from the bottom of the rectangle. Then let go of the mouse button. 

10. Use Edit > Select All then select Edit > Copy. 
11. In Fontographer: 

 
Open the character window for the character you are copying, such as M. 

12. Select Edit > Paste. 
13. If you need to reposition the character, go to Fontographer�™s Layer palette, and click on the 

WORD Template. This does not mean the check box! The checkboxes only display/hide the 
contents of a layer. Clicking on the NAME of a layer will move you to that layer. 

14. You may move the box and its contents with the arrow cursor or the arrow keys on your 
keyboard. 

15. When you are satisfied with the position of the character, go back to the Fontographer Layer 
palette and click on the WORD Outline. This will move you to the Outline, or drawing, layer of 
Fontographer. 

16. Choose Element > Autotrace. A dialog box will appear. For the purposes of this tutorial, use the 
default settings. 

17. Position the character on the baseline. Then, delete the rectangle which surrounds the character 
by double-clicking on one of its points (which will highlight ONLY the path of the rectangle) and 
pressing delete. 

 

#12312: Creating Symbol fonts for Windows  

PC Symbol encoding is normally used for fonts which must work with application features such as 
Microsoft Word's "Insert Symbol". 

Follow these steps to create a PC Symbol encoded font: 

1  If building from an existing font, open the font with original encoding. See Encoding 
Vectors FAQ for details.  

2  Use the File > Generate Font Files, "Advanced" dialog to set the encoding to Custom.  

3  Select "Decorative" under the PC Family pop-up menu on the right.  
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4  Click on the Truetype Options button and select the "Use Symbol Encoding" check 
box.  

  

 

5  Select the "Character Mapping" pop-up menu and set it to "Sequential."  

The font will now respond to applications which use "Insert Symbol." 

This procedure is the same for both Macintosh and Windows Fontographer in versions 4.1 and above. 

Additional Information  
Be advised that PC Symbol encoding was not intended to work with Unicode keyboard drivers. 

  

 

#12313: Font Embedding in Fontographer 4.1 Windows  

Issue 
Embedding levels of a Windows TrueType font are not recognized by Adobe Acrobat. 
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Reason Embedding is the practice of inserting a parameter into a font so that it can be recognized by 
Adobe Acrobat. Adobe Acrobat creates a file which allows the user to view information without installing 
the fonts used in that file. 

A known issue exists with fsType parameters in Fontographer. These parameters may be edited by 
Fontographer but at the time that Fontographer was created these values were not being read by Adobe 
Acrobat. 

Now that Acrobat is making full use of these parameters, the values which Fontographer inserts may be 
defective. 

Solution  
The safest method to work around this problem is to use Fontographer only to insert a placeholder value 
in the fsType field. 

Choose the Element > Font Info > OS/2 Data dialog box and set the fsType embedding field to: 

 $0004 Read / Write  

After inserting this value and generating the font, the embedding level should then be set by using 
Microsoft's Font Properties Editor. 

  

 

#12314: Fontographer 4.1 errors and extension conflicts 

Issue 

I'm getting an error: when autotracing, installing Fontographer or while editing a font. 

Reason 

Open Transport conflicts may be displayed as: Illegal User, Type 1, Type 11, or other system errors. 
Fontographer 4.1.2 (and earlier versions) have Network Copy Protection which conflicts with Apple's 
Open Transport. 

Solution 

This problem is fixed via a free updater available at the Macromedia Fontographer Support Center. 

Power PC users will need the FOG413Pm.hqx updater. 68K Macs will use the FOG413FPU.hqx updater. 
68K Macs without a floating point coprocessor will use the FOG413NFPU.hqx updater. These are binary 
files which can be uncompressed with StuffIt or BinHex. 

Steps 

1. If Fontographer has not been successfully installed or will not accept the Key Number, restart the 
computer while holding down Shift in order to turn the Extensions off. 

http://www.microsoft.com/typography/property/fpedit.htm?fname=%20&fsize=
http://www.macromedia.com/support/fontographer/downloads.html
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2. To run the updater, double-click on its icon. The updater will fix your copy of Fontographer and 
return a message which says, "Successfully updated." 

3. If Fontographer still won't run with Extensions on then there is a definite Extensions conflict. Use 
"Conflict Catcher" or the Extensions Manager to find out which Extension is causing the conflict. 

 

#12317: MMPC2MAC Utility & Size 8,11,14 Bitmap Conflicts 

Issue 

When I drag my font on top of the MMPC2MAC utility, I'm getting an error message: "MMPC2MAC 
can't process this file. Make sure it is a Macintosh file produced using Fontographer 4.1 Windows." 

Reason 

Users will find that not all point sizes can be recognized by this utility. This is due to a flaw in the way 
Fontographer calculates the 4/3 ratio from the Windows VGA 96dpi to the Mac 72dpi screen resolution. 

Solution 

Immediate work-around: create the bitmaps in Fontographer (PC) BEFORE generating Mac font files. 
Also, don't include point sizes 8, 11 or 14. If the bitmaps are created in the Generate Fonts dialog there 
is more possibility of errors. The recommended method is to create them using Recalc Bitmaps. 

Follow these steps for creating Bitmaps 

1. Select the Element menu > Recalc Bitmaps. 
2. Specify bitmap point sizes based on the User's Manual, Page 211. 

 
For example: a 9 pt bitmap created on the PC will display as a 12 pt bitmap on the Mac. 

3. Use the default settings of: 
 
Which characters - All characters Options - Preserve character shapes 

4. Click on OK. 
5. Use the Window > Open Bitmap Window menus to hand edit the bitmaps (see the caveat in the 

User's Manual, Page 113). 

The PC files WILL convert correctly, with the exception of sizes 8, 11 and 14. The permanent fix for this 
issue is to request a patch from Fontographer tech support. 

 

#12319: Creating PC font Families 

Issue 

Windows font families can become problematic when certain family members don't show up in the font 
menu. This problem may occur whether the fonts are created on Macintosh or Windows. 

Reason 
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Be advised that Windows only recognizes four members for a given font family name: 

George-Regular ------ this is the head of the family, there can only be one Regular or Plain member! 

George-Bold -------- note that each family can only have one member in the Bold range! 

George-BoldItalic -------- note that each family can have only one BoldItalic or BoldOblique! 

George-Italic -------- note that each family can have only one Italic or Oblique! 

In order to create larger families refer to Large font families in Windows (TechNote tn_3712) or create 
separate families by using a similar but distinct family name: 

GeorgeCondensed-Regular 
GeorgeCondensed-Bold 
GeorgeCondensed-BoldItalic 
GeorgeCondensed-Italic 

You can also just make single stand-alone fonts with only one family member: 

GeorgeUltra-Regular 

A further problem is that Windows classifies fonts by weight. A Bold weight value would be 700. Notice 
that there is no field in Fontographer to enter a Style weight value. The following procedures will cause 
your font to work with the style linking buttons or hot-keys for Bold and Italic. 

Solution 

Follow these steps to properly prepare a Windows font family. 

1. Go to the Element menu and select Font Info. The Family Name field is where the font is named. 
2. Select a style by using the mouse to select a Style from the pop-up menu to the right of the Style 

field. Selecting a Style with the mouse will pop the proper weight value into the font (even 
though this value cannot be seen). 
 
If you enter a style category in the Style file and do not use the mouse, the proper weight value 
will not be assigned to the font. 

3. Under the File menu select Generate Fonts and choose Computer: Windows and Encoding: 
Windows. 
 
Do NOT select any of the styles (Plain, etc.) which appear above the top line at the top of the 
pop-up menu. The Plain style of the font can have its style field left blank. Regular or Normal 
can also be used. 
 
You will notice that Fontographer's list of styles does not include every possible style. For 
example, there is no listing for Condensed. In this case, you would pick the closest possible style 
listing (such as Thin) and then backspace over -Thin and enter -Condensed. 
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Do not type a Style name into the field until one has first been selected with the mouse. 
(Macintosh users, see the Addendum file in your Fontographer folder, p. 28) 
 
Select Windows encoding for most normal fonts. See Inaccessible characters in Windows fonts 
(TechNote tn_3700) for information on the nuances of the Windows encoding vector. 

4. Click the Generate button. Locate the resulting font and drag the TTF or PFB and PFM files to a 
Windows formatted floppy in the Macintosh drive, then transfer the floppy to the Windows for 
installation. 
 
It is not necessary to make any bitmap sizes for Windows fonts. 

Additional Information 

After a Windows family is installed it will only show the family name in an application menu. Windows 
knows to go and get the proper style when it is selected via the application task bar or style menu. 

Example: Arial shows only the name Arial in the Microsoft Word font menu. When the "B" (for Bold) 
styling linking button is clicked, the bold font will be found and used. Incorrect family settings will result 
in a fake bold. 

 

#12320: Fontographer 4.1 Windows Printer Conflicts  

Issue 1  
Can't print at 600 dpi under FOG 4.1 WIN using non-PostScript printer drivers to a hybrid printer. 

Solution  
Downgrade the printer driver properties to 300 dpi and use a PostScript printer driver. 
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Issue 2  
Hybrid printer is in PCL mode when using a PostScript driver (or vice versa). 

Solution  
Use the appropriate driver. (Fontographer will not print from a hybrid printer when using a PCL driver. 
You must use a PostScript driver.) 

Additional Information  
Truetypes which are sent to PCL printers require that the printer driver settings be set to "Print Truetype 
as graphics." Older drivers will need to be set to "raster." 

Issue 3  
Selected characters won't print. 

Solution  
Turn on "Selected Characters" in BOTH the Fontographer AND Windows dialogs. 

Issue 4  
Fontographer won't print at all -blank pages or locks up. 

Solution  
Make sure your printer driver is not older than September of 1993 Install printer drivers which came 
with your printer and try one of them Try a printer driver from a different manufacturer (Agfa, for 
example). If all else fails, generate a font, install it, select from an application menu and print it from the 
application. 

Issue 5  
Character Info is not printing properly 

Solution  
The character info which Fontographer prints with the character can only display properly if the printer 
driver is set to allow for grayscale. 

 

#12322: How do I convert Mac fonts to run on my PC? 

Issue 

How can Macintosh fonts be converted to Windows format? How can Macintosh fonts be opened in 
Windows Fontographer? 

Solution 

Macintosh fonts (and files) have resource forks which are used by Macintosh HFS disk formatting to read 
a file. Windows does NOT use an HFS file structure, therefore it cannot properly interpret a Macintosh 
file. 

Method 1 
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Macintosh Fontographer can be used to generate a Windows font on the Macintosh platform which can 
be installed on a Windows machine. 

Method 2 

The TransMac and CrossFont utilities will strip the resource fork from the font so that it can be used on 
Windows or opened in Windows Fontographer. 

1. Download the TransMac and CrossFont utilities from Acute Systems. 
2. Use the TransMac utility to ensure that your font makes it safely to Windows. TransMac is a 

utility which preserves the binary format of the Macintosh font files you are sending to 
Windows. 
 
There are several ways to maintain file integrity, including using a utility such as BinHex, etc. If 
you don't know how to make sure the files are brought safely to the Windows platform, then 
use TransMac. See the CrossFont readme.txt file for more information on preserving file formats. 

3. After using TransMac you can copy the files onto a floppy disk and bring them to Windows. 
 
It is strongly advised that you use a Macintosh formatted floppy or Zip disk. Experience has 
shown that these utilities are easier to work with when using Macintosh formatted media. 

4. Next, use CrossFont (formerly Wrefont), a Shareware utility that will prepare a Macintosh font to 
be used on Windows. 
 
This utility comes with a readme.txt file which explains how to use it. Macromedia cannot offer 
tech support on how to use this utility. 

Additional Information 

Most problems reported by CrossFont users are because they have failed to bring the Macintosh font to 
Windows in a binary format. 

Play it safe and use TransMac or StuffIt on the Macintosh to create a StuffIt archive which can be brought 
to the Windows machine safely and then extracted with StuffIt for Windows. 

A free evaluation copy of StuffIt for Windows is available from Aladdin Systems. 

Be advised that this version of CrossFont does not keep family styles intact nor is the font's encoding 
necessarily cross-platform. 

After the fonts are stripped of their resource forks they should be opened and re-generated in 
Fontographer in order to keep their family and encoding information intact. 

See Creating portable fonts (TechNote 13365) for information on creating fully compatible cross-
platform fonts. 

Third party links  
Although links to external websites are provided as a resource, the websites are not part of Macromedia. 
Please see Macromedia's policy regarding links to third party websites in the Legal Notices and 
Information section. Pages to external websites will open in a new browser window. 

 

http://www.asy.com/
http://www.aladdinsys.com/
http://www.macromedia.com/help/copyright.html#disclaimer
http://www.macromedia.com/help/copyright.html#disclaimer
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#12323: Increase ascent without scaling characters  

Issue In Fontographer 4.x, increasing the ascent will also scale the font so that the intended result of 
gaining more white space between lines does not occur. 

Solution  
In order to gain the extra line space, without having to scale the characters: 

1  Navigate to Element > Font Info > General 

Element > Font Info only for Macintosh 

2  Uncheck �œRetain path coordinates when changing em square" 

3  Uncheck �œAutomatically compute em square from ascent + 
descent" 

 

At this point, a correct PostScript font can be generated. 

If you wish to create a Truetype, use File > Generate Fonts and select the �œTrueType Options��  button 
and check the �œConfine screen characters to em square��  check box, before generating the font. 
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Additional Information  
Truetype fonts contain font leading as well as a parameter called usWINascent. The usWINascent is the 
leading specified by the Windows operating system. It is possible for the two values to conflict. 

To increase or decrease the leading you can override the Windows operating system by using the 
Element > Font Info menu to select the OS/2 Metrics table and inserting a value into the usWINascent 
field. See PC Truetype Leading Issues for details. 

 

#12324: Problems with Quote or Apostrophe Characters 

Issue 

The wrong character is displayed when a smart apostrophe (�™) or quote characters (�� ) are typed. 
Smart quotes (also known as curly quotes) are fancy characters which make text look better compared to 
the straight apostrophe (') and straight quote or inches character (") that reside on the key to the right of 
the semicolon on the keyboard. 

Reason 

This "wrong" character has been placed in one of the slots designated for the curly quotes or apostrophe 
characters. 

Solution 

Either turn the "Smart Quotes" preference off in the application or do not place characters in these slots. 

Issue Smart quotes do not display in application software. 

Reason The "Smart Quotes" preference has been turned off in the application software. 

Solution In the majority of cases, this is solved by turning on the "Smart Quotes" option in the 
application software. Future conflicts may be avoided by pasting the preferred (straight or curly) type of 
quotes and apostrophes into all slots where these characters are assigned. Once that has been done, only 
the desired characters can be displayed, regardless of the settings for the application's preferences. 

See the appropriate table in the manual to determine which slots contain the characters for a specific 
encoding vector. Make sure to always open a font with its original encoding via the File > Preferences > 
General menu, in order to avoid encoding conflicts. 

  

 

#12325: Repairing corrupted fonts 

Issue 

While trying to install (or open) my font, I got an error message which indicates that my font is corrupted 
-what can I do about it? 
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I'm getting rectangles in place of characters when I try to use my font. 

Reason 

Fonts may become corrupted due to disk errors or memory errors. 

Solution 

Copy and paste all of the font characters into a new font window. The idea here is to ONLY copy slots in 
the font which contain characters. One of the slots which appears empty may contain data which is 
causing the corruption. Take no chances on transferring this corruption into a new font window. 

1. Shift-click ONLY on slots which have characters in them. 
2. Use Edit/Copy to copy the selected characters to the clipboard. 
3. Use File/New to open a new font window. 
4. In the empty new font window shift-click ONLY on slots which correspond to the same positions 

in the old font window. 
5. Use Edit/Paste to paste the characters from the clipboard into the highlighted slots in the new 

font window. 
6. Compare the new font window with the old to ensure that all characters were copied to the 

correct locations. 

Note: Don't forget to import the metrics into the new font window. Also, to avoid problems, set the 
width of the space character (decimal 32) to make sure that inter word spacing doesn't change. 

 

#12326: Saving a database versus generating a font  

"File>Save" or "Save As," is used for saving a Fontographer DATABASE. The name which is chosen 
(Example: mydatabase.fog) is ONLY the name of a DATABASE. 

FONTS are named under Element>Font Info>General (the Mac menu is: Element>Font Info). This is 
where the font's Family Name, and Style name are entered. Unless this procedure is followed -the font 
will always be named "Untitled". 

FONTS are generated under File>Generate Fonts. 

Notes: 

Any imported metrics or bitmapped screen fonts will remain in a DATABASE when re-opened. If a FONT 
is re-opened, everything will have to be re-imported manually. 

When a DATABASE is re-opened, it will retain the printer font's PostScript ID and the suitcase font's 
FOND ID. 

 

#12327: Screen font doesn't reflect changes to outline font 

Issue 
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A font is edited and regenerated but the edits are not reflected in the screen font. 

Reason 

There are two editors in Fontographer. The Bitmap editor and the Outline editor. The Recalc Bitmaps 
feature is used to cause the bitmaps to match the outlines. 
An easy way to think of this is that the outline editor opens by default in Fontographer. This means that 
the editing is normally applied ONLY to the outlines unless the user specifically recalculates the bitmaps 
in order to reflect the changes which were made to the outlines. 

Solution 

If there are not any imported or hand-crafted bitmaps, use Element > Recalc bitmaps to force the screen 
font to recognize changes made to the outlines. 

In order to prevent all of the bitmaps from being recalculated they can be calculated one at a time via 
Windows > Open Bitmap Window using the "Recalc from Outline" button. You can also specify Changed 
or Selected characters within the Recalc Bitmaps dialog. 

 

#12328: Finding the lower right of a character  

The "lower-right of a character" like "T" would mean the bottom of the crossbar of the T. Regarding the 
"lower right", it is the right that gets precedence. 

Generally speaking, you want the origin point to be the rightmost point in a character. If there are 
multiple points at the same x-coordinate value, the lower (lowest) of them takes precedence. This is 
where "correct path direction" will place the origin of the path. 

What if the lower right point happens to be a serif point? 

It doesn't matter. If you are blending fonts, the point is to match the "lower-right" origin point 
placement in corresponding characters. 

 

#12333: Setting Truetype parameters for Unicode Fonts  

Issue  
How can I input the proper parameters into the TrueType table fields in Fontographer? 

Solution  
The data in these fields is obtained from the TrueType Specification (TTF Spec). There are several fields 
which require the user to convert binary to hex before entering them into the applicable field in 
Fontographer, as below. 

Introduction to Unicode Fonts 
The typical computer keyboard (Mac or Windows) uses a combination of 256 keystrokes in a normal 
font. In order to access characters above 256 we must assign another set of 256 keystrokes called a Code 
Page. When a font has the proper Unicode values (found in the Unicode Book from Addison-Wesley 
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Publishing or at the Unicode website) and the proper Code Page settings (found in the TTF spec), then 
the keyboard driver will recognize that the keyboard has a new set of characters assigned for each key. 

In the Windows 95 environment the user needs to install the Multi-lingual Support Package through the 
Add/Remove Control Panel. When the appropriate language keyboard driver is successfully installed it 
will appear in the Keyboard Switcher on the task bar. For example: if the task bar shows "En' for English 
this can be changed by holding down the mouse over "En" and selecting the desired language. Now the 
proper characters should appear when the proper font and keyboard are selected in an application. 

If you don't have the time to invest in learning the TTF spec, try opening a working Unicode font, then 
cut and paste your characters into that font. Be sure to rename and re-generate it as a new font. 

Using the OS/2 Data Table 
These tables are found under the Element > Font Info menus. The following settings are the only tables 
which need editing for a Unicode font. The values in the OS/2 table are to be taken from the TrueType 
Font Spec, version 1.66 is available from Microsoft. 

Understanding the OS/2 Version Field 
The OS/2 Version Field is found on Page 84 of the TrueType Font Spec. Modern fonts will usually use 
Version 1 but some fonts may need to be set to Version 0 to work properly with some applications and 
keyboard drivers. 

Understanding the Selection Field 
The Selection Field is found on Page 98 of the TrueType Font Spec. Most fonts do not need any special 
settings here but Microsoft recommends a setting of $CC40 in order to insure that your font will work 
with older applications. 

Understanding the Code Page Fields 
The OS/2 Code Page Range table is found on Page 101 of the TrueType Font Spec. Here is where the 
user would determine the coverage of language support needed for their font and the appropriate bit 
field settings. 

There are two data entry fields used for entering Code Page information in Fontographer. These fields 
are for entering 4 byte long integers broken up into Hex digits. Every 4 bits = 1 Hex Digit. Every 8 bits 
= 1 Byte. 

Here are the Code Page fields for TimesNewRomanCyrillic: 

Code Page 1: $4000009F - "F" is the first hex digit. Code Page 2: $DFD74000 

Breakdown of the first hex digit: a bit setting of "F" can be referenced in the TTF Spec 1.66 Page 101. 

Hex "F" would be represented in Binary Notation as 1111. This means that in the first bit field ALL of 
the bits are turned on. The first hex digit provides coverage for bit positions 0-3 in the Code Page as 
below. 

Binary 
Bit 
Position 

Code 
Page Description 

1  0  1252 Latin 1  

1  1  1250 Latin 2  

1  2  1251 Cyrillic  

http://www.unicode.org/
http://www.microsoft.com/typography/what/ttfonts.htm
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1  3  1253 Greek  

Referencing this page in the TTF Spec would show us that when bit positions 0-3 are all turned on then 
Latin 1, Latin 2, Cyrillic and Greek would be supported in this font. 

Breakdown of the second hex digit: a bit setting of "9" can be referenced in the TTF Spec this way: 

Hex "9" would be represented in Binary Notation as 1001. This means that in the second bit field, bit 
positions 4 and 7 are turned on. Thus, the second hex digit provides coverage for bit positions 4 and 7 in 
the Code Page as below. 

Binary 
Bit 
Position 

Code 
Page Description 

1  4  1254 Turkish  

0  5  1255 Hebrew  

0  6  1256 Arabic  

1  7  1257 
Windows 
Baltic  

Referencing this page in the TTF Spec would show us that when bit positions 1 and 7 are on then Turkish 
and Windows Baltic would be supported in this font. 

Bit fields 3 through 7 are empty for this font. 

* Breakdown of the eighth hex digit: 

A bit setting of "4" can be referenced in the TTF Spec this way: 

Hex "4" would be represented in Binary Notation as 0100. This means that in the eighth bit field, bit 
position 30 is turned on. Thus, the eighth hex digit provides coverage for bit position 30 in the Code 
Page as below. 

Binary 
Bit 
Position 

Code 
Page 

Description 

0  28  n/a  Alt ANSI & 
OEM  

0  29  n/a  Mac / US 
Roman  

1  30  n/a  OEM  

0  31  n/a  Symbol  

Referencing this page in the TTF Spec would show us that when bit position 30 is on then the OEM 
Character Set would be supported in this font. 

Understanding the Character Range Fields 
The Character Range Fields are found on Page 95 of the TrueType Font Spec. These fields are set by 
converting binary to hex using the same method as for the Code Page fields. 
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Understanding the First and Last Character Fields 
These fields are found on Page 99 of the TrueType Font Spec. These fields accept Unicode number 
ranges. In Fontographer, you would view your font database by Unicode and then identify the first and 
last Unicode characters. Be advised that Unicode numbers may not appear sequentially in your font 
database. 

Using the TrueType Name Table  
The TrueType Name Table is found on Page 77 of the TrueType Font Spec. These fields are used for 
"localizing" the font and work in conjunction with the version of the Windows operating System. (For 
example: Arabic & Hebrew Windows will understand that this font is typed on the screen from right to 
left.) 

The Platform ID table (Page 77) and the Microsoft Platform-specific Encoding ID ( Page 78) are not 
found in Fontographer. Fontographer automatically creates all of these settings so that every font 
generated by Fontographer can be used on any of the specified platforms. 

The Microsoft Language ID - LCID (found on Page 78) is called "Microsoft Language ID" in Fontographer. 
Refer to the TTF spec for settings. Be advised that many Unicode fonts have more than one Code Page 
and/or a "subfont" inside of them. Fontographer's default is $0409 as found in the TTF Spec on Page 78. 
These settings will also be specific to the localized version of Windows you may be using. 

The Apple Encoding ID and the Apple Language ID can be found on Page 80 of the TrueType Font Spec. 
Refer to the tables for the appropriate settings. These settings will (along with the TrueType ID which is 
set under TrueType Options in Fontographer's Advanced Generate Fonts dialog) make the font work 
correctly under WorldScript (the counterpart to the WIN95 Keyboard Switcher) on the Mac. 

Note: Fontographer does not have the capability to write the Description, Designer fields of a TrueType 
font. These fields were not in the TTF spec until a year and a half after Fontographer 4.1 was released. 
Your best bet is to get Microsoft's free Font Properties editor for editing these. 

 

#12334: Symbol substitution issues in Adobe Standard Encoding  

The correct behavior when we open an Adobe font with Original encoding is that it will PRINT Symbol 
substitution characters (see Encoding Options in the Fontographer User Manual). Pagemaker allows this to 
be disabled via the Print dialog check box: "Use Symbol Font" 

However, it makes sense that ALL bitmaps which are displayed on a Macintosh are going to be 
Macintosh encoded. If we have loaded some Adobe bitmaps into an Adobe Standard Encoded font the 
BITMAPS will always be mapped to Macintosh encoding. 

Thus, the bitmaps are ordered according to Macintosh encoding while the outlines are Adobe encoded. 
Confusion results because at this point some of the slots will have a bitmap which doesn't match the 
outline in the same slot. 

Follow these steps to straighten the mess out: 

1  Open an Adobe Postscript Type 1 font with Original encoding.  

2  Change the preview encoding under Element > Font Info to 
Macintosh encoding.  

http://www.microsoft.com/typography/property/fpedit.htm


– 127 – 

3  Import the Adobe bitmaps from the original font. You will 
notice that this will place the bitmaps into the slots which do 
not match the outlines.  

4  Finally, change to "Use Macintosh encoding to choose the 
character" in your Fontographer Preferences under "When the 
user types a key to choose a character:" This preference affects 
the font without requiring it to be reopened.  

The bitmaps will now match the correct slots and will remain matched even during subsequent changes 
to the encoding under Element > Font Info. 

These characters are substituted by Adobe Type Manager (ATM) unless otherwise noted: 

Decimal Character Name  Character  Keystroke  

161  degree - printer driver 
substitution   

Shift-
Option-8  

173  notequal  
 

Option =  

176  infinity  
 

Option-5  

177  plusminus - printer driver 
substitution   

Shift-Option 
=  

178  lessequal   Option ,  

179  greaterequal   Option .  

181  mu - printer driver 
substitution   

Option-m  

182  partialdiff  
 

Option-d  

183  summation  
 

Option-w  

184  product   
Shift-
Option-p  

185  pi   Option-p  

186  integral  
 

Option-b  

189  omega   Option-z  

195  radical  
 

Option-v  

197  approxequal   Option-x  

198  delta   Option-j  

214  divide - printer driver 
substitution   Option-/  

215  lozenge  
 

Shift-
Option-v  

240  apple   
Shift-
Option-k  
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#12335: Troubleshooting the MMPC2MAC utility 

Issue 1 

Where is the MMPC2MAC utility for converting fonts for Macintosh? 

Solution 

The user will NOT be able to see this utility on Windows. The user must have a Macintosh with a CD 
drive in order to drag this utility to the Macintosh hard disk. 

Note: The utility cannot be used while on the CD, desktop, or network. 

If there is no Macintosh available we recommend you rent or borrow one in order to test these fonts. 
Macromedia cannot be responsible for untested fonts created with this utility. 

If all else fails, click here to download the MMPC2MAC utility. This file is in BinHex format (*.hqx 
extender) so that it can be viewed on both Macintosh and Windows. However, it will only RUN on a 
Macintosh after it is taken out of the BinHex format using a decompression utility, such as Stuffit 
Expander. This freeware utility can be downloaded from Aladdin Systems. 

For details on the use of the MMPC2MMAC utility, check the ReadMe located in the Fontographer 
folder. 

Issue 2 

When I drag my font on top of the MMPC2MAC utility, I get the following error message: 
"MMPC2MAC can't process this file. Make sure it is a Macintosh file produced using Fontographer 4.1 
Windows." 

Also, the MMPC2MAC utility will not highlight when a font is dropped on top of it. 

Solution 

Make sure that Macintosh is selected as the computer type when generating a font. The result should be 
a filename with a dollar sign (myfon$.sui). Do not leave the font on a floppy, on the network, or on the 
desktop. The font and MMPC2MAC must both reside on the hard drive. 

Troubleshooting 

If the MMPC2MAC utility has generic icon, rebuild the Desktop by holding down Option-Command 
while restarting. 

The correct icon is shown below. 

http://www.macromedia.com/support/fontographer/ts/documents/mmpc2mac/MMPC2MAC.hqx
http://www.aladdinsys.com/expander/index.html
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Next, use ResEdit (or some other resource editor) to make sure 
MMPC2MAC's Type (APPL) and Creator (FogX) are set correctly. 

 

Make sure that any fonts which are dragged to the hard disk have: 
TYPE = TEXT and CREATOR = dosa. 
If all else fails, copy and paste the characters into a new font and try again. 

As a last resort, try dragging the font directly from a floppy disk onto the MMPC2MAC utility. 

The resulting font will be created on the floppy disk. 

 

#12336: Where to find Fontographer Updaters 

Issue 

Where can I find the latest update to my version of Fontographer? 

Solution 

Go to the Fontographer Downloads area. 

Here's the list: 

Macintosh 

Fontographer 4.1 to 4.1.3 Power Macintosh updater 
Updates Fontographer PM version 4.1 to 4.1.3. 

Fontographer 4.1 to 4.1.3 FPU updater 
Updates Fontographer FPU version 4.1 to 4.1.3. 

Fontographer 4.1 to 4.1.3 NON-FPU updater 
Updates Fontographer Non-FPU version 4.1 to 4.1.3. 

PC 

Windows Fontographer 3.5 to 3.5.1 updater 
Updates Windows Fontographer from 3.5 to 3.5.1. 

http://www.macromedia.com/support/fontographer/downloads.html
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Fontographer Windows 3.5.1 to 3.5.2 updater 
Updates Fontographer Windows version 3.5.1 to 3.5.2. 

Notes 

Mac FPU updaters are only for machines which expect a socketed FPU chip. Power PCs have integrated 
FPUs. Therefore, do NOT use FPU updaters on Power PCs. 

There are NO online updaters for Fontographer 4.1 Windows. There is a Fontographer 4.1.5 Windows 
updater which is available for mailing by request. This updater fixes the Bold Italic and composite 
character widths issues found in tech note 3733 as well as the Macintosh bitmaps issue found in tech 
note 12317. Requests may be made via the email support option by sending an email with a postal 
address and Fontographer serial number. 

  
 

#12338: WIN95 font loads as Custom encoded 

Issue 

When I open a WIN95 font the encoding is often set to Custom instead of WIN95. 

Reason 

Microsoft made some last minute changes to the WIN95 encoding vector. These changes affected the 
way Fontographer reads the font because the changes came after the creation of the Fontographer 4.1 
Windows code. Since the character name list in the opened font is not identical to the list as coded in 
Fontographer, it must be labeled as a Custom encoding vector. The problem is magnified by the fact that 
even Arial and FL Chianti LN do not share a common character name list. 

Solution 

When loading a Windows 95 font you must: 

1. Choose File > Preferences > General Preferences. Select the radio button for Keep the font's 
original encoding. Click OK. 

2. Open the WIN95 font and check the preview encoding under Element > Font Info > General 
and you will see that Fontographer thinks this is a Custom encoded font. Set the preview 
encoding to Windows 95 and keep in mind that you will still need to hard code your encoding 
under the Advanced Generate dialog when generating the font. This is because the preview 
encoding is only there to give you a screen representation of what a particular encoding vector 
would do with your font. The font is actually encoded via the Generate dialog box. 

3. Be advised that some WIN95 fonts will exhibit a strange behavior. You can type Alt-0133 (for 
example) in an application and get the correct character, even though you won't see the correct 
character in the Fontographer font database window. This is because WIN95 has moved the 
character to the bottom of the font. 

Example: 

1. Load a WIN95 font with your preferences set to open with the font's original encoding. 

http://www.macromedia.com/support/email/complimentary
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2. Change the preview encoding from Custom to WIN95. 
3. Notice that the ellipsis (character 133) has moved to decimal 594. 
4. Generate the font with Win95 encoding. 
5. Install the font and select it from the font menu in your application. At this time you'll notice 

that you can use Alt-0133 to display the ellipsis even though it didn't appear there in the 
Fontographer font window. 

  
 

#12339: Windows error messages in Fontographer 4.1 

Issue 

Error message "fontog.exe caused error in FONTG410.DLL" 

The error alert box may appear with the following error message: "This application has performed an 
illegal operation and will be shut down". It may be necessary to view the error log file in order to 
confirm that this error is caused by a DLL conflict. To view the log file, the hard drive can be searched for 
*.log and the log file can be searched for "FONTG410.DLL". 

Reason 

There is a DLL conflict and font registry problems may occur with some Microsoft products and 
Fontographer. 

Solution 

Microsoft Word 

To use Microsoft Word and Fontotographer, do the following: 

1. Run Microsoft Word before running Fontographer. 
2. Type some text in Microsoft Word and then select that text and change it to a different font. This 

allows Word to read the Windows font registry. 
3. Minimize the Microsoft application and then run Fontographer. 

Microsoft Office 

Try one or more of the following: 

• Remove Microsoft Office Startup from the Startup menu. 
• Restart the system after getting the "illegal operation" error. 
• When two versions of Microsoft Office are installed, run both versions and minimize both. 
• Use a third-party error handler. 

Two popular utilities are Ramgate and Norton Crashguard. 
• If none of the above solutions work then reinstall Microsoft Windows because some Windows 

system resources may be corrupt. 
 

http://www.ramgate.com/
http://www.symantec.com/
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#12364: Font displays rectangles instead of characters 

Issue 

Sometimes, when you install or use a font you will see a rectangle instead of the characters which should 
be there. 

Solution 

• If this is happening ONLY with the space character 
 

 
1. Open the Fontographer database or font file. 
2. Open the space character (decimal location 32), place a single point there, then set the 

width appropriately. 
3. Save the database (to someplace other than C:\>Windows\System), then generate a new 

font, uninstall the old one and install the new. 
The loose point will thrown away when Fontographer assembles the font. 

• If this is happening to symbols (logos, icon artwork) or signatures, it is because the character is 
too complex for the Windows Truetype rasterizer. See Creating a Complex Logo Font or Erratic 
Printing or Display of Windows TrueType Fonts. 
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Notice the superfluous points on the character at the right. Use Element > Clean Up Paths to 
simply the amount of points used on a path. 

• If ALL the characters appear as rectangles, it is probably because the character mapping table 
got trashed. This font is corrupted. To fix this follow the procedures outlined in Repairing 
Corrupted Fonts. 
 

 
• Finally, rectangles will also be displayed if there is no such character defined for a particular 

encoding vector. The rectangle serves as the "missing glyph" which means "There is no such 
character defined in this encoding vector." 
 

 
 
For example, if you are using Windows 3.1 encoding and you have a character named 
"whatever" in decimal slot 142 you will get a rectangle when you try to enter that character 
because slot 142 is not defined ("notdef") in the Windows 3.1 encoding vector. 
 
If the desired slot is notdef in that font's encoding then change it to some other encoding (see 
the encoding tables in the manual) using the Preview Encoding underneath the Family Name 
field. Click "OK" and inspect the encoding again. If it is correct you can "burn" the encoding into 
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the font via the File > Generate Fonts > Advanced dialog. 
 
This usually happens when the font was not opened with its original encoding. See Encoding 
vectors FAQ. 

 

#12365: Spikes or spurs are displayed on paths  

Issue What causes spikes, spurs, artifacts, dropout and other distortions to occur on paths? 

Solution  

1  Paths are too complex or points are not at 
extrema. Use Element>Clean Up Paths 
repetitively until paths begin to be changed. Then 
use Edit>Undo to back up to the last step which 
preserves the character shape.  

2  There may be broken paths, paths on top of 
paths, adjacent points, twisted BCP handles.  

3  Hinting (usually happens when the character is 
non-Roman) can cause spikes and this can be 
isolated by turning hints OFF when generating a 
test font.  

4  Sometimes a particular printer driver can cause 
spikes. Search the manufacturer's web site for the 
latest printer driver available. 

Thickening of characters can occur if the path 
direction is incorrect. Select Element>Correct Path 
Direction 

5  Unusual shapes may require adding an additional 
point (or two) to the problem area. For TrueType 
fonts, Dropout Prevention may help. This feature 
is found in the Advanced Generate dialog under 
the "TrueType Option"s button.  

6  If none of the above techniques seem to help, 
there may be a stray point in the em square of the 
problem character. Zoom out and inspect the 
font's outline window carefully or try the 
procedures found in TechNote 3717.  

  

 

#12561: Using SBIT32 with Fontographer  

Issue  
How can I make a reliable screen font on the PC? 
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Reason  
FON files produce erratic behavior which is difficult to control [see Generating Windows FON Bitmaps 
(TechNote 03716)]. 

Solution  
Use Microsoft's SBIT utility (For Windows 3.1, Windows 95 or NT) to embed a custom BDF bitmap file 
into a TrueType font. 

Terms  
BDF (Bitmap Distribution Format) files are hexadecimal representations of a bitmap font. 

PPEM stands for Pixels Per Em unit and represents the lowest size which the bitmap will be displayed at. 
Bitmaps have a one-to-one correspondence to point sizes selected in an application. A PPEM of 12 
would mean that there will be no display of that bitmap below 12 pixels, or below 12 point. 

Steps  

1  Open the font for which you want to create an SBIT embedded 
bitmap.  

2  Under the Element > Recalc Bitmaps menu, create some point 
sizes. Use "Preserve Line Spacing." Due to the resolution 
differences between the Macintosh (72 dpi) and Windows (96 
dpi) platforms, follow the 4/3 rule as found in the manual (p. 
211) for cross-platform bitmaps. These rules will apply 
regardless of which version of Fontographer or which platform 
the bitmaps are created on. You will want to hand-edit the 
resulting bitmaps in order to get the best possible screen 
image.  

3  Rename the font and select File > Generate Font Files.  

4  Under Generate, Advanced dialog, select BDF as the Bitmap 
font to output.  

5  Set the point sizes of your hand-edited bitmaps.  

6  Click on the Generate button.  

7  Use a text editor to edit the BDF file. Here is what the BDF file 
header looks like:  

  STARTFONT 2.1 FONT Ever SIZE 12 75 75 
FONTBOUNDINGBOX 11 12 0 -2 STARTPROPERTIES 1 
Copyright "Generated by Fontographer 4.1" END 
PROPERTIES CHARS 93 STARTCHAR SPACE ENCODING 
32 etc  

8 Change the SIZE parameters from 75 75 to 72 72 9 Remove characters from the BDF for which is no 
bitmap data (except the space character which must be left in the font). 10 Update the CHAR value to 
reflect the number of characters which are left. 11 The file name will probably looked like this: ever____ 
.12. Save this as a text file like this: ever12.bdf. 12 Use a text editor to create a MET file. The SBIT32 
documentation sample file has only one line: PPEM 11 -edit this file to reflect your PPEM size(s). There 
are several other parameters which can be set in MET file, please refer to the SBIT32 documentation. Be 
advised that SBIT32 *.met files are NOT Fontographer *Met files or any variety of Fontographer export 
formats. Save this as a text file like this: ever12.met. The same procedure will need to be done for each 
point size. For example: ever10.bdf 13 At the DOS prompt, embed the BDF and MET files into the TTF 
as follows:   C:\>SBIT32 -a ever.ttf ever12.bdf ever.met newever.ttf   This embeds 

http://www.microsoft.com/typography/tools/tools.htm
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the BDF and MET files resulting in a new font which can be installed. After installation you can test the 
results by loading the new font from the menu of an application. When you select the BDF's point size 
you will get the hand-edited version rather than the rasterized version of the TrueType font.  

An easy way to be sure that you are seeing your hand-edited bitmap is by creating a test font with a 
crude number drawn in the bitmap editor. For example, you could draw a "1" and a "2" in the "A" slot 
so that when you type an "A" in your test font you will be sure that you are getting your hand-edited 
bitmap when you see a "12." 

Troubleshooting  
Problem  
Fontographer 4.1 WIN tells me that I can't use the point size I've typed in the Generate Fonts > Bitmap 
sizes field. Also, I can't seem to successfully create 8, 11 and 14 pt bitmaps. 

Reason  
Users will find that not all point sizes can be recognized by this utility. This is due to a flaw in the way 
Fontographer calculates the 4/3 ratio between the 72dpi Mac screen resolution and the Windows VGA 
96dpi. 

Solution  
Immediate work-around: Make sure you create the bitmaps in Fonotographer (PC) BEFORE you generate 
the .BDF files. 

Third party links  
Although links to external websites are provided as a resource, the websites are not part of Macromedia. 
Please see Macromedia's policy regarding links to third party websites in the Legal Notices and 
Information section. Pages to external websites will open in a new browser window. 

  

 

#12564: Fontographer Mac/Win Serial Number Issues 

PC Fontographer 

• Windows Fontographer 3.5.2 Updater (Updates from 3.5.0 and 3.5.1 available online) 
• Windows Fontographer 3.5.2 Upgrade to 4.1.5 - $99 
• Windows Fontographer 4.1 Updater to 4.1.5 - Free upon request to registered users. Include 

postal address and Fontographer serial number using the Support by Email link. Fixes problems 
with BoldItalic, improper preparation of Mac bitmaps and Type 1 width problems. 

Mac Fontographer 

• Mac Fontographer 3.x 4.0.x to 4.1 Mac version Upgrade - $149 
• Mac Fontographer 4.0.x to 4.1 Mac version Upgrade - $99 
• Mac Fontographer 4.0.x to 4.0.4 Updaters available online or per request. 
• Mac Fontographer 4.1 to 4.1.3 Updater - free download (fixes Open Transport problems). 

  

 

http://www.macromedia.com/help/copyright.html#disclaimer
http://www.macromedia.com/help/copyright.html#disclaimer
http://www.macromedia.com/support/fontographer/
http://www.macromedia.com/support/fontographer/downloads.html
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#12565: The easy way to generate a font with Macintosh 
Fontographer  

Here are some quick steps for generating fonts: 

1  When the font is ready to generate, go to Element > Font Info 
menu. 

 

2  Be sure to give the font a unique name under the Family Name 
field. 

3  Use File > Save As... to create a backup *Fog database of the 
font for future use in creating different versions. This file is NOT a 
font. It is a backup database of raw materials which can be used 
to create a font. 

4  Select File >Generate Font Files >Easy. This is the dialog box 
which actually makes the font. 
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5  Under "Type of font to generate" select PostScript or 
TrueType. For Macintosh PostScript fonts, enter a size of 9 pt. 
under the Bitmap Size to Output. Do NOT select any bitmap 
sizes when creating TrueType or any type of Windows (PC) 
fonts. 

6  Use the "Set Directory" button to make sure your Output 
Folder is not set to the Macintosh System Folder. Set it to a 
work folder. 

7  Click the Generate button. 

8  Install TrueType fonts by dragging them on top of the System 
folder. For PostScript fonts use Adobe Type Manager to install 
fonts.  

  

 

#12569: Why do characters not appear in the preview mode? 

Issue 

Paths are visible in outline mode, but choosing View > Preview causes them to disappear. 

Solution 

First of all, check to make sure the tint value of the path is not 0%. Do this by looking under Element > 
Selection Info, if it is at 0%, set it at the desired amount (this will be 100% for Truetype and PostScript 
Type 1 fonts) and the character should appear in the preview of the outline window. 

If the tint value is already set to 100%, check to make sure that you do not have paths on top of each 
other by double-clicking on the outside path and pressing delete. 
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Finally, make sure that the Fill is set to Normal and the Stroke is off for normal fonts. 

  

 

#12574: Embedding fonts with Macintosh Fontographer  

Issue 
When creating a PDF file, Adobe Acrobat does not recognize the embedding level of a Macintosh font. 

Embedding  
Adobe Acrobat creates a PDF file which allows users to view textual information. The text in the PDF file 
can be viewed in a font that hasn't been downloaded into the viewer's system. Embedding is the 
practice of inserting a certain parameter into a font. This parameter affects how the viewer can interact 
with the PDF document. 

Macintosh Fontographer allows font designers to set one of two levels of embedding in their Macintosh 
font: 

 ROE 
Read Only embedding. The user can only read the PDF file.  

 RWE 
Read / Write embedding. The user can read and edit the PDF 
file.  

When Fontographer was created these two levels of embedding were not recognized by Adobe Acrobat. 
Now that Adobe Acrobat recognizes these two levels of embedding, font designers must insert an 
embedding parameter into their font to avoid the possibility that Fontographer will insert an invalid 
default value. 

Solution  
You can set your embedding parameter in Fontographer, as follows: 

1  Choose Element > Font Info.  

2  Inspect the Notice text box at the bottom of the dialog box. 

3  If copyright notice appears in the Notice text box, position the 
cursor one space after the notice and type ROE or RWE after the 
copyright, as indicated in the illustration below. 

Note: If copyright information does not appear in the Notices 
text box, then type only RWE or ROE. 
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#12597: Latest Versions of Fontographer  

PC Fontographer 

Windows Fontographer 3.5.2 Updater (Updates from 3.5.0 and 3.5.1 available online) 

Windows Fontographer 3.5.2 Upgrade to 4.1.5 - $99 

Windows Fontographer 4.1 Updater to 4.1.5 - Free upon request to registered users. Include postal 
address and Fontographer serial number using the Support by Email link. Fixes problems with BoldItalic, 
improper preparation of Mac bitmaps and Type 1 width problems. 

Mac Fontographer 

Mac Fontographer 3.x 4.0.x to 4.1 Mac version Upgrade - $149 

Mac Fontographer 4.0.x to 4.1 Mac version Upgrade - $99 

Mac Fontographer 4.0.x to 4.0.4 Updaters available online or per request. 

Mac Fontographer 4.1 to 4.1.3 Updater - free download (fixes Open Transport problems) 

 

#12635: Using Illustrator to copy/paste into Fontographer  

Issue  
Illustrator 7 for Macintosh will not copy/paste paths into Fontographer. 

http://www.macromedia.com/support/fontographer/
http://www.macromedia.com/support/fontographer/downloads.html


– 141 – 

Macromedia is aware of this issue. You can confirm that there is a clipboard problem by placing 
something on the clipboard in Illustrator 7 and then going to the Finder and selecting View Clipboard. 
There will be nothing found. This does NOT occur in Illustrator 8. The following procedure is a 
workaround which will allow you to copy the Illustrator 7 clipboard format directly into Fontographer. 
We strongly suggest that you save a backup copy of your Illustrator file before attempting this. 

Solution  

1  Open a copy of the file in Illustrator 7 Macintosh.  

2  Choose Edit>Select All. 

3  Choose Window>Show Swatches. 

4  In the swatches palette, shift-select ALL colors and patterns. 
Drag these colors to the trash can icon in the lower right corner 
of the swatches palette or select Delete. These changes will 
apply only to the current Illustrator document.  

5  You should use the Illustrator toolbox to set your fill to none.  

6  You may now hold down the Option key while selecting 
Edit>Copy from the Illustrator Edit menu.  

7  Toggle your screen to Fontographer and select a target character 
slot.  

8  Hold down the Option key while selecting Edit>Paste.  

Additional Information 
Option-Paste will scale the character in the em square. If your object had a fill in Illustrator it will not 
paste into Fontographer at all unless you use Option-Paste. 

A regular Paste will cause your object to fill the entire em square. 

Fontographer cannot import Illustrator strokes or fills. For this reason, it may be necessary to use the 
Element>Selection Info dialog box to make sure your Fill is set to a 100% tint. 

This procedure will NOT work for Illustrator 7 on the PC. The work-around for the PC is to save the file as 
an Illustrator 1.1 file and then Import the resulting EPS into Fontographer. See Tech Note 3721 for 
details. 

 

#12637: Hottest Fontographer frequently asked questions  

Issue 1  
"I upgraded from the Fontographer 4.1 Macintosh floppy disk version (serial number is of the 111xxxx 
variety) to Fontographer 4.1.4 Macintosh on CD and I was not given a new serial number." 

Solution It appears that in the past we've assumed that all Macintosh 4.1.x users were using the serial 
number - Key Number combination and that upgrade customers could just use their existing numbers. 

Not true for the Macintosh Fontographer 4.1.4 CD. Fontographer 4.1.4 requires that users have a serial 
number with the 60041 prefix. 
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Thus, when ordering an upgrade from Macintosh Fontographer 4.1 to 4.1.4 be sure to request a new 
serial number which has a 60041 prefix. 

Issue 2  
"I have this 60041... (Macintosh) or 65241... (Windows) serial number but the screen says that I need to 
enter my KEY number during the install." 

Solution See Fontographer Mac/Win Serial Number Issues. 

This note explains that the inclusion of KEY NUMBER on the screen was a typo. 

Issue 3  
"Can Fontographer create 2-byte fonts?" 

Solution See Two-byte fonts. 

Issue 4  
"Can Fontographer create Soft Fonts or PCL fonts?" 

Solution Fontographer was not designed to create these font formats. For assistance with these formats, 
contact: Elfring Soft Fonts -these folks can create soft fonts ( as well as custom FONs ). 

 

#12651: PC Truetype Leading Issues  

Issue  
Characters have too much or too little white space between sentences. 

Reason  
This may happen because the distance from the cap height to the ascender is either too close or too far. 

The Windows operating system has a feature called "TTF Collision" which is designed to prevent fonts 
from colliding when there is negative leading. Experiments with the ascender will sometimes cause the 
system to override the metrics in your font and will push or insert leading. 

Solution  
To increase the leading use the Element > Font Info > General dialog and change the Ascent. 

To decrease the leading, you can override the Windows operating system by selecting Element > Font 
Info > OS/2 Metrics and inserting a value into the usWINascent field. 

http://www.elfring.com/
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Additional Information  
If your characters get squished or appear to have a leading or scaling problem on a PCL printer, set your 
PCL printer driver settings to graphics or raster. 

  

 

#12652: Controlling Custom Leading of Macintosh Fonts  

Issue  
"How can I control the leading of my Mac Truetype font?" 

Solution  
Leading is set via Element>Font Info and by changing the Ascent. The "Leading" field itself is a 
placeholder for compliance with the Adobe Type 1 specification (only some applications see this 
parameter) and is not used in this procedure. 

You can have further control of Truetype leading by creating a screen font intended to be associated with 
a TrueType on a Mac.  

1  Choose Element>Recalc Bitmaps and then choose a point size 
and a default of "Preserve Line Spacing."  

2  The metrics for the screen and the printer will now come from 
the FOND resource of the screen font rather than the SFNT of 
the Truetype. 

Issue  
"How can I control the leading of my Mac PostScript font?" 

Solution  
Normally, the leading for a PostScript font is controlled as above for Truetype fonts. Problems occur 
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when the leading of your outline font does not match your bitmap. Sometimes this manifests itself as a 
"deep cursor" -i.e., a cursor which is much taller than the characters in the font. 

Follow the procedures below if this happens: 

The most important thing to remember is that the final PostScript is not there for you to edit but for your 
printer and ATM to use. The System knows about the font only through the information supplied from 
the bitmap suitcase. Only at print time does the printer driver look for a PostScript font to send to the 
printer. Many Fontographer users are not aware that there is a bitmap editor hiding under the Windows 
menu which can be used to deal with metrics problems. Normally, we do not recommend hand-editing 
bitmaps but these tips are offered as a way of dealing with leading problems which may occur in your 
screen fonts. 

Keep in mind that the bitmap is a completely different font from the PostScript font. Therefore its metrics 
may not necessarily match unless you purposely cause them to match. The way you make them match is 
via the Element>Font>Recalc Bitmaps menu. 

Thus, you can change your ascender under Element>Font info and then use Recalc Bitmaps in order to 
cause the leading of your outline font to match your bitmap. Sometimes you will see an extra ascender 
guideline in the bitmap editor. This is a clue that your outline font and bitmap font have different 
ascenders. 

They can be caused to match by using the "Preserve line spacing" feature in the Recalc Bitmaps dialog. In 
order for this feature to work correctly you must have your Element>Font Info checkboxes set to 
"Automatically Compute Em Square". Generate your font and install it for testing. 

A Philosophy of Leading for Macintosh Fonts  
In ye olden days leading (pronounced with an emphasis on the metal) was the practice of inserting lead 
slugs between lines of text in order to produce a pleasing amount of white space. The problem with 
doing this on a computer is that there can be a difference between the leading of a screen font and a 
printer font unless certain obstacles are overcome. Improper leading or character spacing often manifests 
itself with the use of accented characters which straddle the ascender or appear above it. 

Leading for accented characters  
You CAN place the accents (or any other shapes) above the ascender line. Most commercial font accents 
straddle the ascender. You can even have characters whose cap height is above the ascender but the key 
is that you do this at your own peril!!! 

If you place an accent above the ascender you run the risk of colliding with sentences above the 
accented character. If you want extremely tight leading that is your prerogative. This is not meant to 
imply that there is something wrong with doing this. Just make sure you know what you are doing! It 
may be wiser for a beginner to scale down the characters and fit accents within the em square. 

Which method should I use? 

Preserve Line Spacing 

Use this feature (under Element>Recalc Bitmaps) when you do NOT want tight leading. 

This feature can cause characters below the accent to become squished. The over-riding purpose of this 
feature is to preserve the designated amount of white 
space between lines of text. It does its job at the expense of some of the character shapes. Use this 
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feature when you care more about the font's appearance on 
the printer than what it does on the screen. 

Preserve Character Shapes 

Use this feature when you don't care if characters touch the line above them or when using tight leading. 
BUT be advised that this feature allows your accents to 
dictate how much white space will be inserted based on the highest point found above the ascender. 

Use this feature when you care more about the font's appearance on screen than what it does on the 
printer. 

Here is an example of Habitat* specifically designed with tight leading for the umlaut character: 

 

The next screen capture shows how the first character is squished when the bitmaps are recalculated with 
Preserve Line Spacing. The second character was recalculated with Preserve Character Shapes. 

 

The bottom line depends on whether you care if your bitmaps are squished on the screen in order to 
preserve the leading when proof-reading or making a screen presentation. Both versions of the above 
font will PRINT without squishing because the PostScript printer font is a different file from the screen 
font. Squishing will only be seen at Fontographer-generated bitmap sizes. Sizes which are rasterized by 
ATM will not display squishing unless your ATM controls are set to Preserve Line Spacing. 

*Habitat (Copyright Joe Treacy) is part of the Treacyfaces Type Catalog. Used by Permission. 
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#12719: Special characters and kerning/metrics equivalence dialogs  

Issue  
Entering special characters into the Assistance and Metrics Equivalence dialogs. 

Solution  
The following list contains the allowable characters: 

The dash character ( - ) is used as a range separator, as in A-Z 

The comma ( , ) and/or space characters are used to separate characters or ranges of characters. Like this: 
AZ, 0-9 or a,b,c,d,e. 

The single quote character ( ' ) is used as a delimiter to separate characters which are either not part of 
the Macintosh encoding vector or for the following special characters: 

Single quote ( ' ) Comma ( , ) Hyphen ( - ) Space 

To use these as characters put a single quote in front of them, for example ', '- 

More examples: 
Example 1  
The first special character example shows a single quote delimited by single quotes before and after it. 

''', 

Example 2  
The second example shows a comma delimited by single quotes before and after it. 

',', 

Example 3  
The third example show a space delimited by single quotes before and after it. 

' ' 

Note that these characters can be separated by commas or spaces like this: 

''', ',',' ' 

Additional Information  
When non-Macintosh encoded characters need to be typed into these dialogs the user must change the 
File > Preferences > General Preferences so that the top radio button is on. 

When the user types a key to choose a character: 

Use the font's encoding to choose the character 

Use Mac encoding to choose the character 
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#12768: Tips on Autotracing in Fontographer  

Issue: 

I want to take my handwriting and make it into a font. I see that Fontographer can autotrace background 
images, but the process can be confusing. Please explain. 

How To Do This: 

1. Scanning Your Image: 

Bigger is almost always better. On a 300 dpi scan, start with a drawing at least 2 inches high. Three 
inches is even better. When you get a character 8" tall and scanned at 1200 dpi, you get too much data 
for a clean autotrace. The optimum is about 4 inches at 400 dpi. The better the resolution of the 
original, the better the subsequent autotrace. Also be very careful to register the page on the scanner so 
that the original is not skewed. Colors will be ignored, so it is best to set the scanning depth to Black and 
White, or 1-bit. When you are ready to scan, save the image as a PICT file. 

2. Getting the PICT into Fontographer: 

Using a recently released paint program, open the PICT file. We recommend Zedcor's DeskPaint desk 
accessory. Don't use a program which will decrease your resolution, such as MacPaint. SuperPaint 3.0, 
Canvas 2.0, PhotoShop, and Digital Darkroom will also work. The next step is to copy the character and 
paste it into the character outline window in Fontographer. But first lets consider the scaling of the 
characters. Are the characters you have scanned proportionally correct? In other words, did you begin 
with drawings which had the capitals larger than the lowercase characters, with even smaller commas? If 
so, then you donÕt want to lose that proportion when pasting the font into Fontographer. When pasting 
a bitmap image, Fontographer will scale the bitmap to fill the em square of the font. Optionally, when 
pasting the image with the Option key depressed, Fontographer will not scale the character at all. If the 
original size of your char was about 3 inches, then use the Option-Paste. Otherwise, youO ̃re better off 
making a box around the bitmap which will represent the em square and copy the box with the image. 
To begin, make a box which is a little taller than the "J" and a little wider than the "M" and at least as 
far down as your lowest descender (like the j or the p). Drag the box over the M so that there is very 
little white space at the top of the M. Then make a small mark at the bottom of the M. This will 
represent the baseline. Make sure the box never touches the character image. Now use that box with 
every character so that the characters will all scale proportionally. The box will also get traced, but it can 
be easily removed with two mouse clicks. Now, drag each char image into the box, copy and paste the 
box and image into an open Outline Window in Fontographer, select Auto Trace from the Element 
menu, and you've got a good PostScript drawing of your scanned image. 

3. The Clean Up: 

It is likely that some additional path tweaking will be necessary before everything is perfect. When 
Autotracing logos scanned at only 300 dpi, some of the smaller parts will need some adjustment. Use the 
background image to judge how close the trace is to the original scan. When you have each character 
just so, you are nearly finished with the font. 

If you were not able to create the box around the character before you imported the bitmap, then you 
might need to scale and move the image now. Do this using the "Scale" and "Move" items in the 
Transform dialog for just one character in the font. Remember, the undo Command is Cmd-Z; use it 
liberally while you are finding the correct Scale/Move settings. When you have it the way you like it, 
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note the exact scale and value and apply that scale to every character by selecting all in the font window. 
Now, after tweaking the handles and test printing, you should be ready to go with your new font. 

 

#12769: Troubleshooting the Petrucci font  

Issue  
Petrucci's font metrics (ascent/descent) are not functioning properly. In order to function properly in the 
Finale music editing application, Tim Herzog had to design Petrucci with a strange em square. 

Solution  

Before you begin, make sure your Preferences are set to "Keep font's original encoding" as described in 
Encoding vectors FAQ.  

1  Open "Petru" in Fontographer.  

2  Use File > Import > Metrics to import Kerning (5 pairs) from 
the bitmap suitcase file and save the font with a new name. 

3  Use File > Import > Metrics to import Ascent/Descent. 

4  Use File > Import > Metrics to import Bitmaps.  

Now, check your work. Open the outline window for the Cap "B" (decimal 66) character. 

Does the lowest point sit on the descent? 

Does the highest point sit on the ascent? 

Does the leftmost middle corner point of the glyph sit on the baseline? 

If you can answer, "Yes" to all three questions, then your revision of Petrucci is ready for editing. If not, 
then go to the Element > Font Info dialog and change the Ascent to "503" and the Descent to "507". It 
is not important for these values to add up to a 1000 unit em square. The outline font which is 
generated will be normalized to a 1000 unit em square. 

After changing these values you should recheck your font as above. If you find any measurements off by 
more than 3 em units you should try entering different values for the Ascent and Descent until it gets 
close enough. 

 

#12908: Preparing fonts for Unix Systems  

Since there are many flavors of Unix, the first step is to identify which file format your project requires: 

PostScript Type 1 Font  
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Sun computers (running Solaris or the X-Windows OS) call for this font format and also require an *.AFM 
file. AFM files can be generated from the File>Generate Fonts>Advanced dialog. These systems often 
use a BDF bitmap file for a screen font. 

Silicon Graphics (SGI) machines usually take a PostScript Type 1 font and run it through a converter 
called "Convert Mac Font". 

The NeXT computer uses PostScript Type 1 fonts and AFM files which have been generated from Mac 
Fontographer 4.1.x with the target computer selected as "NeXT". You will need to delete the *.nxt 
extension before installing. 

OS/2 2.0 uses PFB and AFM files. These can generated using File>Generate Fonts>Advanced and 
selecting Computer>PC and PostScript Type 1. We cannot guarantee fonts to work with OS/2 versions 
above 2.0. 

PFA Font Files  

This format can be generated via File>Generate Fonts>Advanced with the Computer selected as PC and 
the Outline Format selected as PostScript Type 3. 

Note: most Unix fonts are encoded with ISO Latin encoding. 

 

#12909: Solving Stylemerger font family problems  

What is Stylemerger?  

Stylemerger is a Mac-only utility which is used to place the four standard members of a font family into 
a *.FAM suitcase file. This procedure allows these fonts to work with LINKING. Linking is the ability of an 
application to use the task bar, menu items or hot-keys to select a particular Style in a font. 

The members of a simple family are listed below: 

George-Plain 

George-Bold 

George-BoldItalic 

George-Italic 

This family does not have a fly-out menu but DOES have linking. The family could have a fly-out menu if 
used with Adobe Type Reunion. If ATR is installed and things still don't look right trash the ATR 
preferences and restart. 

The members of a complex family are listed below: 

GeorgeLtCond (Notice that this is a stand-alone family with unique name) 

GeorgeLtCond-Bold 
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GeorgeLtCond-BoldItalic 

GeorgeLtCond-Italic 

Additional Information  

 Mac OS8.x users - Stylemerger was written in 1993 and is 
showing its age. Stylemerger does NOT work reliably under any 
OS8.xor OS 9.x configuration. OS8.x users will find that some 
family members are missing from the FAM suitcase. 
Stylemerger works more reliably on 040 (Quadra, Centris) 
machines with OS7.x.x and extensions off. Try downloading 
and using the old version of Stylemerger. This file will be a 
StuffIt archive which can be extracted using the StuffIt utility.  

 Do not attempt to use Stylemerger on fonts which have already 
been installed. 

 Make sure the Style name is preceded by a hyphen. 

 Do not make a large number of sizes: 10, 12, 24, 36, 48, etc. 
and expect the font to work correctly because Stylemerger has 
a limit of 64K allowed in each bitmap's FOND resource. 

 Increase Stylemerger's RAM allocation via Get Info in the 
Finder. It needs at least 4000k 

 If other stand-alone fonts are dragged into a FAM file... keep in 
mind that they will not LINK when styles are selected in an 
application. 

 Do not try to use the ResEdit / ATR procedures on a font 
intended for cross platform documents. 

 Stylemerger does NOT create families for the PC. 

 Some users have reported font families which substitute 
Courier in Pagemaker 6.5. Pagemaker 6.5 doesn't recognize 
hyphens in font Style names. Example: (George-Bold) First, 
make sure to select a Style name from the pop-up menu, then 
try deleting the hyphens. 

 Be advised that Adobe products expect to see family members 
listed as if Adobe Type Reunion were installed. Family 
members may not appear in the order expected. 

 When using a font in a cross-platform document, be sure to 
select the Plain weight of the font from the font menu and then 
apply a bold or italic style to it. Do not select a bold or italic 
style from the font menu. 

  

 

http://download.macromedia.com/pub/fontographer/smerger.sea.hqx
http://www.aladdinsys.com/downloads/software.html
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#12910: Creating Outline or Keycaps fonts  

Introduction 
Fontographer uses display PostScript to show the outlines on the screen. Type 1 and TrueType fonts use 
the PostScript interpreter's winding fill algorithm to display and print fonts. A winding fill is 
accomplished by coming across the screen, finding the outermost path and filling everything from there 
until the next path is found. The outermost path must be clockwise in order for the fill to work correctly. 
The fill will stop when it finds a counter-clockwise path. Therefore the paths must alternate: clockwise / 
counter-clockwise / clockwise, and so forth. (See the User's Manual for details.) You can make sure of a 
path's direction by clicking on that path and then observing the arrow at the bottom left of the outline 
window. Clockwise arrows point right and counter-clockwise arrows point left.  

Outline font  
To create an Outline font do the following: 

1  Deselect all points by clicking in the white area to 
the side of your character. 

2  Turn off Preview and double-click the outermost 
path. 

3  Choose Element > Expand Stroke. Expand it by at 
least 5 em units for this tutorial so that you can see 
the stroke easily.  

4  You will now see a new path around the edges of 
your previous path. Double-click this new path and 
expand its stroke by 5 ems.  

5  You should now see a fill in between the strokes 
you've expanded and no fill inside your character.  

  

 
  Note: The path direction arrow at the bottom left shows that the outermost path is clockwise. 6 Choose 
Element > Correct Path Direction to make sure that the path direction is correct. You can change a path's 
direction manually by double-clicking the path and then setting it via the Element menu for clockwise or 
counter-clockwise. Or you can choose Edit > Select All and then choose Element > Correct Path 
Direction. 7 Later you can expand by 1 em unit in order to hide the fact that there is a expanded stroke. 
You will need to use the magnifying glass to zoom in close enough to be able to see the path and work 
on it.  
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Keycaps font  
To create a Keycap character which has a black border but no fill do the following: 

1  Place a box around the character. 

2  Choose Edit > Select All to highlight all points. 

3  Choose Element > Expand Stroke to create 
expanded strokes around all of the paths.  

  

 
    4 Make sure to correct the path direction by choosing Element > Correct Path Direction.  

 

#12911: Creating PostScript Type 1 fonts for DOS  

Adobe's installation program for DOS apps will install your custom fonts if you make it think they're just 
like Adobe�™s font packages. This document will assist you in that. To obtain Adobe�™s Installer and the 
Font Foundry utilities, purchase an Adobe Windows font. 

There are four files you need to make Installation go along with you. Three of these will be generated by 
Fontographer (Macintosh or Windows) and are ready to use with little or no manipulation. The final file, 
INSTALL.CFG must be modified by you. 

First, lets compare a Fontographer generated INF file to an original Adobe file. They are quite similar 
and in most cases will suffice for the installation. 

The GDBI____.INF file looks like this: 

FontName (AGaramond-BoldItalic) 

Note: When saving a font for use in the DOS environment, it is best to use a hyphen to distinguish the 
family name from the style. If you don�™t save the name with a hyphen, then Fontographer will not 
include the hyphen and some applications will be confused. 

FullName (Adobe Garamond Bold Italic) 

AppleName (AGaramond BoldItalic) 
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AppleFONDID 14570 

FamilyName (AdobeGaramond) 

version (001.000) 

isFixedPitch false 

CharacterSet (isoadobe) 

Encoding (StandardEncoding) 

ItalicAngle -18.5 

CapHeight 660 

UnderlinePosition -100 

UnderlineThickness 50 

StemWidth 130 

Serif true 

Pi false 

SuperiorBaseline 247 

PCFileNamePrefix (GDBI_) 

VPMenuName (AGaramond Bold) 

Note: Space required if separate words; no hyphenation. 

VPTypefaceID 10 

VPStyle (I) Note: N = Normal, I = Italic; B = Bold; T = BoldItalic 

MSMenuName (AGaramond Bold) 

WORDMenuName (AGaramondBold) 

PCLTypefaceID 20918 Note: Five digits in the range of 0-64k. Don�™t use first 512. They are Adobe�™s. 

PCLStrokeWeight 3 Note: -7 to 7 or fifteen possibilities 

PCLStyle 1 Note: 0-256 

The GrL_____.INF file looks like this: 

FontName (GraphicLight) 
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FullName (GraphicLight) 

AppleName (GraphicLight) 

AppleFONDID 2125 

FamilyName (GraphicLight) 

version (001.000) 

isFixedPitch false 

CharacterSet (isoAdobe) 

Encoding (AppleStandard) 

ItalicAngle 0 

CapHeight 599 

UnderlinePosition -133 

UnderlineThickness 20 

StemWidth 100 

Serif true 

Pi false 

PCFileNamePrefix (GrL_____) 

VPMenuName (GraphicLight) Note: Space required if separate words; no hyphenation. 

VPTypefaceID 29001 Note: Five digits in the range of 0-64k.Don�™t use first 512. They are Adobe�™s. 

VPStyle (N) Note: N = Normal, I = Italic; B = Bold; T = BoldItalic 

MSMenuName (GraphicLight) 

WORDMenuName (GraphicLight) 

PCLTypefaceID 290023 

PCLStrokeWeight 0 Note: -7 to 7 or fifteen possibilities 

PCLStyle 0 Note: 0-256 

You can see that there is not much difference in the two files. The order is somewhat different, but 
should not be a problem. Note that the Encoding (AppleStandard) line differs; it would be best to 
generate all your fonts intended for DOS as Adobe Standard encoded fonts, then this field would match 
up. 
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Now load the INSTALL.CFG file from the AGaramond font package. It looks like this: [The lines preceded 
with a �œ#��  are comments and not read by the Installer program] 

# Installer Configuration File 

# Contains package specific information used by the install program. 

DISKSIZE 713 

FILE INSTALL.CFG 1 

FILE README 1 

# Font entry fields: 

# Fontname - PostScript name of the typeface 

# Filename - 5 character PC filename base 

# Number of the disk this filetype sits on or zero if not present. 

# One entry for each filetype PFB, INF, CTF, ???, ABF, AFM 

FONT AGaramond-Regular GDRG_ 1 1 0 0 0 1 

FONT AGaramond-Italic GDI__ 1 1 0 0 0 1 

FONT AGaramond-Semibold GDSB_ 1 1 0 0 0 1 

FONT AGaramond-SemiboldItalic GDSBI 1 1 0 0 0 1 

FONT AGaramond-Bold GDB__ 1 1 0 0 0 1 

FONT AGaramond-BoldItalic GDBI_ 1 1 0 0 0 1 

DISKNAME 1 'Font Disk' 

PKGNAME agrmnd 

Note that this .CFG file is designed to be used from a floppy with multiple fonts to be installed. The Disk 
size is for a 720k floppy. The 1 by File ReadMe indicates that a readme file is on the disk and should be 
copied. The 1 1 0 0 0 1 indicates that a PFB, INF, & AFM for each of the fonts listed is on the disk. 

Below is the default CFG file generated by Fontographer. You will need to change this file to indicate the 
disk size, disk name, and a listing of all the fonts on the disk to be installed. 

# Installer Configuration File 

# Contains package specific information used by the install program. 

DISKSIZE 0 
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FILE INSTALL.CFG 1 

FILE README 0 

# Font entry fields: 

# Fontname - PostScript name of the typeface 

# Filename - 5 character PC filename base 

# Number of the disk this filetype sits on or zero if not present 

# One entry for each filetype PFB, INF, CTF, PFM, ABF, AFM 

FONT GraphicLight GrL_____ 1 1 0 0 0 1 

DISKNAME 1 'Font Disk' 

PKGNAME GraphicLight 

Once you�™ve modified the .CFG file, copy the .PFB, .INF, and .AFM files, as well as the new .CFG file to 
its own disk. 

Now, run the Installation program. (For WordPerfect install, make a back-up of the WPPS1.ALL file first 
though, just as a precaution) When it says "Insert Font Disk" put that new disk in the drive. It will ask 
what fonts it should install, and if everything goes well it will copy the PFB to your PSFONTS directory, 
create a crude bitmap font for the screen image, and update the Font menu for the target app. In theory, 
this disk is ready for installation into any DOS app supported by the Adobe Installer. 

Additional Information  
Adobe's Install program works best when the font files have underscores in them.Every Adobe font file 
name is broken down into no more than five letters with at least three spaces following. If the font you 
want to install has no underscores, it would be in your best interest to rename the associated files and 
make the appropriate changes in the .INF file and INSTALL.CFG file. 

Do not allow special symbols or extended characters in the comment lines of the .AFM file. Many fonts 
include characters like the copyright symbol in the comment line and it translates as a right angle of 
sorts, and the Installer hates it. If you get the message, ERROR PARSING FONT_____________.AFM, 
that�™s the reason why. 

  

 

#12912: Quadra 840AV conflicts and Fontographer  

Here is a partial list of things that can cause a Quadra 840AV to have problems: 

Superclock 3.9.1  

NOW utilities 4.0.1  
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ATM before 3.6  

AfterDark before 
2.0.x  

DiscDoubler 3.7.7 or 
older  

AutoDoubler 2.0  

PrintShop  

Pagemaker 4.02  

DiscLock In Touch  

It is not possible to drag or move referenced characters while running Fontographer on the 840AV. 
Use Edit > Unlink Reference to remove these objects. 

It is necessary to delete the Fontographer Sounds file in order to run Fontographer on the 840AV 

If running under System 7.0.1 it is necessary to install the latest version of the Hardware System 
Updater. 

Some problems may be caused by System 7.1 this version has known problems which Apple fixed via 
the Hardware System Updater 2.x or later. 

Other alternatives are zapping your PRAM (restart while holding down Command-Option-P-R), unplug 
all SCSI devices. After zapping the PRAM you should rebuild your desktop by restarting while holding 
down Command-Option) or upgrade to a more recent Macintosh OS. 

 

#12914: Installing Windows fonts in OS/2 2.0  

How to install the fonts: 

1  From the OS/2 System window, double click on �œSystem 
Setup.��   

2  From the System Setup window, double click on �œFont 
Palette.��  

3  Click on �œEdit Font.��  

4  Click on �œAdd.��   

5  Insert the disk with the font file you wish to add into drive A, or 
choose an alternative drive/directory.  

6  Click on �œAdd.��   

7  Select the AFM file for the font you wish to install. (Note: OS/2 
2.0 only works with the Type 1 Windows font format.)  

8  Click on �œAdd.��   
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9  Close the "Edit Font" window. Your font is now installed.  

How to Add Your Font to the Font Palette: 

1  From the OS/2 System window, double click on �œSystem 
Setup.��   

2  From the System Setup window, double click on �œFont 
Palette.��  

3  From the �œFont Palette�� , select the font you want to replace. 

4  Click on �œEdit Font.��   

5  Click on the scroll button for �œName.��   

6  Select the font you installed.  

7  Make any changes to the style, size, and emphasis.  

8  Close the �œEdit Font��  window. Your font is now in the 
�œFont Palette.��   

How to Remove Your Font from OS/2 2.0  

1  From the OS/2 System window, double click on �œSystem 
Setup.��   

2  From the System Setup window, double click on �œFont 
Palette.��  

3  Click on �œEdit font.��  

4  Click on �œDelete.��   

5  Select the AFM for the font you wish to delete.  

6  Click on �œDelete.��   

7  Select �œYes��  to delete font.  

8  Select �œYes��  to delete the font from the DLL directory.  

9  Close �œEdit Font.��  Your font is now deleted. 

 

#12915: Generating and Installing UNIX NeXT PostScript&reg; Type 
1 Fonts  

Note: The following procedures apply ONLY to Macintosh Fontographer. Fontographer for Windows 
does NOT generate Unix fonts. 

In the "Generate fonts" window, there is an option in the PostScript section named "Unix format." 
Choosing this option generates an Adobe Type 1 PostScript font for use with computers running UNIX 
such as NeXT and Sun. 

Two files are generated: The .NXT file is the PostScript data, the .AFM file is the metrics data. No bitmap 
format file is required for the Display PostScript environment of the NeXTSTEP operating system. For a 
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font named "Myfont," the PostScript file will be called "Myfont.NXT." This file must have the ".NXT" 
ending removed before you install it. The Adobe Font Metrics file will be called "Myfont.afm." The 
extension must be lowercase before installing it on the NeXT. To use these files, copy them to the NeXT 
on a high density floppy and follow the steps in this TechNote. 

System Requirements: A NeXT computer using NeXTSTEP 2.0 (or later) system software. 

Installing fonts into your Home Font Library  
To understand the terminology and all the ways in which fonts can be installed on a NeXT, refer to the 
NeXT Users Manual. The shortcuts and methods explained here will be useful, although not quite 
identical, to installing the font into the /LocalLibrary /Fonts Directory. 

Step A: Setting up the Folders 

1  In the File Viewer, go to your Home Directory.  

2  Create a new folder and name it "Library."  

3  In the Library folder, create a new folder and name it "Fonts."  

4  In the Fonts folder, create a new folder.  

5  Copy the PostScript file and .afm file for a single font into the 
newly created folder. For the "Myfont" font example, you 
would copy the file named "Myfont" and the file named 
"Myfont.afm" into the new folder.  

6  Rename the folder which now contains the two font files 
"Myfont.font." Press the "Return" key.  

In review, the pathname for this would be "~/Library/Fonts/Myfont.font". This font is still not usable at 
this time. In the next section, we will explain the two methods for completing the installation of the new 
font. 

Step B: Getting the NeXT to recognize your new font. 

There are two ways you can get your NeXT to recognize your font. The first method is the easiest and 
should be attempted first. If you are unsuccessful with that method, the second method is a little more 
involved, but may provide you with additional information on why your font is not working. 

Method One: 

1  If you have any font files open in "Edit", close them.  

2  Start up "WriteNow" (or any application which supports fonts). 
A message will appear saying, "Incorporating information 
about new fonts. Please wait."  

The font should now be properly installed and usable in any application which supports the use of fonts. 
However, if you have an unusable font, go through the steps again and be sure to check your syntax. If 
your font is still unusable in "WriteNow", use the second method to provide you with some information 
on what is going wrong. 

Method Two: 
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1  Start up the "Terminal" application.  

2  Type the following on the command line: /usr/bin/buildafmdir 
~/Library/Fonts  

This tells the NeXT to look in the "Library/Fonts" within your home directory and install any new fonts it 
finds there. If "buildafmdir" doesn't have any problems installing your font, it will not print any 
messages, and your font will be installed when the command prompt returns to the screen. If there were 
problems, "buildafmdir" will display error messages while it is running. These messages will give you an 
idea of why the font is not installing correctly. 

  

 

#12916: Using FPEDIT with Fontographer  

FPEDIT is part of the publically available set of Microsoft's OpenType utilities. 

It allows you to change the following parameters in your Truetype font's properties: 

1  FPEDIT allows designers to add a link to their 
Website or email address.  

2  FPEdit allows users to make embedding 
permissions more restrictive. 

3  The Localize feature allows the font to work with 
an international keyboard driver. 

4  Other parameters include a personalize signature 
for Designer, Foundry, Font Description, License 
and Vendor ID.  

These parameters should be added after you have generated your font in Fontographer. Current versions 
of Fontographer will only retain the embed and Vendor ID fields in a font. All the rest of the fields 
described above will be stripped out when the font is brought into Fontographer. This is because 
Fontographer was written before the OpenType specification was released. 

The public version of FPEdit is accessible from: 

http://www.microsoft.com/typography/creators.htm 

Additional information  
WEFT is another tool used to embed fonts within Web pages - the ALLOWED URL ROOTS feature in 
WEFT is a security measure to stop Web pages designers from linking to font objects on your site. 

 

http://www.microsoft.com/typography/creators.htm
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#12918: Font format tutorial  

Font files come in a variety of formats; distinguishing among them (and how they appear on different 
platforms) can be a daunting task. Use the chart below to quickly determine the meaning, extensions 
and icons associated with the many font file formats currently in use. 

Windows fonts 

Format  File 
Extender  

Description  Icon  

TrueType  .TTF Printer Outline font 

The bitmap screen sizes are 
rasterized by the system's 
TrueType rasterizer. 

 

 

OpenType  .OTF  Printer Outline font 

The bitmap screen sizes are 
rasterized by the system's 
TrueType rasterizer. 

 

 

PostScript 
Type 1  

.PFB 

Installed 
with 
.PFM file 

Printer Font Binary (this is 
the outline font) 

The bitmap screen sizes are 
rasterized by the PostScript 
rasterizer. 

 

Screen 
font  

.FON  System screen font 

This font file format is used 
when a custom screen 
bitmap is desired for a 
particular point size. 
Attempting to customize 
screen bitmaps can be 
unreliable. 

 

 

PostScript 
Type 3 

.PFA  Mostly used on the UNIX 
platform, this font file 
format is not recognized by 
Adobe Type Manager 
(ATM).  

 

Multiple 
Master  

.PFB 

.MMM 

The numbers seen in some 
Multiple Master file names 
are used to identify a 
particular "instance" of the 
font's weight. 

An example font name for 
a Multiple Master: 

 

 



– 162 – 

TektoMM_100_LT_564_NO 

Macintosh fonts 

Format  File 
Extender  

Description  Icon  

TrueType  none or .suit 

The suitcase 
icon will only 
have the .suit 
extender 
when created 
by 
Fontographer. 
Otherwise, it 
will probably 
not have any 
file extender. 

Printer 
Outline font 

The triple-A 
font icon 
should be 
located 
inside of the 
suitcase icon. 
If the triple-A 
icon is 
dragged 
from the 
suitcase onto 
the Desktop 
it will appear 
as the triple-
A icon. 

Note: 
Sometimes a 
TrueType 
outline font 
will also 
have screen 
fonts (see 
below) 
associated 
with it. The 
system will 
use the 
screen font 
to display a 
particular 
point size 
rather than 
the system 
rasterizer. 

 

 

 

OpenType  .otf  Printer 
Outline font  

 

PostScript 
Type 1 

none Printer 
Outline font 
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The icons for 
commercial 
printer fonts 
will vary 
because they 
will display 
the logo of 
the font 
foundry that 
created 
them. The 
icon to the 
right 
represents a 
font made by 
Adobe. A 
printer font 
icon made 
by 
Fontographer 
will look like 
a printer. 

 

 

Screen 
font  

none 
.bmap 
.FAM 

Normally, the 
suitcase icon 
for a Type 1 
screen font 
will not have 
a file 
extender. If 
the screen 
font was 
created by 
Fontographer, 
it will have a 
.bmap 
extender. The 
file extension 
will be .FAM 
if a font 
family is 
merged with 
Stylemerger. 

System 
Screen Font 

All 
Macintosh 
PostScript 
fonts must 
have a screen 
font suitcase 
file 
associated 
with them in 
order to be 
installable. 
The screen 
font file 
(located 
inside of the 
suitcase) will 
have a 
particular 
point size 
associated 
with it. 

Note that 
screen fonts 
have an icon 
with one "A" 
as contrasted 
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with the 
TrueType 
triple-A 
icons. Also, 
screen fonts 
will 
sometimes 
be located 
inside the 
suitcase for a 
TrueType 
font (see 
above). 

Screen 
font 
suitcase  

      

 
      

Screen font suitcase made by Fontographer  

 
Screen font family suitcase  

 
Screen font in a particular point size, normally located inside the screen font suitcase PostScript Type 3 
none Fonts in this file format are used for grayscale fonts sent to the printer only; they are not 

recognized by ATM. Multiple Master none  

Note that printer fonts made by Fontographer have a printer icon. Commercial printer fonts will have the 
logo of the font foundry which created them. 

Note that these fonts also need an associated screen font suitcase to be installable. 

The numbers seen in some file names are used to identify a particular "instance" of the font's weight. 

Example: 
PenumMM_220 LT 0 SA 10 
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UNIX fonts 

Format  File 
Extender  

Description  Icon  

PostScript 
Type 3  

.PFA This font is referred to as 
an ASCII font in the 
UNIX environment.  

Screen 
font 

Used with  
X-
Windows  

.BDF  Bitmap Distribution 
Format screen font 

Can be embedded inside 
a TrueType font. 

 

 

Sun 
Solaris 

Silicon 
Graphics 

PostScript 
Type 1 

.PS  This file format can only 
be created on Macintosh 
Fontographer. It is 
installed with a bitmap 
file and an AFM file. 

SGI uses a Convert Mac 
Font utility to convert 
these files. 

 

NeXT 
PostScript 
Type  

.NEXT 

.nxt 

This file is only created 
on Macintosh 
Fontographer. It is 
installed with a bitmap 
file and an AFM file.  

 

Associated font files 

Format  File 
Extender  

Description  Icon  

text  .AFM 

Used on 
Macintosh 
and 
Windows 

Adobe Font Metrics file 
which contains the font 
file's spacing, widths and 
kerning. 

You can read this file to 
troubleshoot font 
problems, but it is not 
needed for installation. 

 

binary  .PFM 

Used on 
Windows 
only 

Printer Font Metrics 

Corrupt PFMs can be 
discarded and new ones 
can be created by 
installing the font using a 
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PFB, AFM and INF. A 
new PFM will be created 
by the install. 

text  .INF 

Used on 
Windows 
only 

Information file which 
contains the 
MSMenuName and 
VPstyle parameters 
which can be used to 
create large font 
families. 

 

 

 

#12948: Hacking Fontographer to open 2-byte fonts  

How to create an MMSZ resource which allows Fontographer to open two-byte fonts 

The following procedure is offered for Fontographer user's who want to attempt to open a two-byte 
font. Macromedia makes no guarantees that this procedure will work since Fontographer was not 
designed to open this font format. Be advised that your machine is likely to crash at anytime during this 
procedure. 

The procedure has to done using the Macintosh ResEdit utility. Macromedia cannot offer tech support to 
teach users how to operate this utility.  

1  Open the Fontographer application icon in ResEdit.  

2  Select Create New Resource. 

3  Make its type MMSZ. 

4  Give the resource two bytes by entering 10 00 in the hex editor.  

5  Close the resource and Get Info on Resource .  

6  Change the resource ID to 100.  

7  Close and Save the resource.  

8  Now allocate at least 100mb of RAM to Fontographer by 
selecting the Fontographer icon from the Finder and using File 
> Get Info.  

9  Two-byte fonts will now open in Fontographer but may take 3 
or 4 hours to load. 

Additional Information  
See Two-byte fonts for more information on this font format. 
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#12950: Why doesn't Adobe Expert Encoding work in TrueType 
Fonts? 

Issue 

Adobe Expert fonts CANNOT be generated as Truetype fonts with Adobe Expert encoding on the 
Macintosh or Windows platforms. 

Reason 

 
The problem is that Adobe Expert encoding uses unique character names. These names are not 
applicable to the TrueType specification 

Some will ask, "Why is it that I CAN select Adobe Expert and TrueType?" Because we should have 
prevented you from doing this! 

Solution 

Here's how to create a Truetype font which mimics Adobe Expert Encoding:  

1  Open an Adobe Expert font with original encoding. See 
Encoding vectors FAQ.  

2  Open a new, empty font and go to Element > Font Info > 
General and switch the Preview encoding to Windows 3.1 or 
Macintosh encoding if you are on a Macintosh. 

3  Paste your Adobe Expert characters into the new font. 

4  Generate as a TrueType with Windows 3.1 encoding or 
Macintosh encoding if you are on a Mac.  

This work-around causes the characters to have non-Adobe Expert character names which can be 
recognized when the font is installed as a Truetype for Macintosh or Windows. 

 

#12953: Quick-Start Unicode Font Tutorial  

Issue  
I want to create a new international TrueType font by adding some characters which are not in an 
existing font. 

Solution  
There are a couple ways to look at this: 

1. Hopefully, this is a working Unicode font which can be opened in Fontographer, edited, renamed and 
re-generated and everything will work fine. If not, read on! 

2. If we don't care about the font working as a bona fide Unicode font we can just put the characters in 
slots normally used for other characters. This will be fine if you are the only one using the font and you 
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make yourself a key map. But other users might assume that this is a real international font which works 
with a particular keyboard driver and has left-to-right, etc. These people will be justifiably unhappy. 

3. Search this database for "unicode". You can also go to the Unicode Home Page and find out the 
Unicode number for the character you want to add and define a slot according to the tech note. The 
keyboard driver doesn't care what slot or order the characters are in but it may help you to keep track of 
them if you put it in a sensible place. (Perhaps another font can show you where this character is usually 
put?) 

4. See Setting Truetype parameters for Unicode Fonts (TechNote 12333) in order to learn how to set up 
the code page in Fontographer's OS/2 Data table. We've saved you a lot of work by adding a chart of bit 
settings (as below) for the Code Page fields. Follow the other instructions in the TechNote in order to 
make sure your font is as compatible as possible. 

You should read the TrueType Specifications (downloadable from Microsoft's website) in order to find 
the appropriate values for the language you are working with. 

We've done some of the homework for you by adding the following table found on pages 101-102 of 
the TrueType spec. This spec was written before Unicode 2.0. Any languages which are not listed here 
(Example: Ethiopian) will require that you go to the Unicode Home Page and obtain the code page and 
unicode range information. 

Fontographer OS/2 Data - Code Page 1 field 

Language  Bit Settings  

Latin-1  $00000001  

Latin-2 East European  $00000002  

Cyrillic  $00000004  

Greek  $00000008  

Turkish  $00000010  

Hebrew  $00000020  

Arabic  $00000040  

Windows Baltic  $00000080  

Alt ANSI  $00000100  

Alt ANSI  $00000200  

Alt ANSI  $00000400  

Alt ANSI  $00000800  

Alt ANSI  $00001000  

Alt ANSI  $00002000  

Alt ANSI  $00004000  

Alt ANSI  $00008000  

Thai  $00010000  

JIS / Japan  $00020000  

Chinese / Simplified  $00040000  

Korean / Wansung  $00080000  

http://www.unicode.org/
http://www.microsoft.com/typography/specs/default.htm
http://www.unicode.org/
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Chinese / Traditional  $00100000  

Korean / Johab  $00200000  

ANSI / OEM  $00400000  

ANSI / OEM  $00800000  

ANSI / OEM  $01000000  

ANSI / OEM  $02000000  

ANSI / OEM  $04000000  

ANSI / OEM  $08000000  

ANSI / OEM  $10000000  

Mac / U.S. Roman  $20000000  

OEM  $40000000  

Symbol  $80000000  

Fontographer OS/2 Data - Code Page 2 field 

Language  Bit Settings  

OEM  $00000001  

OEM  $00000002  

OEM  $00000004  

OEM  $00000008  

OEM  $00000010  

OEM  $00000020  

OEM  $00000040  

OEM  $00000080  

OEM  $00000100  

OEM  $00000200  

OEM  $00000400  

OEM  $00000800  

OEM  $00001000  

OEM  $00002000  

OEM  $00004000  

OEM  $00008000  

IBM Greek  $00010000  

DOS Russian  $00020000  

DOS Nordic  $00040000  

Ext. Arabic  $00080000  

DOS Canadian French  $00100000  

Ext. Hebrew  $00200000  

DOS Icelandic  $00400000  

DOS Portuguese  $00800000  
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IBM Turkish  $01000000  

IBM Cyrillic  $02000000  

Latin 2  $04000000  

DOS Baltic  $08000000  

Greek (former 437G)  $10000000  

Arabic ASMO 708  $20000000  

WE/Latin 1  $40000000  

U.S.  $80000000  

Third party links  
Although links to external websites are provided as a resource, the websites are not part of Macromedia. 
Please see Macromedia's policy regarding links to third party websites in the Legal Notices and 
Information section. Pages to external websites will open in a new browser window. 

  

 

#12958: Disabling font style linking  

Some font designers want to prevent users from selecting a Bold or Italic style. The following hack has 
been known to accommodate this problem but is not for the faint-of-heart! Macromedia cannot offer 
tech support on the use of ResEdit. Also, be aware that this is an old hack and may not work with a 
newer Macintosh OS. 

To disable style linking 

1  Open the font bmap with ResEdit. Double-Click on FOND, OR 
choose �œOpen FOND Picker��  from menu. Double-click on 
the ID or choose �œOpen Resource editor��  from menu.  

2  Scroll down to the item �œOffset to style mapping table��  and 
note the 8-digit number in the box. 

3  Option click on the ID, OR choose menu item �œOpen using 
hex editor�� . 

4  Scroll down to the 8-digit number noted above, which is 
actually split into 2 sets of 4 digits. In the last 4-digit column (on 
the right), add hex 10 (ten) to disable Bolding, or add 40 (forty) 
to disable Italicizing, OR add 50 (fifty) to disable both Bolding 
and Italicizing. 

EXAMPLE: looking for 00000898 Disregarding the 
list of 6-digit numbers on the left, find 0000 
0898 0000 0076. To the last 4 digits (0076), 
add hex 10,40 or 50: adding 50 would produce 
the number 00C6. The line would read 0000 0898 
0000 00C6.  

http://www.macromedia.com/help/copyright.html#disclaimer
http://www.macromedia.com/help/copyright.html#disclaimer


– 171 – 

Similarly, adding 80 will disable Condensing, and 100 will disable Narrowing, However, Fontographer 
fonts are already setup so that no additional width is allowed for these functions, so disabling them is 
unnecessary. 

To enable style linking  

1  Open the font as above, but, under the �œOffset to style 
mapping table�� , locate the �œExtra width��  block for the 
needed function, such as �œExtra width for Bold�� . If this says 
1024, there is room for the Bold effect to be 125% as large as 
the original.  

2  A slight misnomer - in actuality these functions ARE enabled, at 
least in Fontographer fonts, BUT if no width is given for those 
functions, they will show no effect. Condense and Expand are 
left at zero in FOG fonts. 

3  Calculate the percentage based on an em of 4096, in other 
words, 1024 is 25%, but use a negative number for Condense. 
You may place this number in normal (decimal) terms - ResEdit 
will convert it to Hex. 

 

#12959: Troubleshooting BDF Font Files  

What is a BDF?  
BDF is the Bitmap Distribution Format used on all Unix platforms (including Aux and AIX and X-
Windows) to produce a screen font. Our files are only partly useful in that they are fixed at the 72 dpi 
resolution. Without a BDF our Unix users would have no way of creating a screen font from 
Fontographer. For more information on BDFs go to Adobe's font specifications. 

BDF files can be generated from both Macintosh and Windows versions Fontographer. 

How to use a text editor to check BDF fonts 
Open your BDF font in a text editor. The hex section of the BDF is simply a mathematical representation 
of the bitmap. For this reason, sometimes these fonts are referred to as hexadecimal fonts. The first line 
represents the first row of pixels in the bitmap, and so on down to the bottom of the file. Hexadecimal is 
a Base 16 counting system.Counting is done from 0 through f, like this: 0,1,2,3,4,5,6,7,8,9,a,b,c,d,e,f. 
Turning these bits off and on is what turns the pixels off and on in order to draw the font on the screen. 

After the font is made, install it, then open the BDF file in a text editor. Set your leading to "solid" and 
you will be able to see a graphical representation of your hex code. Just to give you an idea, the capital 
letter "I" would look kind of like this: 

X  

X X X  
O  

X X O  
O  

X X O  
X  
X  
X  

http://partners.adobe.com/asn/tech/type/ftechnotes.jsp
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X  

Each hex number is represented by a series of four pixels. A zero in hex indicates that all pixels are off. 
The table below is designed to demonstrate which bits are turned on when their hex equivalent appears 
in your BDF file. 

Bit 

Bit 8 
Bit 4 
Bit 2 
Bit 1 

Explanation 
0         all pixels OFF 1       X right most pixel ON 2     X   2 column ON 3     X X 1 column + 2 column 

= 3 4   X     4 column ON 5   X   X 4 column + 1 column = 5 6   X X   4 column + 2 column = 6 7   X 
X X 4 column + 2 column + 1 column = 7 8 X       8 column ON 9 X     X 8 column + 1 column = 9 a 
X   X   8 column + 2 column = 10 b X   X X 8 column + 2 column + 1 column = 11 c X X     8 column 
+ 4 column = 12 d X X   X 8 column + 4 column + 1 column = 13 e X X X   8 column + 4 column + 

2 column = 14 f X X X X all ON = 15  

Third party links  
Although links to external websites are provided as a resource, the websites are not part of Macromedia. 

Please see Macromedia's policy regarding links to third party websites in the Legal Notices and 
Information section. Pages to external websites will open in a new browser window. 

  

 

#12997: BDF files for X 11 Windows  

Issue  
I want to generate a bitmap font for X11 Windows. How can I do that? 

Solution  
The font is generated as BDF screen font from Fontographer. The screen or bitmap font will work for 
onscreen use only; it will not give acceptable results when printed. 

1  Select File > Generate font files > Advanced.  

2  Under Bitmap font to output, select BDF.  

3  Specify point size(s) in the Bitmap sizes to output field.  

4  Click on the Generate button.  

The resulting BDF file(s) may be edited in the XmBDFed bitmap editor for UNIX. This editor is designed 
for the purpose of editing BDF files for use with X11 Windows. 

Additional information  
The XmBDFed bitmap editor can be found by searching for "xmbdfed" using an internet search engine. 

http://www.macromedia.com/help/copyright.html#disclaimer
http://www.macromedia.com/help/copyright.html#disclaimer
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For more information on Unix font formats and installation of Unix fonts, search this database for "BDF" 
or "Unix". 

BDF (Bitmap Distribution Format) files can be created with Fontographer for Macintosh or Windows. 

 

#13017: Troubleshooting Font Problems in Microsoft Word  

Issue  
Word wrapping, spacing, hyphenation and spell checking problems occur when using a font in Microsoft 
Word. 

Solution  
All reported problems of this type have been due to conflicts between symbol encoded fonts and 
Microsoft Word. 

First of all, try the solutions offered in the above mentioned tech notes. If they fail to solve the problem 
you can create a custom encoded font using the following method: 

1  Open your font WITH ORIGINAL ENCODING as per tech note 
3713.  

2  Use Edit>Unlink Reference to make sure there are no composite 
characters. 

3  Open a new, empty font database. 

4  Use Element>Font Info>General to switch this new font's 
preview encoding to OEM.  

5  Now, copy/paste you characters from the old font into the 
proper slots in the new one.  

6  When finished, you need to make sure that none of the flags are 
set for Symbol encoding. Go to File>Generate>Advanced and 
make sure that the PC Family is set to "Don't Care" also, under 
the TrueType Options button, make sure PC Symbol encoding is 
OFF and that the Character Mapping is set to Standard.  

7  Generate the font with OEM encoding and install it. Test it in 
WordPad first in order to compare behavior with Microsoft 
Word. 

  

 

#13191: International Fonts for Macintosh  

Issue 
International font displays the wrong characters after editing it in Fontographer. 

Solution 
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1  Open the font with original encoding as described in tech note 
3713.  

2  Go to File>Generate>Advanced and on the right-hand side of 
the dialog you will see the Bitmap Font to Output Section. 

The ID field (to the right of the NFNT pop-up menu) is where you type the range for PostScript fonts. 
Truetype fonts have a TrueType ID field on the left-hand side of the dialog box. Enter a number within 
the proper range. 

Here is a table of some of the most popular script ranges: 

Script System  ID Range    

Arabic  17920  18431  

Chinese (Simplified)  28672  29183  

Chinese (Traditional)  16896  17407  

Cyrillic  19456  19967  

Greek  18944  19455  

Hebrew  18432  18943  

Japanese  16384  16895  

Korean  17408  17919  

Vietnamese  31232  31743  

Central European  30720  31231  

  

3  Enter the appropriate script range and generate the font with 
Custom encoding.  

4  Make sure that the language kit for the script you are using has 
been installed from the Macintosh System disk. Macs are not 
Unicode machines. They use KCHR keyboard resources and the 
Keyboard control panel to find characters. When the language 
kit is installed you will see an American flag in the upper right-
hand corner of your screen. 

5  Install any needed KCHR resources inside your System file (NOT 
the System folder). See your "Using Fontographer booklet" for 
instructions on creating your own KCHR. 

6  Open your application software and select the font from the 
font menu. Pull down the Keyboard Layout Manager menu (the 
menu with the flag) to select the keyboard you wish to type 
with.  

Additional Information  
See Inside Macintosh Volume VI for more information. 

  

 



– 175 – 

#13192: Fonts won't display or work incorrectly in Illustrator 7  

Issue 1  
Fonts are missing from font menu in Illustrator 7 

Solution  
Illustrator 7 uses the AdobeFnt.lst file (found in the System>Preferences folder) in order to keep track of 
which fonts will be used on the font menu. For various reasons, fonts can become listed as "invalid" in 
the AdobeFnt.lst file. 

1  Try re-opening your font with its original encoding (see tech 
note 3713) and then re-generating your font with Adobe or 
Mac encoding.  

2  Some fonts may actually be corrupted. You can use ATM to 
perform an integrity test. See tech note 3735 for instructions on 
repairing corrupted fonts. 

3  Delete the AdobeFnt.lst from your Preferences folder and restart 
Illustrator 7. 

Issue 2  
Can't stop Adobe Symbol font substitution in Illustrator 7. Adobe encoded fonts substitute certain 
characters from the Symbol font when printed. If this issue is foreign to you then search 
http://www.macromedia.com/support/search/ on "Adobe Symbol Substitution Characters". Sometimes 
you don't want this to happen. Use the following technique if you still get the Symbol substitution 
characters when you don't want them. 

Solution  

1  The solution is to use Custom, OEM or Macintosh encoding.  

2  Delete the AdobeFnt.lst from your Preferences folder and restart 
Illustrator 7. 

Additional Information  
Related issues are covered in great detail on Adobe's web site at http://www.adobe.com. Look for the 
following tech notes: 409110, 409204, 409212, 409313 

  

 

#13211: Japanese & Korean keyboard layouts  

Fontographer was not designed to create two-byte fonts. The following information is provided for users 
who need to know how to locate Japanese and Korean keystrokes on the keyboard. 

For more information on setting the default keyboard locale in Windows, see Microsoft Article 177561. 

Each layout is shown in several states. 

http://support.microsoft.com/default.aspx?scid=kb;en-us;177561
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Keys are shown as follows: 
White text on gray key = Control key 
Black text on gray key = Generates a character 
Black text on white key = Generates a character in combination with another key 

Japanese-IBM (Normal Latin State) 

 

Japanese-IBM (Shift Latin State) 

 

Japanese-IBM (Normal Kana State) 

 

Japanese-IBM (Shift Kana State) 
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Japanese-NEC (Normal Latin State) 

 

Japanese-NEC (Shift Latin State) 

 

Japanese-NEC (Normal Kana State) 

 

Japanese-NEC (Shift Kana State) 
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Korean (Normal Latin State) - Same as U.S. Keyboard except \ (backslash) =  

Korean (Shift Latin State) - Same as U.S. Keyboard 

Korean (Normal Hangul State) 

 

Korean (Shift Hangul State) 

 

From "Developing International Software for Windows 95 and Windows NT" by Nadine Kano. Copyright 
1995. Reproduced by permission of Microsoft Press. All rights reserved. 

 

#13218: Balkan Keyboard Layouts 

Issue 

How do I create international Windows fonts with proper keyboard layouts in Fontographer? 
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Solution 

Use the following steps to make a Unicode font starting with an empty database: 

1. Switch the preview encoding under Element > Font Info > General to the Unicode Glyph List 
encoding (this list automatically defines a subset of popular Unicode characters for you) or OEM 
encoding. 
 
Use Windows 3.1 or OEM encoding when you have no need for characters above 256. Use 
Windows 95 encoding only if you properly open and switch an existing Windows 95 font and 
place your characters into it as described in Windows 95 font loads as Custom encoded. 

2. See Defining Unicode Characters and Setting Truetype parameters for Unicode Fonts in order to 
prepare a Unicode font for use with the keyboard. 
 
International characters are accessed by switching to an international keyboard on the taskbar. 
The default for US English windows will be displayed as EN on the Windows taskbar. 
 
Click on EN to pop up a list of installed keyboards. For more information on setting the default 
keyboard locale in Windows, see Microsoft Article 177561. 

Each layout is shown in several states. 

Keys are shown as follows: 
White text on gray key = Control key 
Black text on gray key = Generates a character 
Black text on white key = Generates a character in combination with another key 

Croatian (Normal State) 

 

Croatian (Shift State) 

 

http://support.microsoft.com/default.aspx?scid=kb;en-us;177561
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Croatian (Alt State) 

 

Croatian (AltGr State) 

 

Greek (Normal State) 

 

Greek (Shift State) 

 

Serbian-Latin (Normal State) 
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Serbian-Latin (Shift State) 

 

Serbian-Latin (Alt State) 

 

Serbian-Latin (AltGr State) 

 

From "Developing International Software for Windows 95 and Windows NT" by Nadine Kano. Copyright 
1995. Reproduced by permission of Microsoft Press. All rights reserved. 
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#13219: Baltic Keyboard Layouts  

Issue: 

How do I create international PC fonts with proper keyboard layouts in Fontographer? 

Solution: 

To make a Unicode font starting with an empty database: 

1. Switch the preview encoding under Element>Font Info>General to the Unicode Glyph List encoding 
(this list automatically defines a subset of popular Unicode characters for you) or OEM encoding. 

Use WIN3.1 or OEM encoding when you have no need for characters above 256. Use WIN95 encoding 
only if you properly open and switch an existing WIN95 font and place your characters into it (TechNote 
3733). 

2. Define your Unicode characters and set appropriate TrueType parameters per tech notes 8174 and 
12333. 

International characters are accessed by switching to an international keyboard on the taskbar. The 
default for US English windows will be displayed as EN on the Windows taskbar. Click on EN to pop up a 
list of installed keyboards. Additional international keyboards can be installed using the Start Button to 
navigate to Settings>Control Panel>Keyboard and using the Input Locales tab to add keyboards from 
Microsoft's Multilingual Support Package. 

Each layout is shown in several states. 

Keys are shown as follows: 
White text on gray key = Control key 
Black text on gray key = Generates a character 
Black text on white key = Generates a character in combination with another key 

Estonian (Normal State) 

 

Estonian (Shift State) 



– 183 – 

 

Estonian (AltGr State) 

 

Latvia (Normal State) 

 

Latvia (Shift State) 

 

Latvia (Alt State) 
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Latvia (AltGr State) 

 

Latvia (AltGr State) 

 

From "Developing International Software for Windows 95 and Windows NT" by Nadine Kano. Copyright 
1995. Reproduced by permission of Microsoft Press. All rights reserved. 

 

#13220: Cyrillic keyboard layouts 

Issue 

How do I create international Windows fonts with proper keyboard layouts in Fontographer? 

Solution 

Use the following steps to make a Unicode font starting with an empty database: 
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1. Switch the preview encoding under Element > Font Info > General to the Unicode Glyph List 
encoding (this list automatically defines a subset of popular Unicode characters for you) or OEM 
encoding. 
 
Use Windows 3.1 or OEM encoding when you have no need for characters above 256. Use 
Windows 95 encoding only if you properly open and switch an existing Windows 95 font and 
place your characters into it as described in Windows 95 font loads as Custom encoded. 

2. See Defining Unicode Characters and Setting Truetype parameters for Unicode Fonts in order to 
prepare a Unicode font for use with the keyboard. 
 
International characters are accessed by switching to an international keyboard on the taskbar. 
The default for US English windows will be displayed as EN on the Windows taskbar. 
 
Click on EN to pop up a list of installed keyboards. 

Each layout is shown in several states. 

Keys are shown as follows: 
White text on gray key = Control key 
Black text on gray key = Generates a character 
Black text on white key = Generates a character in combination with another key 

Byelorussian (Normal State) 

 

Byelorussian (Shift State) 

 

Bulgarian-Cyrillic (Normal State) 
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Bulgarian-Cyrillic (Shift State) 

 

Bulgarian-Latin (Normal State) 

 

Bulgarian-Latin (Shift State) 

 

Russian (Normal State) 
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Russian (Shift State) 

 

Ukrainian (Normal State) 

 

Ukrainian (Shift State) 

 

From "Developing International Software for Windows 95 and Windows NT" by Nadine Kano. Copyright 
1995. Reproduced by permission of Microsoft Press. All rights reserved. 
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#13221: East European keyboard layouts  

Issue  
How do I create international Windows fonts with proper keyboard layouts in Fontographer? 

Solution  
Use the following steps to make a Unicode font starting with an empty database: 

1  Switch the preview encoding under Element > Font Info > 
General to the Unicode Glyph List encoding (this list 
automatically defines a subset of popular Unicode characters for 
you) or OEM encoding. 

Use Windows 3.1 or OEM encoding when you have no need for 
characters above 256. Use Windows 95 encoding only if you 
properly open and switch an existing Windows 95 font and 
place your characters into it as described in Windows 95 font 
loads as Custom encoded. 

2  See Defining Unicode Characters and Setting Truetype 
parameters for Unicode Fonts in order to prepare a Unicode 
font for use with the keyboard. 

International characters are accessed by switching to an 
international keyboard on the taskbar. The default for US 
English windows will be displayed as EN on the Windows 
taskbar. 

Click on EN to pop up a list of installed keyboards. Additional 
international keyboards can be installed using the techniques 
discussed in Setting international keyboards in Windows. 

Each layout is shown in several states. 

Keys are shown as follows: 
White text on gray key = Control key 
Black text on gray key = Generates a character 
Black text on white key = Generates a character in combination with another key 

Hungarian (Normal State) 
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Hungarian (Shift State) 

 

Hungarian (AltGr State) 

 

Polish (Normal State) 

 

Polish (Shift State) 
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Polish (Alt State) 

 

Polish (AltGr State) 

 

Romanian (Normal State) 

 

Romanian (Shift State) 
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Romanian (AltGr State) 

 

From "Developing International Software for Windows 95 and Windows NT" by Nadine Kano. Copyright 
1995. Reproduced by permission of Microsoft Press. All rights reserved. 

  

 

#13222: Latin countries - keyboard layouts  

Issue  
How do I create international Windows fonts with proper keyboard layouts in Fontographer? 

Solution  
To make a Unicode font starting with an empty database: 

1  Switch the preview encoding under Element > Font Info > 
General to the Unicode Glyph List encoding (this list 
automatically defines a subset of popular Unicode characters for 
you) or OEM encoding. 

Use Windows 3.1 or OEM encoding when you have no need for 
characters above 256. Use Windows 95 encoding only if you 
properly open and switch an existing Windows 95 font and 
place your characters into it as described in Windows 95 font 
loads as Custom encoded. 

2  See Defining Unicode Characters and Setting Truetype 
parameters for Unicode Fonts in order to prepare a Unicode 



– 192 – 

font for use with the keyboard. 

International characters are accessed by switching to an 
international keyboard on the taskbar. The default for US 
English windows will be displayed as EN on the Windows 
taskbar. 

Click on EN to pop up a list of installed keyboards. Additional 
international keyboards can be installed using the techniques 
discussed in Setting international keyboards in Windows. 

Each layout is shown in several states. 

Keys are shown as follows: 
White text on gray key = Control key 
Black text on gray key = Generates a character 
Black text on white key = Generates a character in combination with another key 

Italian (Normal State) 

 

Italian (Shift State) 

 

 
Latin American (Normal State) 
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Latin American (Shift State) 

 

 
Portuguese (Normal State) 

 

Portuguese (Shift State) 

 

Portuguese (AltGr State) 
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Portuguese (Shift+AltGr State) 

 

Portuguese-Brazilian ABNT2 (Normal State) 

 

Portuguese-Brazilian ABNT2 (Shift State) 

 

Portuguese-Brazilian ABNT2 (AltGr State) 
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Spanish (Normal State) 

 

Spanish (Shift State) 

 

Spanish (AltGr State) 

 

From "Developing International Software for Windows 95 and Windows NT" by Nadine Kano. Copyright 
1995. Reproduced by permission of Microsoft Press. All rights reserved. 
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#13223: Mideast keyboard layouts  

Issue  
How do I create international Windows fonts with proper keyboard layouts in Fontographer? 

Solution  
These instructions are only for Turkish fonts. Fontographer cannot create fonts which are guaranteed to 
work with Hebrew Windows or Arabic Windows. This is due to the Glyph Substitution (GSUB) tables 
found in these fonts. 

To make a Unicode font starting with an empty database: 

1  Switch the preview encoding under Element > Font Info > 
General to the Unicode Glyph List encoding (this list 
automatically defines a subset of popular Unicode characters for 
you) or OEM encoding. 

Use Windows 3.1 or OEM encoding when you have no need for 
characters above 256. Use Windows 95 encoding only if you 
properly open and switch an existing Windows 95 font and 
place your characters into it as described in Windows 95 font 
loads as Custom encoded. 

2  See Defining Unicode Characters and Setting Truetype 
parameters for Unicode Fonts in order to prepare a Unicode 
font for use with the keyboard. 

International characters are accessed by switching to an 
international keyboard on the taskbar. The default for US 
English windows will be displayed as EN on the Windows 
taskbar. 

Click on EN to pop up a list of installed keyboards. Additional 
international keyboards can be installed using the techniques 
discussed in Setting international keyboards in Windows. 

Each layout is shown in several states. 

Keys are shown as follows: 
White text on gray key = Control key 
Black text on gray key = Generates a character 
Black text on white key = Generates a character in combination with another key 

Arabic (Normal State) 



– 197 – 

 

Arabic (Shift State) 

 

Hebrew (Normal State) 

 

Hebrew (Shift State) - Same as US Keyboard 

Hebrew (Caps lock on+Shift State) 

 

Turkish-F Type (Normal State) 
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Turkish-F Type (Shift State) 

 

Turkish-F Type (AltGr State) - Also Shift+AltGr State to get CAP AE ligature 

 

Turkish-Q Type (Normal State) 

 

Turkish-Q Type (Shift State) 
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Turkish-Q Type (AltGr State) - Also Shift+AltGr State to get CAP AE ligature 

 

From "Developing International Software for Windows 95 and Windows NT" by Nadine Kano. Copyright 
1995. Reproduced by permission of Microsoft Press. All rights reserved. 

  

 

#13225: European keyboard layouts 

Issue 

How do I create international Windows fonts with proper keyboard layouts in Fontographer? 

Solution 

Use the following steps to make a Unicode font starting with an empty database: 

1. Switch the preview encoding under Element > Font Info > General to the Unicode Glyph List 
encoding (this list automatically defines a subset of popular Unicode characters for you) or OEM 
encoding. 
 
Use Windows 3.1 or OEM encoding when you have no need for characters above 256. Use 
Windows 95 encoding only if you properly open and switch an existing Windows 95 font and 
place your characters into it as described in Windows 95 font loads as Custom encoded. 

2. See Defining Unicode Characters and Setting Truetype parameters for Unicode Fonts in order to 
prepare a Unicode font for use with the keyboard. 
 
International characters are accessed by switching to an international keyboard on the taskbar. 



– 200 – 

The default for US English windows will be displayed as EN on the Windows taskbar. 
 
Click on EN to pop up a list of installed keyboards. 

Each layout is shown in several states. 

Keys are shown as follows: 
White text on gray key = Control key 
Black text on gray key = Generates a character 
Black text on white key = Generates a character in combination with another key 

Belgian (Normal State) 

 

Belgian (Shift State) 

 

Belgian (AltGr State) 

 

Belgian (Shift+AltGr State) 



– 201 – 

 

Dutch (Normal State) 

 

Dutch (Shift State) 

 

Dutch (AltGr State) 

 

Dutch (Shift+AltGr State) - ( , ) as above 

French (Normal State) 
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French (Shift State) 

 

French (Alt State) 

 

French (AltGr State) 

 

German (Normal State) 
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German (Shift State) 

 

German (AltGr State) 

 

Swedish (Normal State) 

 

Swedish (Shift State) 
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Swedish (AltGr State) 

 

Swedish (Shift+AltGr State) - tilde ( ~ ) as above 

Swiss French (Normal State) 

 

Swiss French (Shift State) 

 

Swiss French (AltGr State) 
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Swiss French (Shift+AltGr State)- ( ' ) and ( ~ ) as above 

Swiss German (Normal State) 

 

Swiss German (Shift State) 

 

Swiss German (AltGr State) 

 

Swiss German (Shift+AltGr State) - ( ' ) and ( ~ ) as above 
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From "Developing International Software for Windows 95 and Windows NT" by Nadine Kano. Copyright 
1995. Reproduced by permission of Microsoft Press. All rights reserved. 

 

#13226: Scandanavian Keyboard Layouts  

Issue  
How do I create international Windows fonts with proper keyboard layouts in Fontographer? 

Solution  
Use the following steps to make a Unicode font starting with an empty database: 

1  Switch the preview encoding under Element > Font Info > 
General to the Unicode Glyph List encoding (this list 
automatically defines a subset of popular Unicode characters for 
you) or OEM encoding. 

Use Windows 3.1 or OEM encoding when you have no need for 
characters above 256. Use Windows 95 encoding only if you 
properly open and switch an existing Windows 95 font and 
place your characters into it as described in Windows 95 font 
loads as Custom encoded. 

2  See Defining Unicode Characters and Setting Truetype 
parameters for Unicode Fonts in order to prepare a Unicode 
font for use with the keyboard. 

International characters are accessed by switching to an 
international keyboard on the taskbar. The default for US 
English windows will be displayed as EN on the Windows 
taskbar. 

Click on EN to pop up a list of installed keyboards. Additional 
international keyboards can be installed using the techniques 
discussed in Setting international keyboards in Windows. 

Each layout is shown in several states. 

Keys are shown as follows: 
White text on gray key = Control key 
Black text on gray key = Generates a character 
Black text on white key = Generates a character in combination with another key 

Danish (Normal State) 
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Danish (Shift State) 

 

Danish (AltGr State) 

 

Finnish (Normal State) 

 

Finnish (Shift State) 
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Finnish (AltGr State) 

 

Finnish (Shift+AltGr State) - ( ~ ) as above 

Icelandic (Normal State) 

 

Icelandic (Shift State) 

 

Icelandic (Alt State) 
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Icelandic (AltGr State) 

 

Icelandic (Shift+AltGr State) 

 

Norwegian (Normal State) 

 

Norwegian (Shift State) 
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Norwegian (AltGr State) 

 

Norwegian (Shift+AltGr State) - same (white keys only) as above. 

From "Developing International Software for Windows 95 and Windows NT" by Nadine Kano. Copyright 
1995. Reproduced by permission of Microsoft Press. All rights reserved. 

 

#13227: Slovak keyboard layouts  

Issue  
How do I create international Windows fonts with proper keyboard layouts in Fontographer? 

Solution  
Use the following steps to make a Unicode font starting with an empty database: 

1  Switch the preview encoding under Element > Font Info > 
General to the Unicode Glyph List encoding (this list 
automatically defines a subset of popular Unicode characters for 
you) or OEM encoding. 

Use Windows 3.1 or OEM encoding when you have no need for 
characters above 256. Use Windows 95 encoding only if you 
properly open and switch an existing Windows 95 font and 
place your characters into it as described in Windows 95 font 
loads as Custom encoded. 

2  See Defining Unicode Characters and Setting Truetype 
parameters for Unicode Fonts in order to prepare a Unicode 
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font for use with the keyboard. 

International characters are accessed by switching to an 
international keyboard on the taskbar. The default for US 
English windows will be displayed as EN on the Windows 
taskbar. 

Click on EN to pop up a list of installed keyboards. Additional 
international keyboards can be installed using the techniques 
discussed in Setting international keyboards in Windows. 

Each layout is shown in several states. 

Keys are shown as follows: 
White text on gray key = Control key 
Black text on gray key = Generates a character 
Black text on white key = Generates a character in combination with another key 

Czech (Normal State) 

 

Czech (Shift State) 

 

Czech (Alt State) 
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Czech (AltGr State) 

 

Czech-Qwerty (Normal State) 

 

Czech-Qwerty (Shift State) 

  

Czech-Qwerty (Alt State) 
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Czech-Qwerty (AltGr State) 

 

Slovak (Normal State) 

  

Slovak (Shift State) 

 

Slovak (Alt State) 
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Slovak (AltGr State) 

 

Note: the Slovenian keyboard is very similar to Slovak. 

From "Developing International Software for Windows 95 and Windows NT" by Nadine Kano. Copyright 
1995. Reproduced by permission of Microsoft Press. All rights reserved. 

 

#13228: Master list of international keyboard layouts  

Issue  
How do I create international Windows fonts with proper keyboard layouts in Fontographer? 

Solution  
Choose from the following list of keyboards and follow the instructions for defining characters. 

Balkan Keyboard Layouts  

Baltic Keyboard Layouts  

Cyrillic Keyboard Layouts  

East European Keyboard Layouts  

European Keyboard Layouts  

Japanese, Korean Keyboard 
Layouts  

Latin Countries Keyboard 
Layouts  
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Mideast Keyboard Layouts  

Scandanavian Keyboard Layouts  

Slovak Language Keyboard 
Layouts  

For unlisted keyboards, see "Developing International Software for Windows 95 and Windows NT" by 
Nadine Kano. Copyright 1995. Reproduced by permission of Microsoft Press. All rights reserved. 

Third party keyboard drivers are available from: 

http://www.qtext.com  

http://www.unitype.com  

  

 

#13276: Unrecognized characters in Macintosh Arabic fonts 

Issue 

The Macintosh version of Fontographer displays a lack of robustness in handling the yacute (dec 8) and 
multiply (DEC 29) for Arabic fonts. 

Reason 

This range of characters is commonly used for Control characters or hot-keys in many applications. For 
this reason users cannot depend on these characters as they may be pre-empted by application software. 

Arabic font designers will be quick to point out that many commercial Arabic fonts have these characters 
in slots 8 and 29 when opened. However, Fontographer's internal character list doesn't know what to do 
with these characters. 

Solution 

1  Make sure you have opened the font with its original encoding 
as outlined in Encoding vectors FAQ.  

2  Go to Element > Font Info and change the number of characters 
allowed in the font to include an additional two characters. Also 
change the Preview Encoding in this dialog to Custom. Be sure 
to also use Custom when generating the font. 

3  Copy and paste the yacute and multiply characters into the new 
slots you have created. 

4  Select a character and use Element > Selection Info to change 
the name to yacute. Then choose Set Unicode. Press the OK 
button to close the dialog. If you set the Font window to View 
by: Unicode, the number $00FD will appear above the newly 

http://www.qtext.com/
http://www.unitype.com/
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placed character at the end of your font. Now do the same for 
the multiply character. Its Unicode number should be $00D7.  

5  When you click the OK button to leave the Selection Info dialog 
you will get this message: "There are multiple glyphs with that 
name. Do you want to swap the names of the two glyphs?" Click 
OK.  

6  Generate your font with Custom encoding. The once missing 
characters should now function correctly.  

  

 

#13303: How to add a Euro character to your PC font  

Issue  
How can I add the Euro character to my PC font? Which slot should it go in? 

Solution 1 
Non-Unicode / Windows Encoded Font  

This method is suggested for developers who do NOT require their fonts to be Unicode compliant. 

1  Open your font with original encoding as per tech note 3733. 
Inspect the encoding via Element>Font Info>General.  

2  Highlight the currency character in slot 164 and press the Delete 
key to delete it. 

3  Copy/paste or use File>Import>EPS or use the drawing tools to 
create a custom Euro character in slot 164. 

4  Use File>Generate Fonts>Advanced to generate the font with 
Windows encoding. After you install the font you can test for 
the Euro character using the Alt-0164 keystrokes. Do NOT use 
PC Symbol Encoding or Sequential Character mapping.  

 
Solution 2 
Unicode Font  

This method is suggested for developers who DO require their fonts to be Unicode compliant. 

1  Open your font with original encoding as per tech note 3733.  

2  Highlight Decimal slot 128 (At the top of the Font Window 
change your View By: Decimal to see the whole database listed 
by decimal). 

3  Use the dialog box under Element>Selection Info to enter the 
Character Name: uni20AC and set the Unicode value to 20AC. 

4  See your "Using Fontographer" booklet on "Export Encoding" in 
order to learn how to create your own encoding vector.  
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5  Exit Fontographer and restart the application. Your encoding 
will appear in the list of encodings found under Element>Font 
Info>General.  

6  Use File>Generate Fonts>Advanced to generate the font with 
your encoding vector.  

7  Be sure that you have checked all the pertinent TrueType 
parameters as found in Tech Note 12333.  

8  This font will only work if there is an appropriate keyboard 
driver installed.  

Solution 3 
Adding Euro character to a PC font using Mac Fontographer  

1  Open an empty font database in Mac Fontographer via 
File>New Font.  

2  Switch the encoding to OEM via Element>Font Info. 

3  Highlight Decimal slot 128 (At the top of the Font Window 
change your View By: Decimal to see the whole database listed 
by decimal). 

4  Use the dialog box under Element>Selection Info to enter the 
Character Name: uni20AC and set the Unicode value to 20AC.  

5  Paste the rest of your characters into the appropriate slots. See 
tech note 13433 if you need to know where to place your 
characters for cross-platform usage.  

6  Generate the font with Custom encoding via 
File>Generate>Advanced.  

Symbol Font Conflicts  
The PostScript level III ROMs (LW8500) have the Euro in slot 160 -which is not defined (notdef) on the 
PC. The new Symbol font in the LW8500 ROM will not print a character on the PC because this is seen as 
a notdef character in Windows encoding. 

Note: 
The EuroNT/Euro Win95 packages as well as some free Euro-enabled fonts may be found on Microsoft's 
Euro font page. Be advised that if these fonts are opened in Fontographer the Euro character will be seen 
as an undefined character. It will necessary to use one of the above solutions in order to sucessfully 
generate these fonts. 

  

 

#13304: How to add a Euro Character to a Macintosh font  

Question  
How can I add the Euro character to my font? Which slot should it go in?  

http://www.microsoft.com/windows/euro.asp
http://www.microsoft.com/windows/euro.asp
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Answer 1 
 
A Font Designed on Macintosh and staying on Macintosh  
Replace the "currency" character (decimal 219) glyph with your custom Euro character. 

To add a Euro character do the following: 

1  Open your font with original encoding as per 
TechNote 3713. 

2  If it's a PostScript font you should use the 
procedures in TechNote 3715 to import the 
metrics and bitmaps. 

3  Highlight the currency character in slot 219 and 
press the Delete key to delete it.  

4  Copy/paste or use File>Import>EPS or use the 
drawing tools to create a custom Euro character in 
slot 219.  

5  If it's a PostScript font you will find that changing 
what's in the outline slot doesn't automatically 
change the bitmap screen character for that slot. 
With slot 219 highlighted you should use the 
Windows>Open Bitmap Window menu to bring 
up the bitmap character editor. 
Click on the "Recalc from Outline" button in order 
to change the bitmap to a Euro. 
Do not use Element>Recalc Bitmaps or you will 
overwrite your imported bitmaps.  

6  Use File>Generate Fonts>Advanced to generate 
the font with Macintosh encoding. After you 
install the font you can test for the Euro character 
using the Shift-Option-2 keystrokes.  

  

Answer 2 

Font Designed on Macintosh for Windows 
The safest method is to use decimal slot 164 when creating a font for Winodws. 
Slot 164 is where Windows maps the currency character. 
Follow the steps in order to guarantee that your font will be mapped correctly 
after it gets to the Windows platform. 

To add a Euro character do the following: 

1  Use File>New Font to create an empty 
Fontographer database. Go to Element>Font Info 
and switch the Preview Encoding under (Family 
Name) to OEM or Custom. 
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2  Open your previously created font and copy/paste 
your characters into the empty Fontographer 
database. 
Make sure that the Euro is pasted into slot 164. 
If your font is designed to make use of extended 
characters you will need to paste these characters 
into the slots which Windows uses for these 
characters. 
Search the Macromedia TechNote database via 
http://www.macromedia.com/support/search for 
"crossover" to find a list of character equivalencies 
between Macintosh and Windows. 

3  Use File>Generate Fonts>Advanced to generate 
the font with OEM or Custom encoding.  

4  Install the font on Windows and test the Euro 
character by using the Alt-0164 keystrokes.  

Symbol Font Conflicts  
The PostScript Level III ROMs (LW8500) have the Euro in slot 160. 

This slot has been used for the Dagger character in the past. 
An old symbol font with a dagger character in slot 160 will now print a Euro character in its place. 
 
Note: Sample Euro fonts and information may be found at http://www.adobe.com/type/eurofont.html 

  

 

#13314: What is an encoding vector?  

Definition of encoding 
Encoding vectors are tables of character sets. These tables are used to help the keyboard match a 
keypress with a character slot. Most of the characters in slots 0 -31 are pre-empted by application 
software and the operating system. Slots 32 - 126 (ASCII) are identical on every computer in the world. 
This means that an ASCII "A" is always decimal 65 regardless of which machine it is on. 

So much for the easy part. Characters 128 - 255 are called "extended characters" and this is where the 
use of various encoding vectors comes in. These are the characters which require special combinations of 
keystrokes in order to display. Some international keyboard layouts are standardized with certain 
characters matched to certain keys. 

Another problem is the use of characters above 255. This range of characters is accessed by defining 
Unicode character names and Unicode numbers to each slot as outlined in the Quick-Start Unicode Font 
Tutorial (TechNote 12953). The list below is designed to assist you as you select the proper encoding for 
your font project. 

Encoding list 
I mportant - the first place to start an understanding of encoding is to open the font with its original 
encoding. See Encoding Vectors Q & A (TechNote 3713). 

http://www.adobe.com/type/eurofont.html
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Adobe Standard Encoding - Use only if this character set has all the characters you need and you 
expect features like Smart Quotes (see Problems with Quote or Apostrophe Characters TechNote 12324), 
ligatures and Symbol substitution (see Symbol Substitution Issues TechNote 12334). This encoding vector 
is very good for doing cross-platform fonts as long as you don't need any non-Adobe encoded 
characters. 

Be aware that all screen fonts on a Macintosh use Macintosh Encoding! If you open an Adobe font and 
find that some of the bitmaps are wrong when you generate it as a TrueType then you should also refer 
to the workaround in Symbol Substitution Issues (TechNote 12334). 

Custom Encoding - Used when creating your own encoding. Macintosh users will find instructions in the 
Fontographer folder's Addendum notes. Windows users will find instructions in the "Using Fontographer" 
booklet which came in the box with the User Manual. Custom encoding is used for Symbol fonts (see 
below) and International fonts (see International Fonts for Macintosh TechNote 13191) which work with 
special KCHR resources (see "Using Fontographer" booklet) or keyboard drivers. 

Cross-platform fonts - we have created a portable font template with Custom encoding which behaves 
identically on Windows and Macintosh. You can copy and paste your characters into this template font. 
See Creating Portable TrueType Fonts (TechNote 13365). 

Expert Encoding (Adobe Expert / Mac Expert ) - Required for fonts known as Expert Sets. Characters 
consist of printer's symbols, swash caps, small caps, old style "hanging" numerals, superior and inferior 
characters and text symbols. See Why doesn't Adobe Expert Encoding work in TrueType Fonts? 
(TechNote 12950). 

ISO Latin Encoding - Preferred by most Unix systems. Used mainly for the Sun and NeXT computers. 
See Preparing fonts for Unix Systems (TechNote 12908). 

Macintosh Encoding - Use if font is staying on the Macintosh and Macintosh encoding has all the 
characters you need. This will maintain the Macintosh keyboard compatibility with other fonts. This 
encoding allows characters in the lower 32 slots but we don't recommend you use them unless you 
know what you are doing. Most application software uses these slots for Control keys. 

OEM Encoding - Used on Windows to recoup characters which Windows encoding takes away from you 
(except for 127 and 160). It can be used for custom Unicode fonts.  

Original Encoding - If the font was opened with its original encoding, and the characters seem to be 
where you want them, you should generate with original to retain the encoding. Use this approach with 
fonts which have strange encoding vectors like Sonata, Carta and Zapf Dingbats. 

OS/2 Unicode Glyph list - Gives Windows users access to the full OS/2 character set. Designers will have 
some of the tedium taken out of their project by switching the preview encoding in order to obtain this 
subset of predefined Unicode characters. 

Symbol Font Encoding - See Creating Symbol fonts for the PC (TechNote 12312). This is a special type 
of font. The main thing to remember with Symbol fonts is to open them with their original encoding and 
generate them as Custom. Use the Symbol Font TechNote to verify that all parameters are intact. These 
fonts are normally made to work with application features like Microsoft Word's "Insert Symbol". 

Windows Unicode Glyph List (WGL) - Provides predefined slots for the full WIN95 character set as well 
as Greek, Cyrillic, Hebrew, European, Line draw characters as well as other languages. 
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Windows 3.1 Encoding (ANSI) - Use this if you are staying on Windows and have familiarized yourself 
with the issues presented in Inaccessible Characters in Windows Fonts (TechNote 3700).  

Windows 95 Encoding - Provides predefined slots for Greek, Cyrillic, Hebrew, European, Line draw 
characters as well as other languages. Watch out for problems opening these fonts as outlined in WIN95 
font loads as Custom encoded (TechNote 12338). 

  

 

#13365: Creating portable fonts  

What is a Portable Font?  
Traditionally, Microsoft Windows wasn't designed to recognize all Macintosh keystrokes (for example, 
the Apple key) and the Apple OS wasn't designed to accommodate Windows users. A portable font is 
encoded in such a way that it can place characters in the desired positions whether it is installed on 
Macintosh or Windows. The need for a portable font arises when a user cannot find an encoding vector 
which handles the above criterion. 

How to use a portable font 
These steps assume that you are using Fontographer and FreeHand 8 on a Macintosh. 

1  Create the portable font set with Fontographer (as below), 
install it and enter keystrokes into a Freehand document.  

2  The document can be renamed with a *.FH8 extender (for 
example) to prepare it to go to Windows. 

3  Install the specially prepared Windows font on Windows. 

4  Bring the FH8 file over to Windows and open it in Windows 
Freehand The document should open without requiring you to 
select the font within the application's font menu.  

5  Generate and install a corresponding font on the Macintosh and 
test it in an identical document. The characters should display in 
the same positions on both machines.  

Do I Really Need a Custom Portable Font?  
Maybe NOT! Portable fonts are only needed when you have a need to access extended characters (found 
above decimal 128). Characters 32-127 are the same in every popular encoding vector in the world so 
unless you have a need for extended characters you don't need a portable font. 

The first question: "Is there an existing encoding vector which has the characters needed?" If you stop 
and think about it, Adobe fonts are sold for both Windows and Macintosh. Users can buy both Windows 
and Macintosh versions of a font like Garamond and they can count on their documents displaying the 
correct characters under both operating systems. Use Adobe Standard encoding with PostScript Type 1 
fonts whenever possible and you will eliminate the need for a custom font. 

However, there will always be times when a particular project requires characters which are not found 
when using Adobe Standard encoding. Adobe PostScript fonts can use ATM and your printer driver to 
give you most, but not all, of the characters which are found on both Macintosh and Windows. The 
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CROSS.FOG template font database was developed for these occasions. The custom encoding vector used 
in this database is designed so that neither ATM nor the printer driver will re-encode the font. 

Background on Custom TrueTypes  
Our CROSS.FOG database is derived from the encoding found in the Windows 3.1 version of ARIAL.TTF. 
The encoding found in this database was designed to include ONLY character names which are 
recognized by Macintosh and Windows. Thus, the secret of making a TrueType font work identically on 
Macintosh and Windows is that you must only use character names which are common to both 
platforms. For example, the fi and fl ligatures DO exist in Macintosh encoding but they do NOT exist in 
Windows 3.1 encoding so they would not be found in CROSS.FOG. 

How to use the CROSS.FOG template  

1  Open CROSS.FOG with your File>Preferences set like this: 

When the user types a key to choose a character 

Use the font's original encoding to choose the character 
(Note: Windows only) 

Unless this font is being created on a Macintosh, in which case 
the following setting is used: 

Use Macintosh encoding to choose the character (Note: 
Macintosh only)  

When reading an outline font 

Keep the font's original encoding  
 

2  Check Element > Font Info > General (Macintosh version of 
Fontographer doesn't say "General"). The Preview Encoding 
here (seen under the Family Name) should say: "Custom" if you 
are using Windows Fontographer. If you are using Macintosh 
Fontographer the Preview Encoding needs to be switched to 
Macintosh.  

3  Change the Family Name, then click OK to close this dialog box. 

4  Open your font, use Edit > Select All to view the entire font 
database window, then go to Edit > Unlink Reference to make 
sure that your font has no referenced characters. Now, 
copy/paste the characters from your font into the corresponding 
slots in CROSS.FOG. The idea here is to make it easy for you to 
see where the characters go rather than requiring you to 
understand how a particular character gets remapped on a 
different platform.  

5  Use File > Generate Font Files > Advanced to select the 
following settings. 
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For the Windows version of your font: 

Computer: PC 

Outline Font: TrueType 

Encoding: Custom 

Bitmap font to output: None 

For the Macintosh version of your font: 

Computer: Macintosh 

Outline Font: TrueType 

Encoding: Macintosh 

Bitmap font to output: None 

6  After the fonts are installed you would then open identical 
application documents on both Macintosh and Windows and 
test them with your newly installed fonts. 

Downloading our Sample Portable Font Database 
Download one of the following versions of the CROSS.FOG font database files: 

Macintosh: cross.sea.hqx (216K) 

Windows: cross.zip (58K) 

This database was created in cooperation with the Treacyfaces font foundry. We have created this 
template in order to allow you to take advantage of the special encoding vector contained in the 
database. The characters found in this database are commercial font samples for personal evaluation 
only, and may not be sold, given away, or otherwise redistributed. They are being made available as a 
learning tool only. Please refer to Joe Treacy's license agreement for information if you are also 
interested in licensing these character shapes. 

Additional information 
Macintosh fonts created with Windows Fontographer will need to be brought to the Macintosh and 
dragged on top of the MMPC2MAC utility in order to be converted. For further info on this process see 
Troubleshooting the MMPC2MAC Utility (TechNote 12335). 

Portable fonts do NOT work with basic text editors. They are designed for desktop publishing 
applications or word processing formatted files because they read the font's encoding whereas a text 
editor does not. 

CROSS.FOG does not contain ligatures. If you need characters which are not found in the CROSS.FOG 
template font you will have to make your own custom encoding vector. This is not recommended for 
beginners, Windows users can study the fontog.enc file found in the Fontographer folder. See the 
Fontographer User Manual for a listing of encoding tables. Mac users should refer to the tech note 
addendum file found in the Fontographer folder. 

http://www.pyrus.com/downloads/cross.sea.hqx
http://www.pyrus.com/downloads/cross.zip
http://www.treacyfaces.com/
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There will still be considerable issues which can arise when making cross-platform families (see Creating 
PC font families [TechNote 12319]) and large font families (see Large font families in Windows 
[TechNote 3712]). 

CROSS.FOG can be used to generate PostScript fonts but we cannot guarantee the results. The best 
solution is to just use Adobe standard encoding for PostScript fonts. There are some issues (such as ATM 
re-encoding your font) which come into play when creating portable PostScript fonts with non-Adobe 
encoding. Of course, there will always be font engineers who will create their own keyboard drivers and 
custom encoding vectors in order to recognize characters in certain positions. A useful set of cross-
platform font utilities can be found at the Y & Y web site. 

Note: Although links to external Web sites are provided as a resource, the Web sites are not part of 
Macromedia. Pages will open in a new browser window. 

  

 

#13428: Accessing special characters in Windows 95 encoding  

Issue  
Windows 95 encoded font doesn't allow keyboard access for the special characters above 256. 

Solution  
International keyboard support is provided by the Multilingual Support Package. Additional special 
characters are reliably accessed via the Microsoft Word 97 Insert > Symbol menu. 

Microsoft Windows ships with the core fonts which contain a wide range of subsets for popular use. 
Examples are Arial, CourierNew, and TimesNewRoman. These fonts have been carefully crafted in order 
to work in conjunction with properly installed international keyboard drivers. 

To understand how this works: 

1  
Go to Start > Programs > Accessories > WordPad and select 
Arial from the font menu  

Notice the font is listed on the font menu this way: 

Arial (Central European) 
Arial (Cyrillic) 
Arial (Greek) 
Arial (Western) 

This international info is referred to as the code page coverage or script available in the font. The code 
page coverage is understood when the proper keyboard driver is installed for that coverage. Fonts which 
have international characters will allow you to type those characters if you have the proper keyboard 
driver installed. 

2  
Go to Start > Settings > Control Panel > Keyboard and then select the "Input 
Locales" tab to add a keyboard  

http://www.yandy.com/
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Installed keyboards will be found under the "EN" language indicator on the taskbar. So far, so good, but 
what about special characters which are not necessarily international? 

Special Characters List  
Refer to the Windows 95 encoding table in the Fontographer User Manual for individual characters. 

General Punctuation 
Superscripts and Subscripts 
Currency Symbols 
Letterlike Symbols 
Number Forms 
Arrows 
Misc. Technical 
Box Drawing 
Block Elements 
Geometric Shapes 
Misc. Dingbats 
Private Use Area 
Alphabetic Presentation Forms 

Inserting Special Characters 

1  Select Arial from the Microsoft Word font menu  

2  
Using Microsoft Word, go to Insert > Symbol. Highlight the "Symbols" tab 
in the Symbol dialog  

Note that the Symbol dialog's font menu contains Symbol encoded fonts only. (For more info on how to 
prepare Symbol fonts see Creating Symbol fonts for the PC.) You will NOT be selecting one of the 
Symbol fonts! As long as you have a properly prepared font (such as Arial, etc.) selected in the Microsoft 
Word font menu, the Subset which you select will be taken from that font. 

3  Select the desired Subset from the pop-up on the right  

4  
Scroll through the font's character slots then highlight the character you are looking for. Click the 
"Insert" button to insert it into your text  

5  
The resulting file will not retain all special characters when exported or pasted into another 
application  

Additional Information 

You can use the "Shortcut Key" button to customize your own keystrokes. 

The easiest method for creating a font with special characters is to open a Windows 95 font, paste your 
characters into it and generate with Windows 95 encoding. This will preserve all of the Truetype 
parameters which are very difficult to decipher and enter into Fontographer. For those who are creating 
a font from scratch there are detailed instructions in tech note 12333. 

The most accessible way to use Windows 95 encoding is via Microsoft Word. Users who need these 
characters to work in other applications should check with the vendor. Engineers who are writing 
applications designed to be compatible with the use of special characters should refer to Developing 
International Software published by Microsoft Press. 
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#13432: Conflicts with Macintosh Font Management Software 

Issue 

What might cause Fontographer fonts to have conflicts when installed with a font manager and used in 
Quark? I'm getting scrambled font metrics and conflicts. I've used this font manager for years without 
any font conflicts. Why is this happening now? 

Reason 

Be advised that most of the popular font managment utilites were written before the advent of the latest 
Mac System software. 

As the Suitcase 3.0 manual states: "This kind of font problem happens when an application associates a 
font with an ID number that's different from the ID number used by the application that created the 
document. (Usually this happens with older applications that still track fonts by ID number...). Suitcase 
helps you avoid this kind of font problem by letting you export your font ID numbers into a font ID file 
and then letting you import this font ID file to another Macintosh running Suitcase." 
 
These products have two distinct approaches to handling font conflicts. Quark looks at the FOND 
resource ID of a font while Suitcase keeps track of fonts by their NFNT number. For most people, it 
would be impractical to follow the Suitcase manual's suggestion of creating a font ID file. 

 
The problem arises when you are opening, editing and creating fonts. There is great potential for font ID 
conflicts as various versions of a font are generated from the same database. 

Solution 

Bitmap font substitution on screen or font substitution on printer may be caused by several factors. The 
font may be corrupted, the installation may have a naming conflict, the bitmap ID may have a conflict or 
the printer may have an ID conflict. 

1  If strange things are happening or rectangles 
appear in the place of characters the font may be 
corrupted. See tech note 3735.  

2  Use Element>Font>Family Name to give the 
font a new name. Adding the word "New" to the 
front of the family name is a good way to avoid 
truncation as outlined in tech note 3723.  

3  If it's a PostScript font, play it safe by using 
File>Generate Fonts>Advanced and to change 
the PostScript ID number to "0".  

4  Since the main conflict with Suitcase occurs due 
to the screen FOND ID you should change the 
last two digits of the Bitmap Font to Output>ID 
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field to 99 (or something unique).  

5  Generate the font and install it by dragging it on 
TOP of the System folder. We are still in 
troubleshooting mode so we don't want to use a 
font manager to install this font.  

6  If the font works fine in Quark you should be 
able to delete all other versions and install the 
new font via your font manager. If the font works 
fine via the System install but fails when installed 
with Suitcase or Font Manager you will need to 
call the manufacturer for tech support.  

Additional Information  
Remember that Quark latches on to the FOND ID and will always expect a font with a particular FOND 
ID to be present in the document once the font has been used there. We can trick Quark by copying the 
document data into a new Quark document then highlighting and selecting only the new font with the 
new FOND ID. 

Suggestion: All of the above conflicts can be avoided by modern font management software. ATM 4 
Deluxe can manage font sets and will detect corrupt fonts and font ID conflicts. 

  

 

#13433: Crossover Chart for Cross-platform Characters 

Issue 

Which characters are used to build a cross-platform encoding vector? 

Solution 

Beginners who want to make their own custom encoding vector may want to use this chart as a good 
starting point. This chart contains the characters found in the template font mentioned in Creating 
Portable Fonts (TechNote 13365). Further help is found in Custom Encoding Tutorial (TechNote 13434). 

Notice the characters which have a place to land on either platform. It is important to know that the 
keystrokes will be different but the characters can be found if everything is done right. Also, note that 
there are several undefined ("notdef") characters which should be avoided. 

The purpose of this list is to illustrate: 

• How to know where a character will land on a particular platform. 
• You can't access characters which are not defined in your encoding vector. These characters will 

have ** in the label above the character slot. 
• Characters which aren't already defined by any known encoding vector (nor on this list) must be 

defined in a unique encoding vector. 
• Characters above 256 must be defined as Unicode characters. 
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For an understanding of platform support available for extended characters in Adobe fonts, see Adobe 
encoded characters in Windows (TechNote 13827). 

Character Crossover Chart 

Note: decimal slots 0 - 31 (often referred to as control characters) are not used on the Macintosh, but 
most are accessible on the Windows platform. Only the characters highlighted in bold type are accessible 
on both platforms. 

Character Name Macintosh - decimal  Windows 3.1- decimal  
Eth 1 not used 208 

eth 2 not used 240 

Lslash 3 not used notdef 

lslash 4 not used notdef 

Scaron 5 not used 138 

scaron 6 not used 154 

Yacute 7 not used 221 

yacute 8 not used 253 

Thorn 11 not used 222 

thorn 12 not used 254 

Zcaron 14 not used 142 

zcaron 15 not used 158 

onehalf 21 not used 189 

onequarter 22 not used 188 

onesuperior 23 not used 185 

threequarters 24 not used 190 

threesuperior 25 not used 179 

twosuperior 26 not used 178 

brokenbar 27 not used 166 

minus 28 not used 173 

multiply 29 not used 215 

DEL 127 notdef 127 notdef 

Adieresis  128 196 

Aring  129 197 

Ccedilla  130 199 

Eacute  131 201 

Ntilde  132 209 

Odieresis  133 214 

Udieresis  134 220 

aacute  135 225 

agrave  136 224 

acircumflex  137 226 

adieresis  138 228 

atilde  139 227 
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aring  140 229 

ccedilla  141 231 

eacute  142 233 

egrave  143 232 

ecircumflex  144 234 

edieresis  145 235 

iacute  146 237 

igrave  147 236 

icircumflex  148 238 

idieresis  149 239 

ntilde  150 241 

oacute  151 243 

ograve  152 242 

ocircumflex  153 244 

odieresis  154 246 

otilde  155 245 

uacute  156 250 

ugrave  157 249 

ucircumflex  158 251 

udieresis  159 252 

dagger  160 134 

degree  161 176 

cent  162 162 

sterling  163 163 

section  164 167 

bullet  165 149 

paragraph  166 182 

germandbls  167 223 

registered  168 174 

copyright  169 169 

trademark  170 153 

acute  171 180 

dieresis  172 168 

notequal 173 notdef 

AE  174 198 

Oslash  175 216 

infinity 176 notdef 

plusminus  177 177 

lessequal 178 notdef 

greaterequal 179 notdef 

yen  180 165 

mu  181 181 
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partialdiff 182 notdef 

summation 183 notdef 

product 184 notdef 

pi 185 notdef 

integral 186 notdef 

ordfeminine  187 170 

ordmasculine  188 186 

Omega 189 notdef 

ae  190 230 

oslash  191 248 

questiondown  192 191 

exclamdown  193 161 

logicalnot  194 172 

radical 195 notdef 

florin  196 131 

approxequal 197 notdef 

Delta 198 notdef 

guillemotleft  199 171 

guillemotright  200 187 

ellipsis  201 133 

nbspace  202 160 notdef 

Agrave  203 192 

Atilde  204 195 

Otilde  205 213 

OE  206 140 

oe  207 156 

endash  208 150 

emdash  209 151 

quotedblleft  210 147 

quotedblright  211 148 

quoteleft  212 145 

quoteright  213 146 

divide  214 247 

lozenge 215 notdef 

ydieresis  216 255 

Ydieresis  217 159 

fraction 218 notdef 

currency  219 164 

guilsinglleft  220 139 

guilsinglright  221 155 

fi 222 notdef 

fl 223 notdef 
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daggerdbl  224 135 

periodcentered  225 183 

quotesinglbase  226 130 

quotedblbase  227 132 

perthousand  228 137 

Acircumflex  229 194 

Ecircumflex  230 202 

Aacute  231 193 

Edieresis  232 203 

Egrave  233 200 

Iacute  234 205 

Icircumflex  235 206 

Idieresis  236 207 

Igrave  237 204 

Oacute  238 211 

Ocircumflex  239 212 

apple 240 notdef 

Ograve  241 210 

Uacute  242 218 

Ucircumflex  243 219 

Ugrave  244 217 

dotlessi 245 notdef 

circumflex  246 136 

tilde  247 152 

macron  248 175 

breve 249 notdef 

dotaccent 250 notdef 

ring 251 notdef 

cedilla  252 184 

hungarumlaut 253 notdef 

ogonek 254 notdef 

caron 255 notdef 

 

#13434: Custom Encoding Tutorial  

Issue  
Some keystrokes refuse to respond when a character is placed in a particular slot.  

Solution  
The first thing to do is check tech note 3713 (applies to Mac and PC) and make sure that the font was 
opened with its original encoding. If a particular encoding vector (found in the User Manual) has the 
needed characters then it's just a matter of opening with original encoding and generating with that 
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same encoding. The rule of thumb is that if the needed character can't be found in any of the provided 
encoding vectors then a custom encoding vector will need to be created.  

How to create a Custom encoding vector  
Background info on this subject is found in tech note 13314. Macromedia's Custom encoded template 
font can be used to jump-start a project with a database of characters which are common to Mac and PC. 
Further information is found in the Cross-platform Crossover Chart. 

First, make sure that you really need a Custom encoding vector 

PC Encodings  

The advantage of your own PC encoding vector is that Fontographer will display it in the Encoding pop-
up menu and, if you open with original encoding, will understand that it should leave your font alone. 
Custom encoded fonts should open with "Custom" displayed in the Element>Font Info>General dialog. 
"Custom" to Fontographer means "unknown". So, Fontographer is saying that it doesn't know this 
encoding but it will retain it for you if you generate with Custom. 

Mac Encodings  

The advantage of your own Mac encoding vector is that Mac Fontographer will automatically understand 
that your new characters are part of its database of definable characters. This facilitates the use of the 
Selection Info dialog and causes your encoding vector to appear in Fontographer's pop-up menus. Mac 
users will find instructions in the Fontographer folder's Addendum notes. 

If neither of the above advantages is necessary to your project (or you only need a few Unicode 
characters added to a font) then you should consider NOT making a Custom encoding vector -instead, 
create an OEM encoded font. Be advised that OEM fonts often become corrupted if the following 
procedures are not used. 

How to create an OEM Encoded font 

1  Open a new, empty font database.  

2  
Switch the Preview Encoding to OEM via Element>Font 
Info>General.  

3  
Paste characters in available slots and define them via 
Element>Selection Info.  

4  
Generate the font with "Custom" encoding. Install and 
test.  

Be advised that the characters you define via Step 3 will only be defined in the particular database which 
you are editing. When you define characters this way, Fontographer's internal database of known 
characters will not know where to put these characters. You will also note that the labels above the 
characters will usually be of no value. 

The ultimate solution would be for Fontographer to have a way of updating its internal database to 
include revisions every time the Unicode world is expanded. In the short term, please be advised that as 
long as the hidden glyph list is preserved, there is no need for the characters to be in a particular slot 
(other than a convenience). The keyboard driver will find the character regardless of which slot they 
occupy in a Fontographer database.  
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Quick start on PC Custom encoding  

PC users will find instructions in the "Using Fontographer" booklet which came in the box with the User 
Manual. In a nutshell . . .  

1  Open a new, empty font database.  

2  
Switch the Preview Encoding to Custom via 
Element>Font Info>General.  

3  
Paste characters in available slots and define them via 
Element>Selection Info.  

4  Use File>Save As to create a backup.  

5  
Use File>Export>Encoding to create a text file (example: 
myenc.enc).  

6  
Copy/paste the text from this file into the bottom portion 
of the fontog.enc file in the Fontographer folder.  

7  
Save the file in a text editor as text and with the name 
fontog.enc .  

The myenc.enc file will now be shown in the list of known encodings in Fontographer.  

Problem characters 

 Never use decimal 127 or 160 in PC fonts.  

 
There is no built-in keyboard support for ligatures on the 
PC.  

 

Some special characters may cause problems. The 
"fraction" character will be switched to another character 
on the PC. Symbol substitution characters may become 
switched by ATM, see tech note 12334.  

  

 

#13448: Editing the Underline Position and Width  

Issue 
Editing the Underline Position and Width does not always work. 

Reason  
The Element>Font Info dialog has data entry fields for the Underline Position and Width but the use of 
these parameters is application-specific. Not all applications read this information from a font. 

Underline Position and Width is an effect applied to a font much the same as bolding or italicizing the 
characters. The manipulation of font styling and effects is determined by application software which may 
ignore this information if it so chooses. 
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Typical misunderstandings 

 This information is valid for PostScript fonts only. 
This is not a feature of TrueType.  

 This information does NOT use or make changes 
to the Underscore character. 

  

 

#13449: Quick-Start PC to Mac Font Conversion 

Issue 

What is the fastest way to convert a PC font into a Mac font? 

Solution 

There are several factors which impact a successful font conversion. Here are some quick steps for the 
most popular conversions : 

PC Fonts 

 Make sure that you are not trying to open PC 
font files from a floppy. Drag the font to the Mac 
hard drive before attempting to open the font.  

 Always open fonts with their original encoding as 
outlined in tech note 3713. 

PC TrueType to Mac TrueType 

1  Select File>Open font  

2  If you don't rename the font it will overwrite the 
original one. 

If you would like to retain the original font along 
with the changed version, you must rename it so 
that they will have unique names. 

If you would like the new font to replace the 
original one, then renaming it doesn't matter, 
unless the font is a resident printer font. 
 
If desired, rename the font under Element>Font 
Info. 

3  Rehint font as outlined in tech note 3722.  

4  Select File>Generate 
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Fonts>Macintosh>TrueType. Set the Folder to 
anywhere but the System folder. Click Generate.  

5  Install the font.  

PC PostScript to Mac PostScript (requires ATM) 

1  Select File>Open font  

2  If you don't rename the font it will overwrite the 
original one. 

If you would like to retain the original font along 
with the changed version, you must rename it so 
that they will have unique names. 

If you would like the new font to replace the 
original one, then renaming it doesn't matter, 
unless the font is a resident printer font. 
 
If desired, rename the font under Element>Font 
Info. 

3  Import metrics as outlined in tech note 3715.  

4  Select Element>Recalc Bitmaps and make only a 
9 pt. bitmap. ATM will create other sizes as 
needed.  

5  Select File>Generate Fonts>Macintosh>PostScript 
Type 1. Set the Folder to anywhere but the System 
folder. Click Generate.  

6  Install the font.  

PC PostScript to Mac TrueType (same as above except no bitmaps needed). 

PC TrueType to Mac PostScript (same as above except for Step 3). 

  

 

#13450: Quick-Start Mac to PC Font Conversion 

Issue 

What is the fastest way to convert a Mac font into a PC font using Fontographer for Mac? 

Solution 

There are several factors which impact a successful font conversion. Here are some quick steps for the 
most popular conversions : 
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PC Fonts 

 Always open fonts with their original encoding as 
outlined in tech note 3713.  

 Most users will have no need for screen fonts on 
the PC. Avoid creating any if you can. If you must 
create screen fonts, see tech note 3716 and tech 
note 12561.  

Mac TrueType to PC TrueType 

1  Select File>Open font  

2  Rename under Element>Font Info 
(recommended) 

3  TrueTypes often have RAM problems on the PC. 
Play it safe by using tech note 3710 to insure that 
the font will have enough RAM.  

4  Select File>Generate Fonts>PC>TrueType. Set the 
Folder to anywhere but the System folder. Click 
Generate.  

5  Install the resutling .ttf font file via the Windows 
Font Control Panel.  

Mac PostScript to PC TrueType (same as above). 

Mac PostScript to PC PostScript (requires ATM) 

1  Select File>Open font  

2  Rename under Element>Font Info 
(recommended). 

3  Import metrics as outlined in tech note 3715.  

4  Select File>Generate Fonts>PC>PostScript Type 
1. Set the Folder to anywhere but the System 
folder. Do NOT create screen fonts for the PC. 
Click Generate.  

5  Install the font via ATM on the PC.  

Mac TrueType to PC PostScript (same as above except for Step 3). 
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#13475: Improper Screen Font Display on Macintosh 

Issue 

After opening an existing font and re-generating it, the screen fonts look terrible. 

Reason 

TrueType 

TrueType fonts will contain more points on the curves than the original drawings. The method for 
building curves in TrueType uses quadratics. This requires an oval that would contain four points at 
extrema to have eight points when generated as TrueType. Since Fontographer is a PostScript drawing 
environment, anytime you open or generate a TrueType font, its goes through this conversion of 
PostScript paths to quadratics, or vice versa. Once the path is built optimally for TrueType quadratics, 
there will be no more shifting of the points during the conversion process. 

Even though TrueType fonts do not require screen fonts they are often found inside of a TrueType 
suitcase. The screen fonts won't look right if a font is generated with automated Fontographer bitmaps 
and they are compared to the originals. It may be necessary to create a hand-edited bitmap at each 
point size required. 

Another part of the problem is that Fontographer currently does not preserve all of the existing hints as it 
opens a font. Rehinting with Fontographer hints is not guaranteed to create a font of the same quality as 
the original. 

PostScript 

When comparing an original font to a newly generated font there are some things to consider. The 
original font most likely had hand-edited screen fonts. If these aren't imported then the font will not 
look like the original. Importing the metrics also has a great effect on the final output. 

Whenever possible, allow ATM to create screen fonts. Generate the font with a 9 pt. bitmap (the System 
requires that there be one size in order to install the font). ATM will create the rest of the sizes as 
needed. 

Solution 

Always observe the following guidelines in order to prevent this from happening: 

1. Use File>Import>Metrics>Ascent/Descent in order to make sure that the font's original metrics 
are available. See TechNote 3715 for more details. 

2. When opening existing fonts be sure to use File>Import>Bitmaps to take advantage of any 
screen fonts which are available. 

3. Fonts made from scratch may have a bad appearance due to improper hinting. See TechNote 
3718 and 3722. 

4. If the project requires that a change be made to one of the characters then (after importing the 
bitmaps) use Window>open Bitmap Window to display the bitmap for that slot. Use the "Recalc 
from Outline" button to cause the bitmap to reflect the changes you made to the outline. Never 
use Element>Recalc Bitmaps because it will overwrite all original bitmaps with Fontographer-
derived ones. 
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5. Finally, when hand-editing bitmaps, always use the "Recalc from Outline" button inside the 
Bitmap Editor before performing any edits. 

 

#13628: Reserved characters in modern Windows encoding  

Issue  
Unable to use decimal slots 128, 142 and 158 in font encoding. 

Solution  

Do not use these slots for encoding fonts which are used under Windows 98 or Windows 2000 

These slots have always been reserved (see tech note 3700) but we have traditionally been able to 
kludge a font's encoding via OEM encoding procedures. 
 
Windows 98 and Windows 2000 (NT5) now enforce the reservation of these characters. In other words, 
previous versions of Windows winked at this but the party is over! 
 
First of all, 128 is now used for the Euro character. 

Secondly, OEM always was a kludge which came out of the Windows 3.x era. Those days are gone 
forever. 

In the past we have listed 127, 128, 129, 141, 142, 143, 144, 157, 158, 160 as reserved characters 
which are not defined by any Windows encoding vector. We used to tell users that they COULD cheat 
and recover all of these characters EXCEPT for 127 and 160 via OEM encoding. 

Fontographer can no longer guarantee the behavior of any of these characters when used in OEM or 
Custom encoded fonts under Windows 98 or Windows 2000. All characters which fall into the previous 
"reserved" area of Windows encodings are subject to being used by the newer operating systems. 

  

 

#13629: Macintosh Fontographer screen redraw problems 

Issue 

 
Fontographer exhibits screen redraw problems under Macintosh OS 8.0 and above. They are usually 
manifested as the cursor leaves trails of itself in some text entry fields. 

Reason 

 
Fontographer is showing its age! Apple has made improvements to the OS which are not backward 
compatible with the versions which were current at the time of the most recent Fontographer revision. 

Solution 
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At the time of this writing, several workarounds have surfaced. Be advised that these workarounds may 
not resolve the issue on a particular machine. Here are some of the things which have worked for other 
Fontographer users: 

1  Download and install the latest version of the 
Macintosh Appearance Manager from Apple's 
web site.  

2  Delete the Charcoal font. Save a backup copy of 
the font for future use. 

3  Restart with extensions off and/or disable any 
third party video Control Panels which are 
installed. 

Try installing an older or newer version of any 
third party video drivers. 

Some users have reported that removing the PCI 
Desktop Control Panel resolved the problem. 

 

#13694: Kerning characters above decimal 256  

Issue How can characters above decimal 256 be kerned? 

Solution Characters decimal are accessed via Unicode. The following steps can be taken to create 
Unicode kerning pairs: 

1  Select Windows > Open Metrics Window and enter any 
character in the Text entry field as a placeholder.  

2  Insert the cursor into the CHAR field in the cell at the bottom 
of the Metrics Window.  

3  Type 652, or any decimal designator for the desired character.  

4  Now, type a second character's decimal equivalent in the cell 
to the right of the first one.  

5  Click on the second character's glyph above the cells. The LKR 
lines will appear for that character.  

6  Drag the "K" line (be careful not to drag the glyph) to the left 
in order to manually kern the character.  

Additional Information  
Be advised that many printer drivers and applications do not perform Unicode kerning. 

In order to view your kern pairs make sure that you have kerning turned ON in your application. 
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#13719: Missing FPU error message  

Issue  
"Missing FPU" message is displayed when installing Fontographer 4.0.x to a Power PC. 

Reason  
This msg is caused by installing the FPU version of Fontographer on a Power PC . The Power PC has an 
FPU which is integrated into the CPU. The Fontographer FPU version is expecting an old style FPU which 
was an optional chip popped into a socket on the motherboard. Thus, Fontographer FPU versions are 
incompatible with PPC motherboards. Fontographer 4.1 has native Power PC code. 

Solution  
If you want to use your FOG 4.0.4 you will have to do a custom install of the NON-FPU version. Both 
versions came on your Fontographer disks. Use the "Custom" pop-up ,menu in the installer and select 
Fontographer NFPU. you can drag the Fontographer NFPU icon on top of your hard drive icon inside of 
the installer. 

 

#13725: PostScript Type 3 font tutorial  

How to create a Grayscale PostScript Type 3 font 

It is possible to create "stroked" fonts (fonts which consist of a single open path) for PostScript Type 3 
format. These fonts can also have normal closed paths and a percentage of grayscale fill. 

Keep in mind that this font format is designed for the printer and will not be recognized by ATM. The 
screen output of a PostScript Type 3 font is very blocky and ugly. 

1  Use Edit>Select All to select all characters in the 
Font Window.  

2  Go to Element>Selection Info and turn Fill off and 
Stroke ON.  

3  Set the tint of the stroke to the level of gray that 
you want.  

4  Go to generate fonts and select PostScript Type 3 
as the kind of font you want to generate.  

Additional Information 

PostScript Type 3 fonts don't have to have grayscale tints. A normal PostScript Type 1 font could be 
generated as a Type 3. Sometimes a hinting problem (which manifests itself as a bad display or poor 
quality print job) can be eliminated by generating the font as a Type 3. 

PostScript Type 3 fonts on PC and Unix machines have a .PFA extender. These fonts are also referred to 
as ASCII fonts. 

Fontographer can only open PFAs which were made in Fontographer. 
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#13827: Adobe encoded characters in Windows  

Issue  
Adobe encoding is used whenever possible for cross-platform fonts and documents. However, there are 
some characters which are found in Adobe encoding which will not be available on a given platform. 

Reason  
Many font vendors use Adobe Standard Encoding because it enables the fonts to work on multiple 
platforms. Such fonts generally contain a superset of all characters needed for the Windows ANSI 
character set, but only a subset of those are actually encoded as the font comes from the vendor. When a 
font with Adobe encoding is installed in a user's system, Adobe Type Manager (ATM) and the Windows 
PostScript print driver both re-encode the font to match the Windows ANSI character set. 

When you open a font that uses Adobe encoding, in Fontographer, using original encoding, you will see 
only the subset of characters in the Adobe Encoding show up in slots 32 - 256, and the other unencoded 
characters will be shown in slots above 256. Yet when this font is used, it is re-encoded by ATM and the 
driver, so the font is not used with the same encoding that you see when you open it in Fontographer. 

Solution  

If the character you wish to use is listed in the first section of the chart below, you only need to leave the 
font as is, and use the keystroke shown in the chart. 

If the character is listed in the Exceptions chart at the bottom of this page and there is no keystroke listed 
for it, you may want to place the character in an unused character position (say the yen character), and 
give the font an alternate name. This will enable you to access characters that you otherwise may not be 
able to use, but it has the disadvantage that the alternate font may not work cross-platform, and 
operations such as spell checking will not work for those characters. 

Most of these characters in question have diacriticals and are keystroked by using the normal keystroke 
for a given platform encoding. For example, the adieresis ( ä ) is not found in Adobe encoding but it IS 
found at the bottom of an Adobe font. It is keystroked on the Macintosh by using Option-u-a or the 
same keystroke used for Macintosh encoding. 

The adieresis is found at decimal slot 228 in Windows encoding so it is keystroked on the PC by holding 
down the Alt key and using the numeric keypad to type Alt-0228. The keystroke can be found by 
looking at the following chart or the Windows encoding vector in the Fontographer User Manual. 
Keystrokes can also be found by viewing the font in the Windows Character Map accessory. 

Unencoded Characters Chart  

Adobe 
Encoded Slot  

Character 
Name  

Character  Windows 
Keystroke  

Macintosh 
Keystroke  

unencoded  Ydieresis  Y ̈  159  Option-u-Y  

unencoded  trademark  � ¢  153  Option-2  

unencoded  zcaron   158  Control-o  

unencoded  Zcaron   142  Control-n  
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unencoded  scaron   154  Control-f  

unencoded  Scaron   138  Control-e  

unencoded  ydieresis  ÿ  255  Option-u-y  

unencoded  thorn   254  Control-l  

unencoded  yacute   253  Control-h  

unencoded  udieresis  u ̈  252  Option-u-u  

unencoded  ucircumflex  u ̂  251  Option-i-u  

unencoded  uacute  ú  250  Option-e-u  

unencoded  ugrave  u ̀  249  Option-`-o  

unencoded  divide  ÷  247  Option-/  

unencoded  odieresis  o ̈  246  Option-u-o  

unencoded  otilde  o ̃  245  Option-n-o  

unencoded  ocircumflex  o ̂  244  Option-i-o  

unencoded  oacute  o ́  243  Option-e-o  

unencoded  ograve  o ̀  242  Option-`-o  

unencoded  ntilde  n ̃  241  Option-n-n  

unencoded  eth   240  Control-b  

unencoded  idieresis  ï  239  Option-u-i  

unencoded  icircumflex  î  238  Option-i-i  

unencoded  iacute  í  237  Option-e-i  

unencoded  igrave  i ̀  236  Option-`-i  

unencoded  edieresis  ë  235  Option-u-e  

unencoded  ecircumflex  ê  234  Option-i-e  

unencoded  eacute  é  233  Option-e-e  

unencoded  egrave  è  232  Option-`-e  

unencoded  ccedilla  c ̧  231  Option-c  

unencoded  aring  a ̊  229  Option-a  

unencoded  adieresis  ä  228  Option-u-a  

unencoded  atilde  ã  227  Option-n-a  

unencoded  acircumflex  â  226  Option-i-a  

unencoded  aacute  á  225  Option-e-a  
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unencoded  agrave  à  224  Option-`-a  

unencoded  Thorn   222  Control-k  

unencoded  Yacute   221  Control-g  

unencoded  Udieresis  Ü  220  Option-u-U  

unencoded  Ucircumflex  Û  219  Option-i-U  

unencoded  Uacute  Ú  218  Shift-Option-;  

unencoded  Ugrave  U ̀  217  Option-`-U  

unencoded  multiply   215  Control-]  

unencoded  Odieresis  Ö  214  Option-u-O  

unencoded  Otilde  Õ  213  Option-n-O  

unencoded  Ocircumflex  Ô  212  Shift-Option-j  

unencoded  Oacute  Ó  211  Shift-Option-h  

unencoded  Ograve  Ò  210  Shift-Option-l  

unencoded  Ntilde  Ñ  209  Option-n-N  

unencoded  Eth   208  Control-a  

unencoded  Idieresis  Ï  207  Shift-Option-f  

unencoded  Icircumflex  Î  206  Shift-Option-d  

unencoded  Iacute  Í  205  Shift-Option-s  

unencoded  Igrave  i ̀  204  Option-`-i  

unencoded  Edieresis  E ̈  203  Option-u-E  

unencoded  Ecircumflex  E ̂  202  Option-i-E  

unencoded  Eacute  E ́  201  Option-e-E  

unencoded  Egrave  E ̀  200  Option-`- E  

unencoded  Ccedilla  C ̧  199  Shift-Option-c  

unencoded  Aring  Å  197  Shift-Option-a  

unencoded  Adieresis  A ̈  196  Option-u-A  

unencoded  Atilde  Ã  195  Option-n-A  

unencoded  Acircumflex  Â  194  Shift-Option-m  

unencoded  Aacute  Á  193  Shift-Option-y  

unencoded  Agrave  A ̀  192  Option-`-A  

unencoded  mu  μ  181  Option-m  
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unencoded  plusminus  ±  177  Shift-Option-=  

unencoded  degree  °  176  Shift-Option-8  

unencoded  registered  ®  174  Option-r  

unencoded  logicalnot  ¬  172  Option-l  

unencoded  copyright  ©  169  Option-g  

unencoded  brokenbar   166  Control-[  

unencoded  minus   173  Control-\  

unencoded  threesuperior   179  Control-y  

unencoded  twosuperior   178  Control-z  

unencoded  onesuperior   185  Control-w  

unencoded  threequarters   190  Control-x  

unencoded  onehalf   189  Control-u  

unencoded  onequarter   188  Control-v  

Exceptions Chart  
 
The chart below displays some exceptions to this rule. These characters can be typed in Macintosh 
applications (except for the Control characters) but will not appear in a Windows document. Since these 
characters don't exist in Windows encoding, there is no keystroke available. 

Adobe 
Encoded Slot  

Character 
Name  

Character  Windows 
Keystroke  

Macintosh 
Keystroke  

164  fraction   none  Shift-Option-1  

174  fi   none  Shift-Option-5  

175  fl   none  Shift-Option-6  

193  grave  `  Alt-0096 
substitutes  

` 

198  breve   none  Shift-Option-.  

199  dotaccent   none  Option-h  

202  ring   none  Option-k  

205  hungarumlaut   none  Shift-Option-g  

206  ogonek   none  Shift-Option-x  

207  caron   none  Shift-Option-t  
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232  Lslash   none  Control-d  

245  dotlessi   none  Shift-Option-b  

248  lslash   none  Control-d  

Additional information 

Be advised that Control character keystrokes may not be available in some Macintosh applications. 

#13846: Using FreeHand 8 with Fontographer 4.1  

How is FreeHand typically used with Fontographer ?  

Some designers are more comfortable with the editing tools in FreeHand. Thus, they often prepare 
artwork or character shapes in FreeHand to be brought later into Fontographer. 

On Windows, vectors from FreeHand need to be exported as an Adobe 1.1 EPS format to work in 
Fontographer. The clipboard will not work for vectors but it can used to bring pixels into Fontographer 
for tracing. 

What FreeHand features can I use with Fontographer ? 

 FreeHand can be used to trace a TIFF of a signature or logo 
destined for Fontographer.  

 The following tools in FreeHand can be used to create dynamic 
logos or dingbats in Fontographer: 3D Rotate, Mirror, Fisheye, 
Text on a Path, Blend, Divide, Union, Punch, Intersect, 
Envelope, Flow inside Path, Variable Stroke, Calligraphic Pen, 
and FreeForm.  

 Many more effects could be achieved if Kai's Vector Tools are 
used in FreeHand and the results brought into Fontographer. 

 Vector editing is used by people who are more used to 
FreeHand but this can be counterproductive when designing 
Roman characters. Complications arise in maintaining cap 
height, x-height and stem/serif widths. Also, too many points 
can create an overly complex path which is not tolerated well 
by the TrueType rasterizer nor the PostScript interpreter.  

 Vector effects can become a character in a font in 
Fontographer. As above it wouldn't be a good idea to use 
effects (roughen, smudge) which add extraneous points.  

 It's a given fact but still to be appreciated that Fontographer 
gives the user the power to customize fonts which can then be 
used to greatly enhance a FreeHand document's page layout 
and overall appearance.  

What are the best copy/paste formats? 
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Windows  BMP is the only clipboard format that works on 
Windows but the resolution will affect the outcome of 
the character trace. 

Macintosh  The Option Copy -Paste, Option Copy -Shift Paste to 
constrain keyboard strokes work on the Macintosh to 
copy from FreeHand to Fontographer. 

What export/import formats should I use?  

The Adobe Illustrator 1.1 EPS format should be used to export from FreeHand for Fontographer. 

Is there anything else I should know?  

 Fontographer was the first vector editing 
application in the world.  

 Many of the fonts made in modern font libraries 
were made with Fontographer. 

 The fonts which come on the FreeHand CD were 
made by Fontographer.  

  

 

#13916: Unable to Copy/Paste from FreeHand to Fontographer  

Issue Can't see pasted image when using clipboard from FreeHand to Fontographer. 

Reason  
The native format for the Macintosh clipboard is PICT. The problem occurs when the FreeHand Export 
preferences do not have the PICT option checked. 

Solution  
Make sure that the FreeHand Export preferences have the PICT option checked. 

Also, FreeHand clipboard images will be pasted into Fontographer with a 0% fill. In order to fix this 
problem: use Select All and then go to Element>Selection Info and make sure that the fill is 100%. 

 

#14298: The easy way to generate a font with Fontographer for 
Windows  

Here are some quick steps for generating fonts: 

1  When the font is ready to generate, go to Element > Font Info 
> General menu. 
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2  Be sure to give the font a unique name under the Family Name 
field. 

3  Use File > Save As... to create a backup *.fog database of the 
font for future use in creating different versions. This file is NOT 
a font. It is a backup database of raw materials which can be 
used to create a font. 

4  Select File > Generate Font Files > Easy. This is the dialog box 
which actually makes the font. 

 

5  Under "Type of font to generate" select PostScript or 
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TrueType. Do NOT select any bitmap sizes when creating 
fonts for Windows (PC). 

6  Use the "Set Directory" button to make sure your Output 
Folder is not set to the Windows System Folder. Set it to a 
work folder. 

7  Click the Generate button. 

8  Install TrueType fonts by using Start > Settings > Control 
Panel > Fonts. For PostScript fonts use Adobe Type Manager 
to install fonts.  

  

 

#14314: Common questions about Fontographer  

Creating Portable Fonts (TechNote 13365). 

Scanning and Autotracing in Fontographer (TechNote 03711). 

How do I convert Mac fonts to run on my PC? (TechNote 12322) for more details . 

Can it create non-English language fonts? 
Unicode fonts can be created by plugging the Unicode name and number into a font database. If the 
user has the right keyboard driver for that language, the characters will be found and displayed properly. 
This is a tricky process and may require Fontographer on both platforms to set up fonts for optimal use 
in non-English operating systems. 

Can Fontographer create 2-byte fonts?  
Fontographer cannot generate or open 2-byte fonts. These fonts (also called CJKV) are used in Chinese, 
Japanese, Korean and Vietnamese. CJKV fonts require two keystrokes to display a character, therefore the 
user needs some type of input method (IME) in order to enter keystrokes. Fontographer does not 
provide this functionality. 

#15218: Adobe fonts do not show the proper bitmaps after 
importing bitmaps  

Issue  
After importing the bitmaps for an Adobe Standard encoded font, the bitmaps do not match the outline 
for a particular character slot. 

Reason All bitmaps on a Macintosh are Macintosh encoded. Adobe Standard Encoding is only for the 
printer. 

Solution To ensure that the Bitmap Editor matches the bitmaps correctly to the outlines, follow the steps 
below: 

1  Choose File > Preferences.General preferences under File > Preferences so 
that the font will be opened with original encoding.  
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2  Choose General preferences.  

3  Select Use Macintosh encoding to choose the character under When the user 
types a key to choose a character.  

4  Select Keep the font's original encoding under When reading an outline font, 
as indicated in the illustration below: 

 

5  Choose File > Open Font to open the font. 

6  Choose Element > Font Info. 

7  In the Encoding pop-up menu, choose Macintosh. This sets the encoding for 
the Preview mode.  

8  Click OK.  

9  Choose File > Import > Bitmaps.  

10  In the box at the top, navigate to find the folder which contains the font 
from which you wish to import the bitmaps.  

11  Click the name of the font to select it. 

12  In the Import into pop-up menu, choose Internal bitmap list.  

13  Select Overwrite existing information.  

14  Click Open.  

15  Select a bitmap in the Select a Bitmap dialog box.  

16  Click OK.  

17  To verify whether your bitmaps match your outlines, select a character by 
clicking in a character slot.  

18  Choose Windows > Open Bitmap Window.  

19  In the Bitmap Window you will be able to see whether the bitmaps reflect 
the character outlines, as demonstated below. 
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Note: Be sure to import kerning and spacing at this time as well. See the Metrics: Spacing and Kerning 
chapter in the Fontographer User's Manual and Importing Font Metrics into Fontographer 4.1 (TechNote 
3715). 

When you generate the font, you will want to return to Adobe Standard encoding. To do this: 

1  Choose File > Generate Font Files.  

2  Select Advanced. 

3  In the Encoding pop-up menu, select Adobe Standard. 

4  Make other choices to finish generating the font. See the 
Generating & Exporting Fonts chapter in the Fontographer User's 
Manual for more information about font generation.  

  

 

#15282: Serial number not accepted 

My serial number won't work during installation or during product registration 

Most Macromedia serial numbers are 21 digits, beginning with three letters and followed by a series of 
numbers separated by dashes. Older versions, including Fontographer prior to 4.1.5, may have different 
formats. 

RoboHelp, RoboDemo, RoboInfo, RoboPDF, RoboScreenCapture typically have serial numbers 13 
to 25 digits long. For RoboHelp Office products the digit after the RH or R is always the letter O, which 
stands for office, not a zero. These may be referred to as license keys in some contexts. 

Upgrades  
If you have just upgraded to a new version of the software, make sure you are entering the new serial 
number. Each upgraded version of Macromedia software comes with a new number. 
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Exceptions: 

• If you are installing the upgrade to Studio MX +, use the same serial number as Studio MX. 
• If you are installing the ColdFusion MX Developer Edition included with Studio MX, you do 

not need to enter a serial number. Leave this field blank and continue to the next screen to 
install. 

More tips to ensure that the serial number is entered successfully 

• Make sure that you are entering zeros (0) rather than the letter O (except in the case of 
RoboHelp Office, as indicated above). 

• Make sure all letters are capitalized. 
• Make sure Caps Lock , and any other command keys, are off. Use the Shift key to capitalize the 

letters, and the number pad for all numbers and dashes. 
• If you have a single serial number field enter the dashes between each set of numbers 
• If you see four fields for the serial number, do not enter the dashes, only each set of letters and 

numbers. 
• On an older version, verify that the number is the same on both the bottom of the box and the 

registration card. 
• When installing an upgrade, the installer will first ask for the serial number for the version being 

installed. Then it will ask for the number from which you are upgrading. Be sure to enter the 
correct numbers in each of these fields. 

• When installing under Windows 2000 or Windows NT, the user must be logged on as a Power 
User or Administrator. 

Note: If you are having difficulty finding your serial number, please see Finding serial numbers. 

Write your serial number in your User Manual. It should be kept in a convenient location so it will be 
easy to access when contacting Customer Service or Technical Support. 

 

#15460: Creating a non-Unicode font with international character 
shapes  

Issue  
Some applications are not fully Unicode compliant. Unicode fonts using international characters will not 
function properly in these applications, even if a Unicode keyboard driver is installed. 

Workaround 
One solution to this limitation is to use Fontographer to create a non-Unicode font that substitutes 
international characters for English characters. Because the resulting font has international characters 
placed in the ASCII range of the font, a Unicode keyboard driver is not required to access these 
characters. 

For more information about the ASCII range of characters, refer to ASCII, ANSI, alphanumeric and 
special characters in Dreamweaver (TechNote 15338). Basically, the ASCII range of characters are those 
displayed on the keyboard keys. 

This TechNote offers streamlined and simplified steps to create such a non-Unicode TrueType font with 
international characters shapes. After installing the new font, you will be able to bring the international 
character shapes into non-Unicode enabled programs such as Flash and Fireworks. 
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Creating a non-Unicode font with international character shapes  

1  Copying the character shapes  
Choose File > Open Font. 

2  Under Directories on the Open Font dialog box, browse to locate a folder that 
contains a Unicode font. Double-click the folder name to open it. 

3  Under File Name, select the Unicode font. The font's file name will appear directly 
under the File Name box (see Example 1).  

4  Click OK. This will open the font in Fontographer. 

  

 

5  Choose Edit > Select All.  

6  Choose Edit > Unlink Reference. (This will prepare the character outlines for copying 
and pasting.)  

7  Scroll to find the international characters or the group of characters you wish to copy 
and paste into a new font.  

8  Click in the character slot for the first character you wish to copy. Shift-click to select 
other characters simultaneously (see Example 2).  

9  Choose Edit > Copy. To avoid confusion, you will probably want to minimize this 
Font Window.  

10  Pasting into a new font  
Choose File > New Font. This will open a new, empty Font Window.  

11  Click the "!" (Decimal 33) character slot (see Example 3) to select it. (You can click 
another character slot if you desire; however, you should keep all your pasted 
character shapes in the ASCII range (starting with the "!" character [Decimal 33] and 
ending with the "`" tilde character [Decimal 126].) 

Note: If you have more than 93 character shapes that you wish to use, you may need 
to create more than one font. 

12  Choose Edit > Paste. This will paste all the characters you copied earlier into 
consecutive character slots (see Example 4).  

13  Write down which international character shapes pasted into which character slots. 
This information will later tell you which key on the keyboard you need to press to 
bring a particular character into your text editor.  

14  Naming your new font  
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Choose Element > Font Info > General (Element > Font Info for Macintosh).  

15  On the Font Information dialog box, name your new font in the File Name box (see 
Example 5). Consult Troubleshooting font names (TechNote 3723) for more 
information about naming issues.  

16  Click OK.  

17  Saving the database file  
Choose File > Save As. This opens the Save dialog box. Now you will save your 
original database file, which will have a .fog extension. If, at some point in the future, 
you wish to modify this font you can reopen this FOG file and then regenerate a new 
font. The FOG file is not the font that you will eventually install in your system. 
(Instructions to create the actual font are below.)  

18  On the Save dialog box, browse in the Directories box to select the folder into which 
you wish to preserve your FOG database file (see Example 6). By default, the font's 
name will appear under File name with the .fog extension. You can change the name 
of the database file. Do not save your FOG database file in your Fontographer 
application folder.  

20  Click OK.  

21  Generating the new non-Unicode font  
Choose File > Generate Font Files. This activates the Generate Font Files dialog box 
(see Example 7).  

22  Select the Easy option.  

23  For Computer, select PC for a Windows font. Select Macintosh for a Macintosh font. 

Note: Cross-platform issues are beyond the scope of this TechNote. Unless you are an 
advanced Fontographer user, you should only create fonts for the platform you have 
Fontographer installed on. 

24  For Format, select TrueType.  

25  Leave the Bitmap sizes to output option blank.  

26  Click Set Directory (Set Folder for Macintosh) to locate the folder into which you will 
store the font. Make sure your output folder is not set to the Windows System folder. 
Selecting a folder to put your generated font in is not the same thing as installing the 
font (instructions to do so are below). Do not save your generated font into your 
Fontographer application folder.  

27  Click Generate.  

28  Installing the font  
Consult the following TechNotes for instructions on the proper way to install fonts, 
according to your platform:  

 Font installation in Windows (TechNote 3649)  

 Font installation on the Macintosh (TechNote 
3648)   

29  Once your non-Unicode Font is properly installed on your system, you can access its 
character shapes in a text editor or a graphics program with text editing capabilities, 
such as Fireworks (see Example 8) or Flash.  
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Conclusion 
After the font is installed, the user can press the letter "A" and a Unicode character will appear in the text 
editor rather than an ASCII "A." The US English keyboard is all that is needed in order to display the 
chosen character shapes. 

Note: Although the resulting font will not be Unicode-compliant, the characters can be typed and 
displayed in any application regardless of its level of Unicode support. 

Additional information  
For more information about the Unicode Standard, see What is Unicode and how does it work? 
(TechNote 15464). 

  

 

#15464: What is Unicode and how does it work?  

What is Unicode? 
The Unicode Standard, developed by the Unicode Consortium, is a universal character encoding standard 
used for representation of text for computer processing. The current version (3.1) of the Unicode 
Standard assigns a unique identifier to each of 94,140 characters, covering the scripts of the world's 
principal written languages as well as many mathematical and other symbols. 

The Unicode Standard enables a computer's operating system to utilize a single font which may contain 
characters representing dozens of language scripts, such as German, Cyrillic or Chinese. The unique 
identifier for a character is used by the input program (keyboard driver), the computer operating system, 
the text processing program and the font to display the character on the computer screen. 

Not all software applications or fonts are Unicode enabled. When the text processing application has not 
been configured to understand or recognize a Unicode identifier presented to it (by someone pressing a 
key on a keyboard set to present the identifier), then the computer screen will not display the character. 
Instead of the character, the computer screen will perhaps display the wrong text, a question mark or a 
rectangle.  

Code pages  
An explanation of "code pages" will assist you in understanding the Unicode Standard and how it 
functions with operating systems, fonts and applications. Generally, Latin-based operating systems can 
only display the first 256 characters of a given language script. Unicode fonts can be thought of as 
having "sets" of 256 characters called "code pages." Some fonts may have characters from multiple sets 
of code pages. When you switch the keyboard to another language you are toggling another code page 
so that the keyboard is remapped to a different set of 256 characters. 

The process of displaying Unicode characters  
The process of displaying a character on a computer monitor's screen begins when a key is typed on the 
keyboard. Based on the selected code page for that keyboard, the keyboard driver finds the desired 
character by searching for that character's Unicode number in the font. The host application displaying 
the text must understand the font's Unicode range and the keyboard's code page designation in order to 
display the Unicode character (originally called up when the user pressed a key on the keyboard). 

How does Unicode work in Windows?  
Below are several factors which work together to successfully display a Unicode font in a given 
application on Windows: 
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 A Unicode font (one having Unicode-defined character names 
and corresponding Unicode numbers) must be installed. 

 An application that is compatible with Unicode keyboard 
drivers must be running.  

 A Unicode keyboard driver must be installed in the operating 
system. Language scripts are accessed by switching to an 
international keyboard on the taskbar. The default for US 
English Windows will be displayed as EN on the Windows 
taskbar. Click EN to activate a list of installed keyboards. 

Note: Additional international keyboards can be installed using 
the Start Button to navigate to Settings > Control Panel > 
Keyboard. Use the Input Locales tab to add additional 
keyboard drivers from Microsoft's Multilingual Support 
Package. 

Troubleshooting 
Some reasons why a Unicode font might not work in a given application are: 

 The application may not recognize the range of 
Unicode or code pages in a particular keyboard 
driver.  

 The font may not have the code page or Unicode 
characters properly defined. 

 The user may not have the proper keyboard 
driver installed. 

 HTML files may not have the code page 
(Character Set) defined properly or the browser 
preferences may not be set to display the proper 
code page.  

Additional information  
For more information about the Unicode Standard, see: 

  The Unicode Home Page.  

  What is Unicode?  

For more information about the Unicode Standard and Macromedia applications, see: 

  Fontographer  

  Defining Unicode Characters (TechNote 8174)  

  Setting TrueType parameters for Unicode Fonts (TechNote 
12333)  

  Master List of International Keyboard Layouts (TechNote 13228)  

  Creating a non-Unicode font with international character shapes 
(TechNote 15460)  

http://www.unicode.org/
http://www.unicode.org/unicode/standard/WhatIsUnicode.html
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  Flash  

  Flash does not support the Unicode Standard (TechNote 15412)  

  Fireworks  

  Some Cyrillic fonts do not display correctly in Fireworks 
(TechNote 15169)  

  

 

#15709: Windows 30202 Error in Fontographer 

Issue 

Fontographer crashes with a -30202 error in Windows NT or Windows 2000 

Reason 

There have been a few reports of this error which we have not been able to reproduce. The only 
evidence that has surfaced is that the error is related to an internal problem with the operating system. 
The -30202 error is listed among Microsoft's error messages as "an invalid 16 bit application is installed. 
The Vdd registry entry is invalid." Fontographer is a 32 bit application and there is nothing 16 bit that 
Fontographer is installing. 

There is a strong possibility that the error message is bogus. In reality, the problem seems to be a RAM 
allocation issue. 

Solution 1  
Our suggestion is that you edit the Virtual Memory settings in order to function with Fontographer's 
older memory management. 

Macromedia cannot offer tech support on how to set Virtual Memory for your machine. For detailed 
instructions on Virtual Memory settings see Microsoft tech note Q259184. 

Use Microsoft's tech note to navigate to Settings > Control Panel > System > Advanced and then select 
the Performance Options button and then the Change button under the Virtual Memory group. Most 
users have been successful while using settings of 500mb for Initial and 500mb for Maximum. The most 
likely reason is that Fontographer was written before the large memory models used today were 
available. 

Set the Initial and Maximum sizes both to the same value. It is recommended that you select a 
partitioned drive, if one is available and has sufficient free disk space.. 

Be sure to click on the Set button to apply the new settings. 

Restart your machine and attempt to run Fontographer. If Fontographer runs, your next challenge will be 
to see if the smaller Virtual memory setting affects the performance of other applications. If this is the 
case, you will need to use the new settings when using Fontographer and create a Hardware Profile to 
restart the machine with the old settings for running your system normally. 

If you still get the -30202 error, try Solution 2 as listed below. 

http://support.microsoft.com/support/kb/articles/Q259/1/84.ASP
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Solution 2  
Some users who have reinstalled Windows and then reinstalled Fontographer in Safe Mode or NT VGA 
mode have been able to work around this problem. 

Try reinstalling Fontographer in Safe Mode. 

1  Start > Settings > Control Panel > Add/Remove - use this 
control panel to remove Fontographer - do NOT drag 
Fontographer to the trash. If there is a message stating that 
"not all items could be removed", the Windows Registry has 
trash in it which must be removed. All occurrences of 
Fontographer items in the Registry must be deleted. 
Macromedia Tech Support cannot be responsible for editing 
which users make to the Registry.  

2  Insert the Fontographer CD and drag the Fontographer 
setup.exe installer to the C: drive  

3  Restart the machine in Safe mode - i.e., holding down F8 while 
restarting. Or select NT VGA mode when restarting NT.  

4  Double-click the setup.exe installer  

5  Restart in normal mode  

If this doesn't work, reinstalling Windows has worked for some users. 

After the software has successfully installed, reboot the system again. Launch Fontographer (you'll need 
to reenter the serial number) and try working with Fontographer again, to see if the issue has been 
resolved. 

  

 

#15723: An error message appears reporting the 'exception in 
module 10h' 

Issue 

A message box appears reporting the "exception in module 10h" error. 

You may receive this error message when using any of the following printers: 

 Hewlett-Packard PhotoSmart Photo Printer. 

 Hewlett-Packard DeskJet 690 Series.  

 Hewlett-Packard DeskJet 870C. 

Note: The use of other Hewlett-Packard printers may trigger the problem as well. 
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#15783: FOG for Windows cannot generate Arabic fonts with 
character shape substitution  

Issue  
An Arabic font generated by the Windows version of Fontographer does not reliably display characters in 
text editors. 

Reason  
Arabic fonts include alternate shapes for some characters. Which alternate shape is used for a character 
of this sort will depend on the character's position in a word. These alternate character shapes are stored 
in Glyph Substitution (GSUB) tables. 

The Windows version of Fontographer was not designed to generate fonts that contain Glyph 
Substitution (GSUB) tables. Arabic TrueType fonts are an example of a specific TrueType format which 
Fontographer for Windows cannot reliably generate. 

Workaround  
You can create your outlines in Fontographer and process the generated font in another software. 

Reportedly, you can "assemble" a Fontographer-generated TrueType Arabic font using Microsoft's 
TrueType Open Assembler. Users have indicated that the resulting font will include a GSUB table that 
allows for character-shape substitution in an Arabic font. 

Note: Macromedia does not support third-party software, including, but not limited to, Microsoft font 
utilities. 

Many professional font designers use Fontographer to create their font outlines, regardless of which 
program they use for final processing. 

Fontographer for Macintosh  
Some users have been able to generate Arabic fonts using Fontographer for Macintosh; however, be 
aware that character shape substitution may still be unreliable. See the following TechNotes for more 
information about using Fontographer for Macintosh to create Arabic fonts: 

  Unrecognized characters in Macintosh Arabic fonts (TechNote 
13276)  

  International fonts for Macintosh (TechNote 13191)  

  Mideast keyboard layouts (TechNote 13223)  

Additional information  
For more information about Arabic and OpenType fonts, see the Microsoft article, "Creating and 
supporting OpenType fonts for Arabic scripts." 

Third party links 
Although links to external Web sites are provided as a resource, the Web sites are not part of 
Macromedia. Please see the Macromedia policy regarding links to third party Web sites in the Legal 
Notices and Information section. Pages to external Web sites will open in a new browser window. 

 

http://www.microsoft.com/typography/tools/tools.htm?fname=%20&fsize=
http://www.microsoft.com/typography/otspec/arabicot/summ.htm?fname=%20&fsize=
http://www.microsoft.com/typography/otspec/arabicot/summ.htm?fname=%20&fsize=
http://www.macromedia.com/help/copyright.html#disclaimer
http://www.macromedia.com/help/copyright.html#disclaimer
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#15928: Fontographer and OS X issues  

This TechNote addresses several issues regarding Fontographer and Macintosh OS X, including: 

 Floppy disks  
More recent Macintosh computers generally do not have floppy disk 
drives. If the computer does not have an internal floppy disk drive, 
an external floppy disk drive would be required for this installation .  

1  Restart your computer in Classic mode by choosing 
System Preferences and then click Classic. On the 
Start/Stop tab, select a startup volume for Classic. Then 
click Start. The Classic environment will launch.  

2  Insert the Fontographer floppy Disk One. 

3  In the installation window, double-click the Fontographer 
Installer icon.  

4  Click the Splash Screen to continue.  

5  In the Fontographer Install window, click the Show 
Custom Installations icon (located in the top left corner of 
the dialog box). 

6  In the Fontographer Install window, drag the 
"Fontographer 4.1.x" icon to the icon of your hard drive 
that you want to install Fontographer onto.  

7  Follow any additional instructions to complete 
installation. 

8  Click Quit to quit the installer.  
 

 Installation CD  

1  Restart your computer in Classic mode by choosing System 
Preferences and then click Classic. On the Start/Stop tab, select 
a startup volume for Classic. Then click Start. The Classic 
environment will launch.  

2  Insert the CD and double-click the Fontographer 4.x Installer. 

3  Inside the Fontographer window, double-click the 
Fontographer 4.x Installer.  

4  On the Fontographer splash screen, click Continue.  

5  Click Custom on the installation dialog box. 
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6  On the next dialog box, select the Fontographer 4.1.4 Non-
FPU version.  

  

 

7  Click Install.  

8  If you wish to change the installation location, navigate to find 
and select another location on the next dialog box. To accept 
the default location, click Install. 

9  Follow any additional instructions to complete installation.   

Note: Fontographer will only run on Macintosh OS X when the system has been set to the "Classic" 
environment 

 Fonts and Macintosh OS X 
Although Macintosh OS X can use the same TrueType and PostScript fonts that are used in previous 
Macintosh operating systems, OS X was designed to take advantage of the new OpenType font format. 
See Font installation in Macintosh OS X (TechNote 15818) for details on installing fonts. Refer to 
Macromedia product support for Mac OS X (TechNote 15224) for more information on Macromedia OS 
X product development. 
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Because OpenType fonts make use of additional data tables, Fontographer cannot generate OpenType 
fonts. However, the TrueType and PostScript fonts which Fontographer generates can be used in 
Macintosh OS X. 

Fontographer-generated fonts can be converted to OpenType fonts by using the font utilities found on 
Apple's Font tool page or by joining Adobe's OpenType Developer Program. 

Third party links 
Although links to external Web sites are provided as a resource, the Web sites are not part of 
Macromedia. Please see Macromedia's policy regarding links to third party Web sites in the Legal Notices 
and Information section. Pages to external Web sites will open in a new browser window. 

  

 

http://fonts.apple.com/Tools/
http://partners.adobe.com/asn/developer/type.html
http://www.macromedia.com/help/copyright.html#disclaimer
http://www.macromedia.com/help/copyright.html#disclaimer
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